Вопросы с тегом 'pip'

Вопросы относительно использования pip, установки пакета для Python.
2
ответа

apt-get install vs pip install

Я немного смущен тем случаями, когда вышеупомянутые команды должны использоваться при загрузке пакетов python. Я пытался загрузить пакет с именем pudev в соответствии с ответом с этим
задан 09.03.2014 в 16:51
5
ответов

Как определить и удалить пакеты Python, установленные через pip?

Я случайно установил пакеты Python в свою систему, используя pip вместо apt-get . Я сделал это двумя способами: , используя более старую версию virtualenv, я забыл добавить --no-site-packages при создании virtualenv - после этого, ког...
задан 08.08.2012 в 10:48
3
ответа

Ошибка при установке scrapy в virtualenv с помощью pip

pip install scrapy Downloading/unpacking scrapy Downloading Scrapy-0.24.2-py2-none-any.whl (502kB): 502kB downloaded Downloading/unpacking pyOpenSSL (from scrapy) Downloading pyOpenSSL-0.14.tar.gz (128kB): 128kB downloaded Running setup.py...
задан 19.07.2014 в 02:26
3
ответа

"фатальная ошибка: openssl / opensslv.h: нет такого файла или каталога" компиляция mitmproxy

Я пытаюсь установить пакет mitmproxy через pip следующим образом: $ sudo pip install mitmproxy Он заканчивается следующим сообщением об ошибке: x86_64-linux-gnu-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -fno-strict...
задан 11.07.2016 в 13:53
3
ответа

установка pip3 (для python3) на ubuntu 16.04 LTS с использованием прокси-сервера

Я попытался войти: sudo apt install python3-pip Ошибка, которую я получаю: $ sudo apt install python3-pip Reading package lists... Done Building dependency tree Reading state information... Done The following additional pac...
задан 27.05.2016 в 05:48
4
ответа

Как обновить приложение до последнего?

Я установил pip, используя get-pip.py , после того, как pip freeze выбрасывает ниже ошибки Exception: Traceback (most recent call last): File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 122, in main status = self.ru...
задан 22.12.2015 в 12:27
3
ответа

Как установить пакеты с помощью pip, когда есть несколько версий Python?

У меня установлены разные версии python, а python 2.7 - по умолчанию и 3.2 - второй. Теперь я хочу установить пирамиду на установку 3.2. Как я могу это сделать? Просто использование pip для установки пирамиды не работает, так как я могу измен...
задан 15.02.2012 в 20:18
2
ответа

Как установить pip для Python 3.6 на Ubuntu 16.10?

Я хотел бы начать с указания, что этот вопрос может показаться дубликат, но это не так. Все вопросы, которые я видел здесь на Ask Ubuntu, касались пипса для Python 3, и я говорю о Python 3.6. Шаги, используемые в то время, не работают для Python...
задан 04.03.2017 в 17:47
4
ответа

Является ли «sudo pip install» все еще нарушенной практикой?

Я новичок в Ubuntu, поэтому, пожалуйста, несите меня. Я установил pip , используя эту команду: sudo apt-get -y install python-pip . Затем я установил NLTK с помощью команды на своем веб-сайте, которая была: sudo pip install -U nltk . Но...
задан 25.07.2016 в 04:26
4
ответа

установить подушку на ubuntu 14.04

Я сумасшедший с подушкой. Я уже спрашиваю здесь, не решая: Ошибка Python Django Mezzanine для пакета Pillow У меня Ubuntu 14.04 и python 2.7. Установка подушки с использованием пипса или из github У меня есть эта ошибка: x86_64-lin...
задан 09.11.2014 в 22:12