Вопросы с тегом 'php7'

Вопросы, связанные с седьмым выпуском PHP, язык сценариев на стороне сервера, предназначенный для веб-разработки, который также может использоваться как язык программирования общего назначения
0
ответов

Установите PHP 7 в другую папку с установленным PHP 5.6

У меня есть экземпляр EC2 на Amazon AWS на основе «Bitnami Wordpress 4.4.2-1» AMI с «Ubuntu 14.04.4 LTS (GNU / Linux 3.13.0-77-generic x86_64)» в eu-west-1 (Ирландия). В этом AMI есть PHP 5.6 (php-fpm) с уже установленным Apache. Я хочу устан...
задан 08.10.2016 в 09:43
4
ответа

PHP отображается как текст после обновления Ubuntu 16.04

Apache предоставляет PHP-файлы в виде текста после обновления Ubuntu 16.04. Установлен и запущен Apache. Работает PHP7. Когда я выполняю следующую команду, я получаю правильный вывод: php -r 'echo "\n\nYour PHP installation is working fine...
задан 22.04.2016 в 21:32
0
ответов

Не удается запустить apache при включении php 7 (Ubuntu 16.04)

Я хочу, чтобы php работал, но когда я делаю sudo a2enmod php7.0 , а затем sudo service apache2 restart , я получу Job for apache2.service failed because the control process exited with error code. See "systemctl status apache2.service" and...
задан 13.08.2016 в 01:03
0
ответов

14.04 php7 install - Невозможно добавить PPA: 'ppa: ondrej / php'

Я хочу установить версию php 7 на Ubuntu 14.04. Я запускаю команду ниже (учетная запись root). # LC_ALL=C.UTF-8 add-apt-repository ppa:ondrej/php и результат. Cannot add PPA: 'ppa:ondrej/php'. Please check that the PPA name or forma...
задан 10.05.2016 в 03:46
1
ответ

Установить пакет Ubuntu, отсутствующий php7.0-sqlite3

Ubuntu с php7 Ошибка при попытке использовать SQLite3 из php: PHP Fatal error: Class 'SQLite3' not found in /var/www/html/index.php on line 1 Я попытался установить php7.0-sqlite3: $ sudo apt-get install php7.0-sqlite3 Reading pack...
задан 16.12.2016 в 20:11
2
ответа

Не удается загрузить динамическую библиотеку '/usr/lib/php/20151012/php_xmlrpc.dll'

Я установил Apache 2.4, PHP7 и установил SimpleXML, используя: apt-get install php-simplexml Затем я раскомментировал строку в php.ini для extension=php_xmlrpc.dll и перезапустил Apache. Мой apache.log говорит мне это: PHP...
задан 12.09.2017 в 16:26
2
ответа

PHP7 FPM отказался от запуска

Я все время получаю сообщение об ошибке на моем сервере Ubuntu 16.04 с PHP 7 FPM ERROR: fork() failed: Resource temporarily unavailable (11) Это приводит к тому, что ни один из моих сайтов не работает с ошибкой 502. ПРИМЕЧАНИЕ. Я испол...
задан 28.04.2016 в 14:08
1
ответ

PHP 7 - Невозможно загрузить динамическую библиотеку - curl.so

Я использую phpunit для запуска модульных тестов, и все хорошо и dandy. То есть, пока тест не должен использовать Curl. В этот момент я получаю эту ошибку:    PHP Предупреждение: запуск PHP: невозможно загрузить динамическую библиотеку...
задан 24.11.2016 в 14:46
1
ответ

Как перенести с PHP 5.5. * на PHP 7.0. * и обновить весь стек LAMP на операционной системе Ubuntu Linux 12.04 LTS (64-разрядной)?

Я использую Ubuntu 12.04 LTS (64-разрядная) операционная система на своей локальной машине. Я уже установил стек LAMP (Linux, Apache, MySQL и PHP) на моей локальной машине. После выполнения следующих команд с терминала я получил соответств...
задан 05.03.2016 в 05:54
1
ответ

Когда PHP 7.1 будет доступен в официальных репозиториях? [закрыто]

Я знаю, что я могу установить любую версию PHP, используя здесь ответ: Как установить другую (обновленную или понижающую) версию PHP в поддерживаемой версии Ubuntu? Я запускаю сервер Ubuntu 16.04 LTS и не спешу обновлять, но не смог найти н...
задан 29.05.2017 в 04:27