Вопросы с тегом 'php7'

Вопросы, связанные с седьмым выпуском PHP, язык сценариев на стороне сервера, предназначенный для веб-разработки, который также может использоваться как язык программирования общего назначения
9
ответов

Как установить PHP 7?

PHP 7 вышел вчера , и я хотел бы попробовать.    PHP 7.0.0 поставляется с новой версией Zend Engine, многочисленными улучшениями и новыми функциями, такими как       Повышенная производительность: PHP 7 до двух раз быстрее, чем PHP 5.6   ...
задан 04.12.2015 в 15:13
4
ответа

Установка PHP 5.6 на Xenial (16.04) [дубликат]

Мне нужно использовать php5 (5.6), потому что я работаю над проектом Drupal 7, который не поддерживает php7. Проблема в том, что я недавно обновился до ubuntu 16.04 Xenial, который кажется больше не поддерживают php5 . Я попытался установи...
задан 11.04.2016 в 11:45
3
ответа

как установить imagemagick для php7 на ubuntu 16.04?

Хорошо, сразу после обновления моего Ubuntu и, следовательно, перехода на php7, я, похоже, не могу установить расширение imagick для php, используя ту же самую старую команду sudo apt-get install php5-imagick Я получаю эту ошибку (пробова...
задан 08.05.2016 в 18:54
1
ответ

Переход к определенному php 7.1 / 7.2 с php 7.0 в Ubuntu 16.04 [duplicate]

Как я могу перейти на php 7.1 с php 7.0 в ubuntu 16.04? Если я делаю php -v , я получаю это сообщение: PHP 7.0.8-0ubuntu0.16.04.3 (cli) ( NTS ) Copyright (c) 1997-2016 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Tech...
задан 04.12.2016 в 09:21
9
ответов

Установить laravel 5 на Ubuntu 16.04

Кто-нибудь установил laravel 5 на Ubuntu 16.04? Я только что перешел на Ubuntu 16.04, и я пытаюсь установить larvel 5 framework на нем, используя композитор. Но каждый раз, когда я пытаюсь создать проект, он дает мне этот erros Your requireme...
задан 29.04.2016 в 09:40
4
ответа

PHP отображается как текст после обновления Ubuntu 16.04

Apache предоставляет PHP-файлы в виде текста после обновления Ubuntu 16.04. Установлен и запущен Apache. Работает PHP7. Когда я выполняю следующую команду, я получаю правильный вывод: php -r 'echo "\n\nYour PHP installation is working fine...
задан 22.04.2016 в 21:32
5
ответов

Как установить расширение Mongodb PHP в Ubuntu 16.04 LTS

Я запускаю Ubuntu 16.04 LTS, и я хочу использовать Mongodb с PHP. Для этого я подумал, что sudo apt-get install php5-mongo (которого достаточно для Ubuntu 14.04 LTS) будет достаточно, но я ошибся. Я получаю ошибку, например, E: Unable to loc...
задан 29.04.2016 в 23:01
1
ответ

Как установить php 7 для запуска рядом с php 5 на ubuntu с nginx

Я хочу попробовать php 7 и заставить мой сайт работать на php 7 в то же время, чтобы на всякий случай поддерживать другие сайты, работающие на php 5. так что из конфигурации виртуального хоста домена я могу решить, какой php запускать. Я посм...
задан 23.03.2016 в 07:31
2
ответа

Можно ли установить phpize для PHP7 Ubuntu16.04?

Я пытался установить xdebug в свой Ubuntu16.04 с PHP7.0-fmp. Внутри специализированного инструмента он говорит: Run: phpize (See the FAQ if you don't have phpize. As part of its output it should show: Configuring for: ... Zend Module Api...
задан 02.09.2016 в 01:00
1
ответ

Более короткий способ apt-get install php7.0- {some modules}

В настоящее время я устанавливаю php7.0 и задаюсь вопросом, существует ли более короткий способ установки модулей. обычно я печатаю: apt-get install php7.0 php7.0-fpm php7.0-mbstring php7.0-mcrypt php7.0-phpdbg php7.0-dev php7.0-cur...
задан 12.06.2016 в 14:58