Как мне получить плагин Java, работающий в Google Chrome?

62

Google обновил свой браузер Chrome до версии 35. Эта новая версия использует Aura вместо GTK2 и больше не поддерживает плагины NPAPI, такие как Java (как OpenJDK, так и Oracle) , Плагины PPAPI, такие как PepperFlash, все еще работают.

Моя школа ежедневно использует Google Chrome и приложения Google, и это выглядит потенциально большой проблемой для некоторых образовательных сайтов, которые мы используем. Кто-нибудь сталкивается с решением или обходным путем для работы Java?

В этой статье WEB UPD8 подтверждается, что Java не работает .     

задан HarlemSquirrel 22.05.2014 в 14:02
источник

2 ответа

56

Вы не можете заставить Java работать с Chrome 35. Из-за удаления старого плагина NPAPI. Я поднял отчет об ошибке. Ожидание надлежащего ответа от разработчиков. Отчет об ошибках находится здесь: Ссылка . Вы можете попробовать и следить за темой для обсуждения здесь: Ссылка

UPDATE Похоже, мы собираемся застрять здесь довольно долго. Мой отчет об ошибке был объединен с родительской ошибкой, и он был установлен так, как не будет исправлено. Вот он: Ссылка

UPDATE2 Соответствующий вопрос был отправлен в Oracle. Не так много тяги. Вы, ребята, можете начать обсуждение этой темы. Перейдите сюда: Ссылка

Для всех вас: Чтобы поддерживать работу Chrome, перейдите на Google Chrome на 34. Вы можете скачать deb здесь: Ссылка . Затем используйте диспетчер синаптических пакетов или используйте командную строку для блокировки обновлений для пакета, защищенного Google-хромом. В Chrome 34 нет ярких ошибок, поэтому вы можете безопасно использовать их в течение следующих 3 месяцев. Я надеюсь, что к этому времени будет добавлен некоторый патч.

    
ответ дан Ubuntuser 22.05.2014 в 20:38
источник
2

Вы CAN , чтобы заставить Java работать в Chrome, или, по крайней мере, включить плагин NPAPI для него ... временно. Этот вариант полностью удаляется в Chrome 45. (В настоящее время мы находимся в 43, оценка - сентябрь 2015 года.)

Обратите внимание, что включение NPAPI не обязательно означает, что Java-апплет будет работать ... Я попробовал его с одним, и это не так. Вероятно, это связано с тем, что установлена ​​последняя версия Java, которая в любом случае блокирует любой доступ к сети. Какой позор, так как было создано множество отличных веб-сервисов Java (таких как Ссылка .)

В любом случае опция включения NPAPI находится при просмотре:

chrome://flags/#enable-npapi

Опять же, ваш пробег может меняться (YMMV.)

    
ответ дан rdtsc 15.06.2015 в 17:46