Уникальная пусковая установка, показанная над Dota 2 в полноэкранном режиме

11

Каждый раз, когда я запускаю dota 2 на моем компьютере под управлением 13.10, он выглядит так:

Боковые и верхние бары не исчезают, даже если игра находится в полноэкранном режиме. У меня только эта проблема с dota 2, все остальные игры прекрасно работают в полноэкранном режиме. Я попытался войти в настройки и включить ярлык, который заставляет полноэкранный режим, но ничего не происходит, когда я нажимаю ярлык. есть ли способ исправить это или заставить ubuntu войти в полноэкранный режим?

Эта проблема связана только с Dota 2, а не с другими полноэкранными приложениями / играми.

    
задан Qwertie 29.12.2013 в 10:56
источник

5 ответов

18

Мне удалось перейти к настройкам в игре и изменить настройку окна с границы меньше на полноэкранный. Dota 2 теперь работает в полноэкранном режиме.

    
ответ дан Enjoy87 21.01.2014 в 18:08
источник
3

Измените окно без полей на полноэкранный режим в настройках Dota 2 (видео).

    
ответ дан Dan 14.01.2014 в 22:59
1

В паре, щелкните правой кнопкой мыши Dota 2, перейдите к свойствам - > установите параметры запуска. В texbox типа "-fullscreen" (без кавычек). Перезапустите Dota 2.

    
ответ дан Chiel ten Brinke 26.08.2015 в 17:51
0

Другие решения не сработали для меня, поэтому для других, у кого может быть эта проблема, вот что я сделал.

В Диспетчере настроек CompizConfig выберите Утилита > Обходные пути и отключить Поддержка полноэкранного режима Legacy .

Затем перезагрузите компьютер.

    
ответ дан tk55 01.02.2015 в 16:09
0

Мне лично не нравилось ходить на полный экран, мне нравится быть в состоянии взаимодействовать с другим монитором, не теряя внимания к моей игре. Я также хотел, чтобы моя пусковая установка была на мониторе слева от меня, но игра на моем мониторе вправо (полный экран не позволяет вам делать.)

Единственный откат до сих пор заключается в том, что я не могу получить окно, чтобы нарисовать верхнюю строку меню Unity, чтобы вы в итоге приносили в жертву 20 пикселей в высоту.

Решение для меня состояло в том, чтобы установить следующие параметры запуска в паре.

  1. Щелкните правой кнопкой мыши Dota2 в вашей паровой библиотеке.
  2. Нажмите Set Launch Options
  3. Добавьте следующие -h 1180 -w 1920 -x 1280 -y 0 -noborder
    • -w должно быть шириной монитора, который вы хотите использовать.
    • -h должно быть высотой окна, я не мог избавиться от строки меню, поэтому я вычитал ее высоту (20 пикселей для меня) с высоты игры.
    • -x должно быть смещением вашего второго монитора (мой второй монитор имеет ширину 1280px
    • -y - это смещение сверху, так как строка меню не учитывается, я устанавливаю ее в 0, ее даже не требуется включать
    • -noborder должен указывать доте, что игра должна быть запущена как безболезненное окно, но это не так, я должен был делать шаги с 7 по 10. Этот параметр может оказаться непригодным
  4. Нажмите OK
  5. Нажмите Close
  6. Запустить Dota2
  7. Нажмите Settings Cog
  8. Нажмите Video Options
  9. Установите Display Mode в Borderless Window
  10. Нажмите apply (возможно, вам потребуется перезапустить игру здесь)

Если вы используете настройку одного монитора или хотите, чтобы игра находилась на том же мониторе, что и ваша пусковая установка, примените те же самые принципы, просто скорректируйте варианты -w и -y для размещения, однако вы также будете быть сакрафизирующим вашу ширину, а также ваш рост.

На данный момент я думаю, что это лучшее, что вы можете сделать.

Это говорит о том, что у нового клиента перерождения есть дополнительная опция в настройках видео, чтобы ваша полноэкранная игра не сворачивалась, когда она теряла фокус. Я не играл с ним много, но это означает, что ваша пусковая установка не будет доступна (насколько я мог бы сказать в моем ограниченном тестировании), поскольку игра все равно будет запущена на доминирующем мониторе, на который назначена пусковая установка.

    
ответ дан JaredMcAteer 11.08.2015 в 01:33