Установить bison 2.7 в Ubuntu 14.04

11

Когда я пытаюсь установить bison на моем ubuntu 14.04 с помощью команды sudo apt-get install bison , будет установлена ​​версия 3.

Я хотел бы понизить уровень бизона, чтобы использовать версию 2.7.

Как я могу это сделать?

Спасибо.

    
задан Bechir 08.04.2014 в 14:00
источник

4 ответа

21

Я установил последние pkgs bison (2.7.1) и libbison-dev (2.7.1) из Saucy, и он работал как шарм.

wget http://launchpadlibrarian.net/140087283/libbison-dev_2.7.1.dfsg-1_amd64.deb
wget http://launchpadlibrarian.net/140087282/bison_2.7.1.dfsg-1_amd64.deb
dpkg -i libbison-dev_2.7.1.dfsg-1_amd64.deb
dpkg -i bison_2.7.1.dfsg-1_amd64.deb

Чтобы программа обновления не перезаписывала этот пакет

apt-mark hold libbison-dev
apt-mark hold bison    

Готово.

    
ответ дан Bruno Souza 06.05.2014 в 21:27
источник
4

Просто укажите версию пакета следующим образом:

apt-get install pkg=version

, и вы можете получить все доступные версии, используя apt-cache showpkg bison

    
ответ дан Stormvirux 08.04.2014 в 14:05
2

Вы можете установить версию bison 2.7 через linuxbrew . Как только вы установили linuxbrew, выполните следующие действия:

ruby -e "$(wget -O- https://raw.github.com/Homebrew/linuxbrew/go/install)"

и добавив следующее к нижней части .bashrc или .zshrc:

export PATH="$HOME/.linuxbrew/bin:$PATH"
export LD_LIBRARY_PATH="$HOME/.linuxbrew/lib:$LD_LIBRARY_PATH"

Вы можете установить Bison 2.7!

brew install bison27

Homebrew предназначен для macs, поэтому он будет кричать на вас, если вы не используете свой Mac правильно, если вы запустите врача-пивовара. Поскольку у Mac уже установлен Bison, он откажется закончить установку. Вы можете безопасно заставить это сделать:

brew link bison27 --force

И теперь проверьте bison -V, чтобы увидеть, что вы используете Bison 2.7!

    
ответ дан iggyvolz 15.08.2014 в 19:59
1

bison2 (2: 2.7.1.dfsg-1-ppa1) доступен из моего ppa здесь     

ответ дан RJVB 06.08.2014 в 16:26