Плагин DDS для GIMP

1

Итак, я использую tyring для установки этого . DDS подключается к gimp. Я делал это раньше, но в этой новой установке Ubuntu я терпеть неудачу.

Я извлекаю архив, затем нажимаю make. Это приводит к:

[email protected]:~/gimp-dds-3.0.1$ make
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing 'gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
Package gimp-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing 'gimp-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gimp-2.0' found
[CC]    dds.c
dds.c:27:21: fatal error: gtk/gtk.h: No such file or directory
 #include <gtk/gtk.h>
                 ^
compilation terminated.
make: *** [dds.o] Error 1
[email protected]:~/gimp-dds-3.0.1$ 

Итак, я пропускаю пакет gtk + -2.0. Этого я не могу найти ни в программном центре, ни в Synaptic.

    
задан user234982 05.09.2015 в 12:31
источник

1 ответ

3

Ответы находятся в сообщениях об ошибках

  • GTK + -2.0

      

    Возможно, вам следует добавить каталог, содержащий «gtk + -2.0.pc», в   PKG_CONFIG_PATH переменная среды Нет найденного пакета gtk + -2.0

    поэтому

    sudo apt-get install libgtk2.0-dev
    

    Почему?

    % apt-file search gtk+-2.0.pc
    libgtk2.0-dev: /usr/lib/x86_64-linux-gnu/pkgconfig/gtk+-2.0.pc
    
    % apt-cache search libgtk2 | grep dev
    libgtk2.0-cil-dev - CLI binding for the GTK+ toolkit 2.12
    libgtk2.0-dev - development files for the GTK+ library
    
    % apt-file search --regex gtk/gtk.h$
    libgtk-3-dev: /usr/include/gtk-3.0/gtk/gtk.h
    libgtk2.0-dev: /usr/include/gtk-2.0/gtk/gtk.h
    
  • каркасная-2,0

      

    Пакет gimp-2.0 не найден в пути поиска pkg-config.   Возможно, вам следует добавить каталог, содержащий «gimp-2.0.pc»

    поэтому

    sudo apt-get install libgimp2.0-dev
    

    Почему?

    % apt-file search gimp-2.0.pc        
    libgimp2.0-dev: /usr/lib/pkgconfig/gimp-2.0.pc
    
    % apt-cache search libgimp | grep dev
    libgimp2.0-dev - Headers and other files for compiling plugins for GIMP
    
ответ дан A.B. 05.09.2015 в 12:41