Wine 1.7 не устанавливается на Xubuntu 15.10

12

Итак, после настройки моей установки Xubuntu вчера, я попытался установить Wine 1.7 с помощью ppa: ubuntu-wine / ppa. Однако после выполнения sudo apt-get install wine1.7 он продолжает давать мне эту ошибку:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.7 : Depends: wine1.7-amd64 (= 1:1.7.44-0ubuntu1) but it is not going to be installed
           Depends: wine1.7-i386 (= 1:1.7.44-0ubuntu1)
E: Unable to correct problems, you have held broken packages.

Я пробовал несколько решений, которые я нашел в Интернете, например, автовосстановление, добавление архитектуры i386, очистка моих пакетов и исправление моей установки apt-get. Однако, попробовав все решения, которые я смог найти, wine1.7 все еще не устанавливает. Я не уверен, что это ошибка моего компьютера или ошибка ppa, но если другие могут поделиться своими находками, это было бы здорово.

Спасибо, Elly

Как запрошено, вот результат для apt-cache policy wine1.7 wine1.7-amd64 wine1.7-i386 :

wine1.7:
  Installed: (none)
  Candidate: 1:1.7.44-0ubuntu1
  Version table:
     1:1.7.44-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ wily/main amd64 Packages
wine1.7-amd64:
  Installed: (none)
  Candidate: 1:1.7.44-0ubuntu1
  Version table:
     1:1.7.44-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ wily/main amd64 Packages
wine1.7-i386:i386:
  Installed: (none)
  Candidate: 1:1.7.44-0ubuntu1
  Version table:
     1:1.7.44-0ubuntu1 0
        500 http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu/ wily/main i386 Packages  

и выход для sudo apt-get install wine1.7-amd64 wine1.7-i386 :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine1.7-amd64 : Depends: libgphoto2-port10 (>= 2.5.2) but it is not installable
                 Recommends: libgnutls26 but it is not installable
                 Recommends: wine-gecko2.34 but it is not installable
                 Recommends: wine-mono4.5.4 but it is not installable
 wine1.7-i386:i386 : Depends: libgphoto2-port10:i386 (>= 2.5.2) but it is not installable
                     Recommends: libgnutls26:i386 but it is not installable
                     Recommends: libpcap0.8:i386 but it is not going to be installed
                     Recommends: wine-gecko2.34:i386 but it is not installable
                     Recommends: wine-mono4.5.4:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.
    
задан Elly 23.10.2015 в 20:48
источник

6 ответов

6

Необходимые пакеты в настоящее время недоступны для Wily. Проверьте эту отфильтрованную страницу .

Подождите несколько дней, и пакеты Wily, вероятно, будут доступны. Тем временем установите пакеты Vivid:

wget http://mirrors.kernel.org/ubuntu/pool/main/libg/libgphoto2/libgphoto2-port10_2.5.4-1.1ubuntu1_i386.deb
wget http://mirrors.kernel.org/ubuntu/pool/main/libg/libgphoto2/libgphoto2-port10_2.5.4-1.1ubuntu1_amd64.deb
sudo dpkg -i libgphoto2-port10*.deb
sudo apt-get install -f
sudo apt-get install wine1.7
    
ответ дан A.B. 23.10.2015 в 21:21
источник
10

Зависимость, с которой он не работает, составляет libgphoto2-port10 , что не является Wily. Вы можете попробовать вручную установить DEB-файлы из Trusty:

Ссылка

    
ответ дан D. B. 29.10.2015 в 01:09
4

Вы по-прежнему можете использовать PlayOnLinux в (X) Unbuntu 15.10.

С PlayOnLinux вы создаете (и безопасно удаляете) «виртуальные диски» (в /home/{user}/.PlayOnLinux/wineprefix/) с различными версиями Wine и разными настройками.

В репозитории 15.10:

sudo apt-get install playonlinux

В программе: Меню - > Инструменты - > Управление версиями вин

Вы можете установить версии Wine (x86 или x64), которые вам нужны, в том числе 1.7 (последняя версия 1.7.54), а затем использовать в «виртуальных дисках».

Программы из виртуальных дисков PlayOnLinux вы можете запускать следующим образом:

/usr/share/playonlinux/playonlinux --run "Evernote.5.8.13"

И, конечно, вы можете добавить запись .desktop в /home/{user}/.local/share/applications/

Имхо, в любом случае, это более удобно, чем чистое вино.     

ответ дан Viktor 07.11.2015 в 14:23
2

Начиная с Ubuntu 15.10 (Wily Werewolf) и Debian 8, вы можете установить пакет wine-development, без каких-либо дополнительных ppa, который устанавливает последнюю версию разработки.

После установки будут доступны следующие исполняемые файлы: wine-development, winecfg-development, и т. д .; вместо традиций wine, winecfg, и т. д.

Update

Выпущено вино 1.8 и 1.9; и доступны для Ubuntu 15.10 Wily Werewolf. Чтобы установить их, вы можете добавить новый ppa, созданный вином theam:

sudo add-apt-repository ppa:wine/wine-builds
sudo apt-get update
sudo apt-get install --install-recommends winehq-devel

Для получения дополнительной информации вы можете посмотреть раздел Ubuntu в официальной винной вики .

    
ответ дан Luisg123v 18.11.2015 в 22:24
0

Если вам не нужна самая последняя версия Wine, вы всегда можете просто сделать:

sudo apt-get install wine winetricks
    
ответ дан user464336 23.10.2015 в 22:21
0

Если установка вина завершилась неудачно с разбитыми зависимостями, например

wine : Depends: wine1.6 but it is not going to be installed

и пытается установить wine1.6 , покажите, что это зависит от libgphoto2-6:i386 , который затем зависит от не устанавливаемого libgphoto2-port10:i386 , а попытка установить libgphoto2-port10:i386 удалит версию AMD64 вместе с libsane и некоторые другие пакеты, то вы, вероятно, отключили « Рекомендуемые обновления » в конфигурации Software Sources (например, я проверил только « Важные обновления безопасности » и все остальное не отмечено).

Как только я снова включил « Рекомендуемые обновления », я успешно установил вино.

    
ответ дан Ruslan 22.05.2016 в 18:18