Как установить пакет Adobe Acrobat Reader deb, загруженный с сайта Adobe?

90

Я новичок в Ubuntu, но считаю, что Ubuntu 11.10 установлен правильно. Я пытаюсь установить Acroread, используя AdbeRdr9.4.6-1_i386linux_enu.deb , которую я загрузил с веб-сайта Adobe. Как это сделать?

    
задан ubuntu_rookie 20.12.2011 в 04:56
источник

7 ответов

82

Все версии Ubuntu до 13.10

Чтобы установить Adobe Acrobat, вам нужно включить репозиторий canonical partners на вкладке «Источники программного обеспечения» диспетчера обновлений

Используйте Dash и выполните поиск Источники программного обеспечения или Программное обеспечение и amp; Обновления в 13.04 и более поздних версиях.

Если вы не видите эти параметры в Software Sources, вы можете использовать следующую команду из терминала:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"

Затем в терминале вы можете обновить и установить программу чтения acrobat:

sudo apt-get update
sudo apt-get install acroread

Настоятельно рекомендуется с точки зрения безопасности использовать версию в репозиториях.

Если - по какой-либо причине - вы хотите загрузить непосредственно из Adobe и установить, то применяются следующие инструкции:

Используя firefox, перейдите к:

Выберите следующие параметры, как показано на картинке - скажем, пакет .deb

При нажатии кнопки «Загрузить»:

Оставьте его по умолчанию для открытия в Software Center, где вы можете его установить.

Если вы установили, что ваши загрузки автоматически сохраняются в папке «Загрузки»:

cd ~/Downloads
sudo dpkg -i AdbeRdr*.deb
    
ответ дан fossfreedom 20.12.2011 в 10:59
77

ПЕРЕСМОТРЕННЫЙ: 2016-ноябрь ( только незначительная формулировка )

Для Ubuntu 14.04 LTS, 16.04 LTS и 16.10, 32- или 64-разрядных

[адаптирован: Ссылка ]

Adobe Reader 9 не находится в репозитории «Партнер» для 13.10 (или более поздней версии).

  1. Загрузите Adobe Reader (32-разрядный), с сайта Adobe :

    Отсюда: ftp. adobe.com .. читатель .. 9.5.5

    Проверьте MD5SUM после загрузки, введите

    md5sum AdbeRdr9.5.5-1_i386linux_enu.deb
    

    вывод должен быть

    88036c68998d565c4365e2ad89b04d51 AdbeRdr9.5.5-1_i386linux_enu.deb
    
  2. Откройте командную строку, перейдите в каталог, содержащий файл .deb .

  3. Установить пакет, заставляя принимать 32-битную версию и любые ошибки:

    sudo dpkg -i --force-architecture AdbeRdr9.5.5-1_i386linux_enu.deb
    sudo apt-get -f install
    
  4. Добавьте отсутствующие 32-разрядные библиотеки: ( пропустите этот шаг для 32-разрядного )

    sudo apt-get install libxml2:i386 lib32stdc++6
    
  5. (Необязательно) Запустите в первый раз, чтобы получить значок в строке меню Unity.

    acroread <path>/<MyDocument>.pdf
    

Для Ubuntu 12.04 LTS

  1. Добавить репозиторий «Канонический партнер»

    sudo add-apt-repository "deb http://archive.canonical.com/ubuntu $(lsb_release -sc) partner"
    
  2. Обновите свою систему

    sudo apt-get update
    
  3. Установите Adobe Reader и расширения шрифтов

    sudo apt-get -y install acroread acroread-fonts
    
  4. (Необязательно) Запустите в первый раз, чтобы получить значок в строке меню Unity.

    acroread <path>/<MyDocument>.pdf
    
ответ дан david6 20.12.2011 в 05:05
8

Для saucy (13.10) вы можете включить резидентный резидентный репозиторий. Вот как я это сделал:

sudo echo -e '# for acroread\ndeb http://archive.canonical.com/ubuntu/ raring partner' > /etc/apt/sources.list.d/raring-partner.list
sudo apt-get update
sudo apt-get install acroread

apt-cache show acroread
# Package: acroread
# Architecture: amd64
# Version: 9.5.5-1raring1
# Depends: debconf (>= 0.5) | debconf-2.0, acroread-bin, nspluginwrapper
# [...]

apt-cache policy acroread
# acroread:
#   Installiert:           9.5.5-1raring1
#   Installationskandidat: 9.5.5-1raring1
#   Versionstabelle:
#  *** 9.5.5-1raring1 0
#         500 http://archive.canonical.com/ubuntu/ raring/partner amd64 Packages
#         100 /var/lib/dpkg/status
    
ответ дан MoreIT 22.01.2014 в 13:41
1

Вы можете сделать:

# sudo dpkg -i AdbeRdr9.4.6-1_i386linux_enu.deb

Но я рекомендую evince как лучший PDF-ридер. Это значение по умолчанию в кванте.

    
ответ дан Óscar García Amor 06.11.2012 в 12:41
1

Теперь Acroread доступен в репозитории партнеров Quantal.

См. эту ошибку Launchpad:

В заголовке указано Точное значение, но оно относится к точным, квантовым и ржавым.

    
ответ дан Mark Russell 12.03.2013 в 21:26
1

Кажется, что Adobe не будет поддерживать Linux в ближайшем будущем (см. post здесь ), если только увеличение количества пользователей Linux, запрашивающих поддержку. Это можно сделать, заполнив следующую форму запроса функции Adobe: Форма запроса / отчета об ошибке .

В качестве альтернативы вам может потребоваться перейти на Foxit или master pdf читатели, которые на самом деле быстрее открывают и предоставляют больше бесплатных функций, чем Adobe Reader.     

ответ дан Theodoros P. 02.03.2017 в 14:51
1

Ubuntu 16.10 на amd64, кажется, требует

sudo apt-get -f install
sudo apt-get -y install adobereader-enu

Без i386 в 64-битном env acroread дает ошибки file not found и GTK, поэтому выполните:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get -y install libc6:i386 libncurses5:i386 libstdc++6:i386 libglib2.0-0:i386 libsoup2.4-1:i386 libgtk2.0-0:i386
sudo apt-get -y install libicu-dev:i386 gtk2-engines-murrine libcanberra-gtk-module:i386 gtk2-engines-murrine:i386

Это может быть избыточным, поскольку основной бит i386

sudo apt-get -y install gtk2-engines gtk2-engines-* libgtkmm-2.4-1c2 libcanberra-gtk-module
    
ответ дан jtm 14.04.2017 в 07:14