«Требовать установку ненадежных пакетов» при обновлении с помощью диспетчера обновлений

63

Ошибка не исправлена. Итак, как мне исправить мое обновление графического интерфейса?

Для каждого программного обеспечения я должен установить его из командной строки, потому что я получил ту же ошибку при установке программного обеспечения из Ubuntu Software Center.

    
задан One Zero 29.03.2012 в 13:55
источник

7 ответов

62
  1. Запишите в терминал: sudo apt-get update && sudo apt-get upgrade или отредактируйте настройки диспетчера обновлений (сначала попробуйте это, если вы уже настроили диспетчер обновлений).

  2. Запустите диспетчер обновлений и повторите попытку.

Запуск обновления через терминал дает возможность разрешить или запретить недоверенные пакеты.

WARNING: The following packages cannot be authenticated!
  playonlinux
Install these packages without verification [y/N]?

Если вы доверяете источнику пакета, введите y .

    
ответ дан Zlatan 29.03.2012 в 19:14
источник
43

Это происходит из-за отсутствия некоторых ключей GPG. Чтобы исправить это, откройте терминал и запустите следующие команды:

sudo apt-get update

Вы получите сообщение о том, что какой-то открытый ключ недоступен. Обратите внимание на строку ключа (после NO_PUBKEY, например: D6B6DB186A68F637)

 gpg --keyserver keyserver.ubuntu.com --recv XXXXX

Замените XXXXX ключевой строкой

например: gpg --keyserver keyserver.ubuntu.com --recv D6B6DB186A68F637

gpg --export --armor  XXXXX | sudo apt-key add -

например: gpg --export --armor D6B6DB186A68F637 | sudo apt-key add -

sudo apt-get update

Теперь попробуйте обновить систему еще раз.

Вот аналогичная статья: «Требуется установить ненадежные обновления» Ошибка в диспетчере обновлений

Надеюсь, что это поможет.

    
ответ дан aneeshep 01.12.2010 в 10:05
13

Вы можете установить его через командную строку: sudo apt-get install --allow-unauthenticated exiv2 .

Чтобы постоянно «доверять» репо, выполните следующее: sudo apt-add-repository ppa:pmjdebruijn/darktable-release && sudo apt-get update . Я считаю, что это PPA, который вы используете.

    
ответ дан evgeny 01.12.2010 в 10:12
5

В ответ на ваш вопрос вы не можете "исправить" обновление графического интерфейса (т. е. диспетчер обновлений), поскольку очевидно, что в настоящее время у этого приложения нет возможности устанавливать ненадежные пакеты. Если вы хотите установить ненадежные пакеты, вы должны сделать это в командной строке.

Однако есть два способа остановить диспетчер обновлений от сообщения об этой ошибке: либо удалить ненадежное программное обеспечение из вашей системы, либо доверие рассматриваемого репозитория, как указано в ответе на другой вопрос ( Обновления не устанавливаются из-за "ненадежных пакетов" ) .

Первый шаг - выяснить, какой репозиторий вызывает проблему. Вы можете найти это, набрав apt-cache policy ambiance-colors в командной строке.

Однако, быстрый google показывает, что ambiance-colors и radiance-colors от ppa:ravefinity-project . Поэтому вы должны решить проблему, набрав

sudo add-apt-repository ppa:ravefinity-project/ppa
sudo apt-get update
sudo apt-get install ambiance-colors radiance-colors

взято из Ссылка

    
ответ дан stackex humanoid 10.06.2012 в 22:06
1

почему это так говорит, пакеты, которые вы пытаетесь установить, - это стороннее программное обеспечение. Если вы хотите установить их, включите Canonical флажок на другой вкладке программного обеспечения в настройках диспетчера обновлений, а затем повторите попытку установка.

надеюсь, что это поможет.     

ответ дан Ten-Coin 29.03.2012 в 19:21
0

Ваш вопрос непонятен: вы исправляете обновление своего графического интерфейса, исправляя ошибку. Другой вопрос покажет вам, что делать.

Вы можете отменить выбор любого из ваших обновлений, опираясь на ненадежный источник, или вы можете продолжить использование командной строки, чтобы постоянно доверять этому конкретному источнику. Как только вы выполните одно из этих действий, сообщение не появится. Если вы сделаете последнее, сообщение больше не появится снова для этого конкретного источника.

    
ответ дан Mei 29.03.2012 в 19:04
0

У меня была та же проблема. Для меня эта команда работала:

sudo apt-get update --fix-missing

Преимущество этого по сравнению с другими решениями - его простота. Вы можете продолжать использовать графический интерфейс и не нужно выяснять, какой репозиторий поврежден. Я нашел решение здесь в комментарии. Я не знаю, что Ubuntu достаточно, чтобы объяснить, но я полагаю, что он получает ключи, необходимые для работы всех РЕПО.

    
ответ дан smoortema 20.09.2013 в 10:58