Разметка клавиатуры переключается на английский при каждом перезагрузке

64

Я только что установил Ubuntu 13.10 и действительно наслаждаюсь им. Я из Дании и использую поддерживаемую датскую раскладку клавиатуры (и выбрал ее по умолчанию в установке), но всякий раз, когда я перезагружаюсь, Ubuntu переключается на английский раскладку клавиатуры, хотя маленький значок в панели говорит, что он находится на датском языке. Я должен каждый раз щелкнуть значок, чтобы изменить его на датский. Я попытался удалить английскую раскладку клавиатуры, но это не помогло. Какие-либо предложения?     

задан Dennis Rasmussen 21.10.2013 в 12:03
источник

7 ответов

31

Я итальянец, и у меня была такая же проблема, как и вы вчера вечером. Я тоже пришел в эту ветку, но я не нашел решения.

Стандартная макетная клавиатура была выбрана как итальянская, но при каждой загрузке «переключилась на английскую раскладку клавиатуры, хотя маленький значок на панели говорит, что это было на итальянском языке. Я должен каждый раз нажимать на значок, чтобы изменить его на Я попытался удалить английскую раскладку клавиатуры, но это не помогло ». Это было разочарование.

Я решил, что проблема изменилась с помощью текстовых настроек:

кэтим,этоотличноработаетдляменя:

Теперь моя раскладка клавиатуры по умолчанию является итальянской и работает по-итальянски по умолчанию, а не по-английски. Теперь мне не нужно каждый раз щелкнуть значок, чтобы изменить его на итальянский. Надеюсь, это поможет вам.

    
ответ дан Francesco Marmo 22.10.2013 в 09:34
15

(Обновлено 2014-05-28, благодаря комментарию Бернарда Декоха.)

В программном центре ubuntu установите «dconf Editor» ( dconf-editor ) (если у вас его еще нет). Откройте его, затем откройте рабочий стол - > ibus - > генеральный. Теперь включите свойство «use-system-keyboard-layout». (Вы хотите, чтобы рядом с ним была отметка.)

Источник: Ссылка

    
ответ дан Steve Byrnes 02.04.2014 в 16:25
10

Вот как я это решил (для меня, по крайней мере, работает 14.04):

В терминале введите ibus-setup , откроется окно IBus Preferences . На вкладке Дополнительно установите флажок «Использовать системную раскладку клавиатуры», как показано на скриншоте ниже.

    
ответ дан Alessandro Cuttin 01.08.2014 в 11:10
6

У меня была та же проблема, с Ubuntu 13.10, и после ее использования несколько недель, моя раскладка клавиатуры внезапно начала меняться с испанского на английский каждый раз, когда я вхожу в систему.

В качестве обходного пути я создал следующий скрипт, а затем добавил его в приложения для запуска:

#! / Bin / баш

setxkbmap es

Я попытался добавить команду setxkbmap es непосредственно к запускающим приложениям, но это не сработало, поэтому я сделал сценарий.

    
ответ дан user215507 07.12.2013 в 21:24
4

Я использовал:

setxkbmap es

и наконец! это сработало, теперь я могу использовать и - и тильды - в правой клавише на клавиатуре!

    
ответ дан DanielJM 07.11.2013 в 05:04
1

Это также повлияло на меня, и у меня есть клавиатура pt-br. Я действительно не знаю, как решить проблему, но возможное обходное решение (это сработало для меня) заключается в использовании setxkbmap, пока они не исправят его:

Ссылка

Надеюсь, это поможет.

    
ответ дан Leonardo Coutinho 22.10.2013 в 03:31
1

Сначала откройте Настройки ввода текста , затем поставьте датский список списка входных источников:

    
ответ дан Radu Rădeanu 21.10.2013 в 12:14