Обновление Google Chrome не будет установлено из-за неудовлетворенных зависимостей

14

Сегодня было опубликовано обновление Google Chrome , и оно не было установлено из-за неразрешенных зависимостей. Как я могу исправить это?

    
задан rstreeter78 15.10.2013 в 20:47
источник

4 ответа

3

Попробуйте это.

Загрузка фиктивных пакетов:

wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/lib32gcc1_4.7.3-1ubuntu1_all.deb
wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/lib32stdc%2B%2B6_4.7.3-1ubuntu1_all.deb
wget https://dl.dropboxusercontent.com/u/85403877/ubu13-chrome-fix/libc6-i386_2.17-0ubuntu5_all.deb

Затем установите их:

sudo dpkg -i lib32gcc1_4.7.3-1ubuntu1_all.deb lib32stdc++6_4.7.3-1ubuntu1_all.deb libc6-i386_2.17-0ubuntu5_all.deb

Затем вы можете установить Google Chrome:

sudo dpkg -i google-chrome-stable_current_i386.deb
    
ответ дан Max K 18.10.2013 в 19:26
источник
8

Видите, у меня также есть эта проблема, и я сделал небольшое исследование, чтобы узнать, в чем проблема. Кроме того, у меня есть те же точные ошибки, которые были опубликованы.

Как выясняется, разработчики Google Code для 32-разрядного Ubuntu / Debian Google Chrome "сделали goof" и случайно добавили те зависимости, которые имеют 64-битную архитектуру и недоступны 32-разрядным Ubuntu / Debian. 64-разрядная программа работает нормально, как оказалось.

Все, что мы можем сделать, это подождать, пока не появится другое обновление, которое поможет решить эту проблему; В настоящее время я терпеливо жду, используя Chromium в качестве моей резервной копии. Обязательно обновляйте / устанавливайте, когда выпущена новая версия Google Chrome, как это возможно - и, надеюсь, - устраните эту проблему.

Если вы не можете дождаться, я прочитал, что у нестабильной / бета-версии Chrome нет этой проблемы, поскольку она была решена во время разработки этой новой версии. Вы можете скачать его здесь.

Я бы просто загрузил это, если вы не можете ждать или использовать другой браузер, пока не появится стабильное обновление.

источник: Обновление Google Chrome не будет установлено из-за неудовлетворительные зависимости

    
ответ дан MrSelfDestruct 18.10.2013 в 07:37
4

Вероятно, вы столкнулись с этой ошибкой: Неверные 64-разрядные зависимости от 32-разрядной версии Ubuntu . Это работает.

Все, что я могу предложить, это то, что вы продолжаете следить за ходом этой ошибки и оставаться в текущей версии, пока она не будет исправлена. Есть несколько комментариев, в которых указано, что они исправлены, но затем посмотрите на более свежий отчет об ошибке, который был объединился в # 304017 , поэтому я предлагаю терпение. Если вы хотите, просто sudo отключите Google ppa Google Chrome в своих источниках программного обеспечения. Вы можете повторно включить его, когда захотите.

    
ответ дан user25656 16.10.2013 в 04:51
0

Я столкнулся с одной и той же проблемой на двух разных 32-разрядных 12.04 машинах; см. Невозможно выбрать обновления Chrome на Ubuntu 12.04

Однако я могу сообщить, что с полудня EST 23 октября 2013 года проблема, похоже, решена для меня. Обновление Chrome можно было бы выбрать, и оно было успешно установлено.

    
ответ дан user5395 23.10.2013 в 18:15