Уродливые шрифты в Netbeans - Как я могу использовать системный шрифт?

67

У меня проблемы с тем, чтобы шрифт Netbeans выглядел красиво, это была проблема с тех пор, как я пробовал Ubuntu ~ 8. По какой-то причине шрифты выглядят так, будто они не получают сглаживание подпикселей только в Netbeans, для остальных приложений они выглядят идеально.

Посмотрите, насколько уродливый снимок экрана:

Это не только область кода, но каждый шрифт в приложении выглядит так. Я оглядывался и, видимо, добавлял следующую строку в файл .bashrc , чтобы исправить эту проблему, но в моем случае это не так:

export _JAVA_OPTIONS='-Dawt.useSystemAAFontSettings=lcd'

Он думает, что это может повлиять только на Java-приложения, но я не смог проверить другое приложение Java, чтобы проверить шрифты.

Кто-нибудь знает, что я могу сделать, чтобы исправить это? Как я могу заставить Netbeans использовать системный шрифт?     

задан Javier Villanueva 30.03.2011 в 07:58
источник

16 ответов

38

Как указано в комментариях, это проблема с приложениями Java Swing в Linux. Swing использует настройки сглаживания шрифтов Gnome (деактивированные, оттенки серого или субпиксели), однако он игнорирует настройки подсказки. Он всегда использует полный намек, и если вы используете Ubuntu с небольшим или отсутствующим шрифтом, намекающим (как это делают большинство людей, так как мало намеков является настройкой по умолчанию), это заставит шрифт оказаться значительно другим, чем в других приложениях. Приложения SWT, такие как Eclipse, хороши, но если вам нравится Netbeans, это не поможет вам.

Предостережение: для следующего обходного пути я говорю только о шрифте редактора, потому что в IDE это важно для меня. Вы также можете применить его к шрифтам меню и т. Д., Но это может быть немного выше.

Единственное полезное решение, которое я нашел здесь : используйте Fontforge, чтобы отредактировать выбранный вами шрифт редактора и удалить всю информацию о намеке с сам шрифт, затем сохраните его как новый шрифт и используйте его в Netbeans.

  1. sudo apt-get install fontforge
  2. Запуск Fontforge
  3. Откройте выбранный вами шрифт
  4. Ctrl + A или edit -> Select -> Select all , чтобы выбрать все символы
  5. Советы ⇒ Очистить инструкции
  6. Ctrl + Shift + F или element -> font info , чтобы открыть информацию о шрифте
  7. Переименовать шрифт (например, оригинальное имя + '_nohints')
  8. Сохранить отредактированный шрифт в каталоге .fonts в вашем доме, через file -> generate fonts , убедившись, что используется формат, который читает Ubuntu (см. следующий шаг)
  9. Очистить кеш шрифтов fc-cache -rv - после его вывода, чтобы убедиться, что ваш новый файл шрифта был поднят (например, .sfd не работает, но .ttf ).
  10. Запустите Netbeans и используйте шрифт, который вы создали как шрифт редактора.

Нет, не идеально и да, немного хлопот, но все же мир различий. Надеюсь, что это поможет.

    
ответ дан nem75 21.04.2011 в 23:12
источник
16

Добавить

--laf Nimbus -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

или

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal

в файл: netbeans.config. Вы можете найти его в папке $ NETBEANS_HOME / etc /. Уменьшите размер шрифта приложения от системных настроек.

Источник

    
ответ дан user24789 11.09.2011 в 10:03
7

Я знаю, что это старый вопрос, но в моих поисках той же проблемы я пробовал все трюки здесь без везения. Я думал, что мне просто придется жить со страшным текстом в netbeans.

Тогда я нашел следующее: Ссылка

В основном: Ubuntu 13.10, Netbeans (7.3), патчи шрифтов Infinality для freetype, OpenJDK7 и исправления для его исправления. И это «просто сработало» !!!

Скопировано здесь, если эта ссылка замирает:

  1. установить freetype

    $ sudo apt-get install libfreetype6
    
  2. установить патч бесконечности

    $ sudo add-apt-repository ppa:no1wantdthisname/ppa
    $ sudo apt-get update
    $ sudo apt-get install fontconfig-infinality
    

    Мне пришлось сделать следующее:

    $ sudo rm /etc/fonts/conf.avail/52-infinality.conf
    $ sudo ln -s /etc/fonts/infinality/infinality.conf /etc/fonts/conf.avail/52-infinality.conf
    

    Чтобы использовать визуализацию шрифтов Windows 7, выполните следующие действия:

    $ sudo /etc/fonts/infinality/infctl.sh setstyle win7
    

    Установите USE_STYLE в "WINDOWS7" в файле /etc/profile.d/infinality-settings.sh

  3. установить шрифт фиксированный OpenJDK

    $ sudo add-apt-repository ppa:no1wantdthisname/openjdk-fontfix
    $ sudo apt-get update
    $ sudo apt-get install openjdk-7-jdk
    

    В .../etc/netbeans.conf ,

    netbeans_default_options включает: -J-Dawt.useSystemAAFontSettings=lcd и -J-Dsun.java2d.xrender=true"

    и установите netbeans_jdkhome="/usr/lib/jvm/java-1.7.0-openjdk-amd64"

Это изменило мои шрифты Netbeans с 1990-х годов, приемлемых для современного дня. И теперь я могу использовать Inconsolata в качестве шрифта редактора Netbeans, и он выглядит БОЛЬШИМ.

Снимок экрана по запросу: (фактический текст более четкий, чем этот захват, что-то в захвате слегка размыло его).

    
ответ дан Chris Holt 31.01.2014 в 06:28
5

Сглаживание шрифтов не работает корректно в приложениях Java Swing Ubuntu.

Добавить

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd

в netbeans.config в конце строки netbeans_default_options .

Файл конфигурации можно найти в папке $ NETBEANS_HOME / etc / (например, /home/<user_name>/<neatbeans_folder>/etc/netbeans.conf )

Пример:

netbeans_default_options="-J-client -J-Xss2m -J-Xms32m -J-XX:PermSize=32m -J-Dnetbeans.logger.console=true -J-ea -J-Dapple.laf.useScreenMenuBar=true -J-Dapple.awt.graphics.UseQuartz=true -J-Dsun.java2d.noddraw=true -J-Dsun.java2d.dpiaware=true -J-Dsun.zip.disableMemoryMapping=true -J-Dnetbeans.extbrowser.manual_chrome_plugin_install=yes -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd"
    
ответ дан R. Oosterholt 24.01.2014 в 10:53
2

Не так уж плохо, что шрифт ..

Однако это приложение Java и как особый способ обработки шрифтов.

Если вы хотите изменить размер шрифта, вы можете запустить Netbeans с помощью " - fontsize ":

netbeans --fontsize 12

Если вы хотите изменить тип шрифта, это немного более жесткие изменяющиеся параметры среды, и эта статья очень хорошо объясняет:

Ссылка

Это для ArchLinux, но я думаю, что он будет работать и в Ubuntu, поскольку Java является универсальным программным обеспечением.

    
ответ дан Pisu 10.10.2011 в 23:52
2

У меня была такая же проблема на Ubuntu 12.04 и Netbeans 7.2.

Я попытался добавить -J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd к netbeans.conf , но не решил проблему.

Затем я увидел комментарий проблемы относительно высоты строки в ошибке 215785 Netbeans . Установка высоты строки редактора в 1.0 вместе с настройками AA в netbeans.conf решила мою проблему.

    
ответ дан Caner 01.09.2012 в 15:48
1

Я смог сделать это так (я использую Ubuntu 12.10, также работал над Ubuntu 13.04):


Шаг 1 (возможно, это работает во всех версиях Ubuntu):

Сначала я очистил меню, используя этот плагин Tools -> Plugins -> Settings -> Add :

http://java-swing-ayatana.googlecode.com/files/netbeans-catalog.xml

После добавления этого места вам необходимо установить плагин, выполнив поиск Java Ayatana (описание будет написано на испанском языке). Это сделает верхнее и контекстное меню такими же, как ОС.


Шаг 2 (я не знаю, будет ли это работать во всех версиях Ubuntu):

Затем вы, вероятно, захотите, чтобы шрифты проектов тоже выглядели красивее, что я сделал, чтобы исправить это было запущено в терминале: sudo apt-get install gnome-tweak-tool Я запустил его и выбрал другой default font Теперь Netbeans выглядит красиво!

Вот скриншот:

    
ответ дан Get Off My Lawn 22.12.2012 в 23:49
1

Просто увидел эти сообщения и попытался исправить мою проблему с шрифтами, у меня также был вопрос, я мог выбрать только 4 шрифта, все были хромыми, и задавались вопросом, что произошло, что netbeans дает только 4 шрифта на выбор, а также хромированное поле выбора шрифтов, Я большой поклонник netbeans, и я знал, что могу найти решение здесь.

каким-либо образом я следил за всем возможным руководством. Я использую Ubuntu 13.10 и netbeans 7.3 (да, я люблю неустойчивые вещи)

  1. создайте папку .font в моей папке пользователя.
  2. скопировал все шрифты, которые у меня были в этой папке.
  3. добавлена следующая строка в файл netbeans.conf.

найти его, выполнив:

locate netbeans.conf

отредактируйте его и добавьте следующее в кавычки, как указано выше

-J-Dswing.aatext=true -J-Dawt.useSystemAAFontSettings=lcd --laf Metal
  1. запустить обновление netbeans, которое, как я думаю, теперь имело волшебство, у меня есть красивый выбор шрифта и есть больше шрифтов, чтобы выбрать тогда код для написания (нецензурная шутка).

Надеюсь, это поможет вам.

    
ответ дан talsibony 01.01.2014 в 15:24
0

Я пробовал буквально каждое решение, которое я мог найти, и никто не работал, кроме использования другого JDK по умолчанию для NetBeans.

Oracle JDK не отображает шрифты хорошо. OpenJDK также, похоже, не работает для NetBeans, но творит чудеса для IntelliJ и его братьев и сестер.

Тот, который работал для NetBeans, называется TuxJDK , который по существу является OpenJDK для Java-разработчиков, работающих в Linux. Одним из улучшений является отличный рендеринг шрифтов .

Вот как это использовать:

  1. Загрузите двоичный файл TuxJDK из здесь . («tuxjdk-static-8.92.03.tar.xz» на момент написания)
  2. Извлеките tar.xz, где хотите.
  3. Скопируйте расположение каталога TuxJDK.
  4. Откройте netbeans.conf, расположенную в NetBeansInstallationDirectory / etc /.
  5. Найдите строку, начинающуюся с «netbeans_jdkhome», и замените путь на один, скопированный на шаге 3.
  6. Fire и NetBeans и обработайте ваши глаза красивыми шрифтами!

До: NetBeans перед использованием TuxJDK

После того, как: NetBeans после использования TuxJDK

    
ответ дан Rohit Awate 23.03.2018 в 17:26
0

Просто установите zulu jdk из Ссылка :)

    
ответ дан Arun 30.03.2018 в 14:39
0
#!/bin/sh

gsettings set org.gnome.desktop.interface font-name 'Ubuntu 10'
sh /home/xxx/netbeans-7.2/bin/netbeans &
sleep 5
gsettings set org.gnome.desktop.interface font-name 'Ubuntu 11'
    
ответ дан demonige 19.09.2012 в 13:53
0

Лично я считаю, что общий внешний вид Netbeans на Linux немного разочаровывает, особенно учитывая, насколько хорошо он выглядит на других платформах. К счастью, изменение внешнего вида & amp; (LAF) можно легко сделать изнутри IDE. В зависимости от вашего выбора это часто улучшает внешний вид шрифтов.

Чтобы изменить LAF, выполните следующие действия: Нажмите Tools > > Опции В диалоговом окне выберите «Внешний вид», затем вкладку «Поиск» и «Чувство» Просто выберите один из LAF. Мое предпочтение - Нимбус, но вы можете предпочесть что-то еще.

Есть также два доступных плагина «Dark LAFs»: Dark Metal и Dark Nimbus.

    
ответ дан Larry Hignight 24.07.2014 в 03:12
0

Идя дальше на ручные пути, я подготовил выделенный шрифт под названием «Ubuntu Mono Nohinting», чтобы обойти проблему рендеринга с приложениями Java Swing, такими как IDE NetBeans, IntelliJ IDEA и PyCharm. Информация о намеченном шрифте была удалена из исходного семейства шрифтов Ubuntu Mono.

Как установить

  • загрузите zip-файл отсюда
  • извлеките его
  • открыть * .ttf с помощью Font Viewer для установки.
  • или , вы можете вручную скопировать * .ttf в ~/.local/share/fonts/ .

Как использовать

  • Выберите «Ubuntu Mono Nohinting» в настройках редакторов.

Скриншоты

Ubuntu Mono Font с темой PyCharm Monokai

Шрифт Ubuntu Mono Nohinting с темой Monocai PyCharm

    

ответ дан Nobuto Murata 11.04.2015 в 18:15
0

Я сам сделал немного другое: в моем случае, говоря о NetBeans версии 8.0.1 , проблема заключалась в установке JDK в системе (Oracle JDK 8.0). После перехода на OpenJDK в элементах пользовательского интерфейса появились более красивые шрифты.

Я не знаю, является ли это хорошим ответом, потому что он может работать не везде, но, конечно же, - пытаясь переключить JDK (будь то OpenJDK или Oracle JDK), вы можете увидеть разницу.

    
ответ дан spectre 21.12.2015 в 18:18
0

Добавьте следующий код в конец файла netbeans_default_options вашего netbeans.conf .

-J-Dawt.useSystemAAFontSettings=on

Это позволит использовать системные шрифты.

    
ответ дан Kevin RED 29.11.2017 в 13:25
-1

У меня была такая же проблема на Mint 12. Я решил ее, введя «Расширенные настройки» - > «Шрифты» и уменьшив шрифт по умолчанию с 11 до 10. Я понизил все шрифты в списке до согласованности.

Должна быть проблема с шрифтом Cantarell 11.     

ответ дан Alan B. Dee 23.12.2011 в 19:25