«ctrl + space» был связан с вызовом некоторого метода ввода и не работает в Emacs или Eclipse автозаполнения

81

В Emacs, запущенном в терминале, ctrl + space - это стандартная комбинация клавиш для выбора региона. Но в Ubuntu 12.04 он будет ссылаться на некоторый метод ввода для неанглийского языка. Мне было интересно, могу ли я зарезервировать его только для Emacs?

В разделе System Settings -> Keyboard -> Shortcuts я не смог найти, к чему привязано ctrl + space . Странно.

Другие программы, особенно автозаполненные в Eclipse, также, похоже, имеют проблемы с обработкой ctrl + space .

    
задан Tim 16.01.2013 в 00:55
источник

8 ответов

119

Похоже, у вас работает Ibus, который по умолчанию использует Ctrl + Space , чтобы включить / отключить редактор ввода.

Вы можете изменить комбинацию клавиш, назначенных ему в настройках Ibus.

Если Ibus запущен в строке меню, вы можете щелкнуть правой кнопкой мыши, чтобы выбрать Предпочтения в меню. Если Ibus не работает в строке меню, вы можете запустить диалог настроек из Dash, запустив Способы ввода клавиатуры или из терминала с ibus-setup .

Обновление для 14.04

ibus-setup больше не доступно для 14.04. Функции из прежнего ibus-setup вместо этого интегрированы в System Settings > > > Ввод текста .

Включение ввода теперь установлено по умолчанию на Супер + Пробел , но Ibus все еще может украсть фокус с Control + Пробел и вызвать другие системные проблемы, прежде всего автозаполнение в Eclipse.

Интеграция ввода ввода Ibus в новые настройки ввода текста по-прежнему продолжается, и это вызывает проблему, поскольку более старая настройка по-прежнему существует за кулисами.

Если вы обновили с 12.04, ibus-settings все равно будет доступно.

В 14.04 вы можете редактировать настройки напрямую: dconf-editor .

Если он не установлен:

sudo apt install dconf-editor

Затем перейдите к Desktop > > > ibus > общий > горячая клавиша . Настройки trigger и triggers покажут 'control + space'. Измените эти настройки, оставив пустые скобки [] в triggers .

    
ответ дан chaskes 16.01.2013 в 01:59
10

Отключить триггер IBUS с помощью командной строки:

gsettings set org.freedesktop.ibus.general.hotkey triggers @as []

Или если это не сработает, попробуйте, если первый произведет ошибку:

gsettings set org.freedesktop.ibus.general.hotkey triggers []
    
ответ дан aba 24.06.2014 в 09:46
4

ibus не причиняет мне ничего, кроме головных болей. Каждый раз, когда я пытаюсь изменить настройки, когда я перезагружаюсь, возвращается Ctrl + Space. Вот мое решение:

sudo apt-get purge ibus
sudo killall ibus

Теперь все работает, пока Ubuntu не решит свою следующую глупую вещь. Может быть, буква «o» отобразится для выключения компьютера?

    
ответ дан Eyal 11.02.2015 в 13:47
2

После обновления до ubuntu 14.04 у меня была та же проблема. Что я сделал.
В предпочтениях Ibus: System > Preferences > Keyboard Input Methods .
Существует опция: Next input method , она была установлена в ctrl + space, я удалил ее, а затем все снова начал работать.

    
ответ дан wmlynarski 24.07.2014 в 11:04
1

Ubuntu Studio 14.04 (XFCE) здесь. У меня не было проблем с Autocomplete ( Ctrl + Space ), но с Copy Line ( Ctrl + Alt + Down ).

Это сработало для меня:

  • Открыть диспетчер Windows: xfwm4-settings
  • Перейдите на вкладку «Клавиатура».
  • Прокрутите вниз до конфликтующего действия.
  • Нажмите кнопку «Очистить» или измените действие на другой ярлык
ответ дан luboskrnac 04.04.2015 в 13:34
0

У меня Ubuntu 14.04 GNOME с LXDE. По-видимому, у этого рабочего стола есть ibus-setup. Итак, для меня изменение настроек ibus было правильным исправлением. Возможно, только Unity покончил с приложением ibus-setup.     

ответ дан JamesH 28.12.2014 в 05:28
0

Изменение dconf-editor было недостаточно для меня. У меня установлен исходный источник Mozc (японский).

В Ubuntu 16.04 мне также пришлось:

  1. Перейдите в раздел Системные настройки - > Ввод текста
  2. Нажмите кнопку Mozc, чтобы выделить
  3. Нажмите на значок гаечного ключа / отвертки ниже
  4. Вкладка «Глобальная настройка»
  5. Первая настройка там, «Метод ввода триггера», была CTRL_SPACE. Я щелкнул его, а затем нажмите Escape , чтобы отключить привязку клавиш.
ответ дан TalkLittle 08.09.2016 в 19:18
0

Для некоторых пользователей, использующих японский ввод с fcitx, проверьте Fcitx Configuration . В меню есть глобальная конфигурация, а под Trigger Input Method - ярлык по умолчанию Ctrl + Пробел .

    
ответ дан Alvin Radeka 19.09.2018 в 03:33