Как получить библиотеки libc для Ubuntu 12.04?

16

Я хочу установить пакет glibc-devel в Ubuntu 12.04. Я - рабочая станция VM Ware в моем проекте, и этот пакет является одной из зависимостей для создания изображения проекта. Я попытался найти информацию об этом пакете Google, но не нашел удовлетворительного ответа.

Этот пакет не поддерживается в Ubuntu 12.04? Если нет, то каков альтернативный пакет для него.

Любая помощь по этому поводу будет полезна.

    
задан Tanuj Sharma 03.07.2012 в 08:12
источник

3 ответа

16

build-essential должен сортировать вас.

sudo apt-get install build-essential
    
ответ дан Mike Steinert 02.08.2012 в 17:06
2

Если вам просто нужен файл libc заголовков , установите libc6-dev .

Если вы предпочитаете устанавливать в командной строке, вы можете использовать:

sudo apt-get update && sudo apt-get install libc6-dev

Это стоит упомянуть, как если бы вы использовали компилятор other , чем версия GCC, предоставленная build-essential / gcc-defaults , вы можете просто установить пакет libc6-dev .

(Установка build-essential будет работать, потому что это приведет к тому, что libc6-dev будет установлено. libc6-dev - это то, что фактически предоставляет файлы заголовков, которые позволяют вам ссылаться на GNU libc.)

    
ответ дан Eliah Kagan 24.01.2013 в 04:54
-1

У меня такая же проблема, и я клонирую источник glibc (GNU libc) с помощью команды:

git clone git://sourceware.org/git/glibc.git

Это отлично работает для меня.

    
ответ дан zimmer 03.04.2013 в 16:34