Ubuntu 14.04: не удается подключиться к новой защищенной паролем сети Wi-Fi

18

После обновления до Ubuntu 14.04 я не могу подключиться к любым точкам доступа WPA2 new WPA2. Существующие работают.

Вот пастик вывода syslog: Ссылка

Вот ошибка, которая иногда появляется во всплывающем окне:

(nm-applet:28277): nm-applet-WARNING **: Connection activation failed: (1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/34' failed in libnm-glib.

Существует обходной путь, но это не очень. При сбое подключения здесь будет создан файл: /etc/NetworkManager/system-connections/<name of network> Если я отредактирую этот файл и добавлю пароль psk=password в раздел [802-11-wireless-security] , тогда я могу подключиться.

Дополнительная информация: Ссылка

    
задан postfuturist 20.05.2014 в 19:12
источник

3 ответа

24

Выполните следующие шаги для перехода на новую сеть Wi-Fi

  1. Нажмите на символ Wi-Fi, который находится рядом с символом аккумулятора.
  2. Нажмите «Изменить соединение», расположенное внизу раскрывающегося списка.
  3. Выберите сеть, к которой вы хотите подключиться, и нажмите кнопку «Изменить».
  4. Перейдите на вкладку WiFi-security и введите пароль этой сети, сохраните и закройте.

Теперь, если вы подключитесь к этому, все будет нормально работать.

    
ответ дан Dhirendra Gupta 12.09.2014 в 07:02
4

Беспроводные драйверы для ubuntu и linux немного осязаемы, когда речь заходит о подключении к маршрутизаторам с определенными настройками, я рекомендую использовать лучшие настройки.

Я рекомендую вам изменить тип шифрования в маршрутизаторе на WPA2 с помощью AES (CCMP). Убедитесь, что вы не выбираете смешанный режим WPA или WPA / WPA2, так как это снова потребует TKIP, который не рекомендуется.

Зайдите в диспетчер сети и настройте параметры беспроводной связи в соответствии с скриншотами для получения наилучших результатов.

Также выполните:

sudo ifconfig wlan0 down
sudo modprobe -rfv iwldvm
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi 11n_disable=1
sudo ifconfig wlan0 up

это будет сброшено при перезагрузке, но если это поможет во многих случаях, мы можем сделать это постоянным:

echo "options iwlwifi 11n_disable=1" | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwldvm
sudo modprobe -rfv iwlwifi
sudo modprobe -v iwlwifi

Перезагрузка     

ответ дан Wild Man 20.05.2014 в 21:00
0

У меня тоже была эта проблема. У меня есть другой ответ.

Я установил ubuntu 14.10 на новую машину, а затем пересадил мой домашний каталог с моей старой машины, которая также работает 14.10. Похоже, что это перетащило ключ из моей старой машины, в частности эти файлы:

~/.local/share/keyrings/login.keyring
~/.local/share/keyrings/user.keystore

Решение для меня состояло в том, чтобы переименовать эти старые файлы ключей и позволить ubuntu создавать новые.

cd ~/.local/share/keyrings
mv login.keyring login.keyringold
mv user.keystore user.keystoreold

У меня есть способ создать новый keyring из этого сообщения на форуме: Ссылка

Замените ~/.gnome2 в своих путях файлов ~/.local/share .

После замены брелока мой сетевой менеджер снова работал правильно.

    
ответ дан Matthew Krafczyk 06.01.2015 в 17:31