Поддерживает ли Ubuntu 16.04 гибридные графические карты (шмель)

15

Поддерживает ли Ubuntu 16.04 гибридные видеокарты? Я прошу из-за поддержки ubuntu мгновенного ядра в Ubuntu 16.04.

Я использую шмелю, чтобы начать, например, игру, в лучшем качестве графики. (optirun ./start.sh)

Ссылка на шмелю

Это работает с Ubuntu 16.04?

    
задан JOnathanJOnes 19.04.2016 в 10:38
источник

6 ответов

18

Я получил его работу после некоторых попыток (nvidia-364, от ubuntu-графики ppa).

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

sudo apt-get install nvidia-364

sudo apt-get install bumblebee bumblebee-nvidia primus linux-headers-generic

sudo systemctl enable bumblebeed

После этого sudo gedit /etc/modules и добавьте 2 строки:

i915
bbswitch

затем

sudo prime-select intel

sudo gedit /etc/bumblebee/bumblebee.conf

в строке 22: Driver=nvidia

Удостоверьтесь, что изменения строк меняются каждый nvidia-current до nvidia-364 (или любой другой версии).

После этого вы можете безопасно перезагрузить компьютер.

    
ответ дан Huba Buba 22.04.2016 в 23:49
источник
10

У Bumblebee не было развития с 2013 года и не рекомендуется в 16.04, установка nvidia-361 и nvidia-prime должна заботиться о функциях шмеля. pilot6 предоставил данные об использовании здесь .

Не позволяйте комментарию «это сломано» влиять на вас. Тем временем было много улучшений.     

ответ дан emk2203 19.04.2016 в 11:32
3

По-прежнему ничего не стоит на проблеме vsync. Нам понадобится ядро ​​4.5, патч xorg (1.19) и патч nvidia.

Вы можете следить за этой темой здесь.

Ссылка     

ответ дан Eduardo Moñino Esteban 22.04.2016 в 13:34
2

Версия шмеля в репозиториях и драйвер nvidia-361 по умолчанию не работают. Вам либо нужно установить более старый драйвер nvidia, либо вручную отредактировать несколько файлов конфигурации или установить драйверы bumblebee и nvidia из ppa, а также вручную отредактировать файлы. Альтернативой является использование nvidia-prime для переключения графических драйверов, но для этого требуется, чтобы вы каждый раз выходили из системы. Bumblebee работает из коробки в нескольких других дистрибутивах, поэтому его разочаровывает необходимость прыгать через так много обручей, чтобы заставить его работать в крупном дистрибутиве, таком как ubuntu.

    
ответ дан Alrekur 30.04.2016 в 02:42
0

Да, это поддерживается. Как отметил Хуба Буба, это некоторые проблемы, которые необходимо решить в будущей версии 4.0 Bumblebee. Предварительная версия доступна через тестирование PPA , если вы ее протестируете, пожалуйста, взгляните на Ссылка , 759 и 761. Сообщите свои результаты здесь, чтобы сообщить нам, нужно ли вам по-прежнему редактировать файл bumblebee.conf .

Также обратите внимание, что команда prime-select (и, следовательно, установка nvidia-prime) вообще не нужна. И хотя вы можете установить оба варианта, сделать совместную работу немного сложнее.

    
ответ дан Archange 20.05.2016 в 15:07
0

Существуют различные способы использования техники Optimus. Bumblebee является лишь одним из решений для некоторых поддерживаемых компьютеров. См. это вопрос со ссылкой на официальную страницу вики Ubuntu . Если вы предпочитаете использовать Bumblebee, я предлагаю дождаться появления версии 4.0 (скоро), чтобы избежать проблем совместимости драйверов NVidia. Надеюсь, это поможет.

    
ответ дан Xiaodong Qi 03.05.2016 в 09:31