Почему некоторые пакеты конфликтуют с самим собой?

15

После обновления до Oneiric у меня возникли проблемы с менеджером пакетов (он хотел удалить половину моей системы, включая libc6, zlib1g-пакеты и т. д.). Во время борьбы с способностями я заметил, что некоторые пакеты имеют метаинформацию, в которой говорится, что они конфликтуют с самими собой. Примеры:

% aptitude show libc-bin
Package: libc-bin                        
Essential: yes
New: yes
State: installed
Automatically installed: no
Version: 2.13-20ubuntu5
Priority: required
Section: libs
Maintainer: Ubuntu Developers <[email protected]>
Uncompressed Size: 3,420 k
Conflicts: libc-bin
Breaks: libc0.1 (< 2.10), libc0.1 (< 2.10), libc0.3 (< 2.10), libc0.3 (< 2.10), libc6 (< 2.10), libc6 (< 2.10), libc6.1 (< 2.10), libc6.1 (< 2.10)
Replaces: libc0.1, libc0.1, libc0.3, libc0.3, libc6, libc6, libc6.1, libc6.1
Provides: libc-bin
Provided by: libc-bin
Description: Embedded GNU C Library: Binaries

См. строку Conflicts: libc-bin ? Еще одно:

% aptitude show qdbus   
Package: qdbus                           
New: yes
State: installed
Automatically installed: no
Version: 4:4.7.4-0ubuntu8.1
Priority: optional
Section: libs
Maintainer: Kubuntu Developers <[email protected]>
Uncompressed Size: 213 k
Depends: libc6 (>= 2.3.4), libgcc1 (>= 1:4.1.1), libqt4-dbus (= 4:4.7.4-0ubuntu8.1), libqt4-xml (= 4:4.7.4-0ubuntu8.1), libqtcore4 (= 4:4.7.4-0ubuntu8.1), libstdc++6 (>= 4.1.1)
Conflicts: qdbus
Breaks: libqt4-dbus (< 4:4.7.3-4ubuntu5), libqt4-dbus (< 4:4.7.3-4ubuntu5), qt4-dev-tools (< 4:4.7.3-4ubuntu6), qt4-dev-tools (< 4:4.7.3-4ubuntu6)
Replaces: libqt4-dbus (< 4:4.7.3-4ubuntu5), libqt4-dbus (< 4:4.7.3-4ubuntu5), qt4-dev-tools (< 4:4.7.3-4ubuntu6), qt4-dev-tools (< 4:4.7.3-4ubuntu6)
Provides: qdbus
Provided by: qdbus
Description: Qt 4 Dbus Tool

То же самое «конфликтует с собой».

Теперь я решил проблемы с менеджером пакетов, но вопрос все еще беспокоит меня: что это значит, когда пакет конфликтует сам по себе? Для чего это используется?

    
задан ulidtko 21.02.2012 в 14:26
источник

3 ответа

24

Oneiric поддерживает Multi-Arch, то есть позволяет одновременно устанавливать пакеты разных архитектур (в настоящее время i386 и amd64 a.k.a. 32-разрядные и 64-разрядные). Некоторые пакеты не могут быть установлены одновременно (например, libc6: i386 и libc6: amd64). aptitude не может обрабатывать эти случаи , и поэтому считает, что это может быть хорошей идеей удалите эти пакеты. Теперь рекомендуется использовать apt-get .

Если вы используете apt-cache show libc-bin , вы можете увидеть строку, в которой упоминается этот конфликт:

  

Multi-Arch: иностранный

Описание этого поля можно найти на странице Ссылка

    
ответ дан Lekensteyn 21.02.2012 в 14:37
источник
8

Aptitude не показывает вам всю историю.

$ apt-cache depends libc-bin | grep Conflicts
  Conflicts: libc-bin:i386

Я нахожусь на 64-битной установке, поэтому на самом деле это противоречит только 32-разрядному аналогу.

    
ответ дан Oli 21.02.2012 в 14:49
7

Вы столкнулись с ошибкой 831768 .

Боюсь, что

aptitude не понимает мультиархия. Лучше избегать aptitude , пока это не будет разрешено. Вы можете выжить с apt-get .

    
ответ дан tumbleweed 21.02.2012 в 23:20