«Служба проверки подлинности недоступна» при установке IDLE (с использованием python 2.7)

16

Я получаю эту ошибку при установке IDLE на 12.10:

Software can't be installed or removed because the authentication service is not available.
(org.freedesktop.PolicyKit.Error.Failed: ('system-bus-name', {'name': ':1.95'}): 
org.debian.apt.install-or-remove-packages

Я ничего не могу установить, даже игры. Все они приходят с тем же сообщением об ошибке.

Есть ли что-то, что мне не хватает? Пожалуйста, предложите.

    
задан Gagan 28.10.2012 в 06:18
источник

3 ответа

6

Временным решением для этого является:

sudo software-center
    
ответ дан Paschalis 26.11.2012 в 11:01
2

Попробуйте следующее:

sudo apt-get update
sudo apt-get install idle3

Кроме того, возможно, ваш менеджер пакетов заблокирован другим процессом, например, обновлением в фоновом режиме или другой установкой, которая не была завершена. Вы можете попробовать перезагрузить, а затем выпустить следующее, которое завершит любые неполные установки:

sudo dpkg --configure -a
    
ответ дан Da1T 14.11.2012 в 19:31
1

Были произведены некоторые обновления для моей установки ubuntu. Я обновил мою ubuntu, и все стало работать для меня потом.

спасибо за вашу помощь

С уважением Гаган Джанджуа

    
ответ дан Gagan 15.11.2012 в 21:35