Nvidia Optimus с GTX 850m не работает

2

Недавно я получил новый ноутбук (Acer Aspire V5 573G) с Nvidia Geforce GTX 850M и интегрированной графикой Intel Haswell. Теперь я прочитал множество веб-сайтов, чтобы узнать, как лучше всего запустить систему. Обычно мне не нужна карта GeForce, так что интеллект достаточно хорош. Тем не менее, я думаю, что Displayport и порт HDMI подключены к карте Nvidia, поэтому мне тоже нужно работать. Проблема в том, что карта Nvidia не обнаружена Ubuntu: выход lshw -C display :

*-display
       description: VGA compatible controller
       product: Haswell-ULT Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: [email protected]:00:02.0
       version: 0b
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:65 memory:b3000000-b33fffff memory:c0000000-cfffffff ioport:5000(Größe=64)

Лучше всего для меня было бы, что карта Nvidia постоянно отключается, но может быть активирована, чтобы я мог использовать HDMI / Displayport. Я уже пытался установить шмелю, но, конечно, карта не обнаружена. Скажите, пожалуйста, если вам нужна дополнительная информация. Большое спасибо!

EDIT: выход uname -a : Linux LappII 3.13.0-52-generic #86-Ubuntu SMP Mon May 4 04:32:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

    
задан Merlin1896 18.11.2014 в 16:45
источник

3 ответа

2

Я думаю, проблема в том, что текущая версия драйверов Nvidia в Ubuntu не поддерживает эту карту. Вы можете попробовать установить более новую версию. Запустите в терминале.

sudo add-apt-repository ppa:xorg-edgers/ppa
sudo apt-get update
sudo apt-get install nvidia-346
sudo add-apt-repository -r ppa:xorg-edgers/ppa

Также имеет смысл обновить ядро и графический стек до HWE 14.04.2. Это можно сделать, выполнив:

sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libqt5gui5 libgles1-mesa-lts-utopic libgles2-mesa-lts-utopic libgl1-mesa-glx-lts-utopic libgl1-mesa-glx-lts-utopic:i386 libglapi-mesa-lts-utopic:i386 libegl1-mesa-drivers-lts-utopic

Затем перезагрузитесь.

После этого попробуйте оба драйвера 346 и 349. Новое ядро и стек поддерживают более новое оборудование.

    
ответ дан Pilot6 17.05.2015 в 20:43
источник
0

Вместо Bumblebee вы можете попробовать проприетарные драйверы nVidia, которые добавили поддержку Optimus.

Откройте Software & amp; Обновления и перейдите на вкладку Дополнительные драйверы . На загрузку потребуется некоторое время, после чего вам будет представлен список драйверов, которые, как известно, работают с этим устройством. По умолчанию будет выбран драйвер с открытым исходным кодом noveau .

Выберите драйвер следующего в списке, возможно, что-то вроде nvidia-331 и нажмите Применить . После завершения загрузки и установки драйвера перезагрузитесь. Теперь вы можете открыть панель управления nVidia и настроить Optimus в разделе nVidia Prime .

Если драйвер не поддерживает Optimus или плохо работает с вашей видеокартой, выберите в списке следующее:

    
ответ дан s3lph 18.11.2014 в 17:56
0

Основываясь на том, что вы сказали в предыдущих сообщениях по Вопросу. Nvidia 349 Кажется, работает с вашей Картой. Вы также собираетесь использовать графический процессор Nvidia только тогда, когда это необходимо.

Итак, у меня есть решение для вас. Я разместил это в своем блоге хорошо и получил очень положительный ответ от людей, которые его использовали. Поэтому я немного скомпилировал документацию, как показано ниже.

Официальный репозиторий Ubuntu имеет только старые и устаревшие драйверы. Я не использую это сам и предлагаю вам сделать то же самое, если вы хотите, чтобы последний драйвер Nvidia был без проблем.

Шаги: -

1) Первый шаг после установки Ubuntu - установить все обновления. Вы можете использовать программу обновления программного обеспечения или просто запустить sudo apt-get update & amp; & amp; & amp; sudo apt-get upgrade

2) Добавьте Xorg-edgers ppa, используя

sudo apt-add-repository ppa: xorg-edgers / ppa, а затем sudo apt-get update

3) Запустите sudo apt-get upgrade & amp; & amp; & amp; sudo apt-get dist-upgrade

Это самый важный шаг. Если вы пропустите это, вы увидите черный экран после перезагрузки. Пожалуйста, сделайте это, когда мы используем xorg-edgers ppa. Мы должны обеспечить, чтобы все пакеты, необходимые для шмеля и nvidia, были взяты из ppa.

4) Теперь установите драйверы bumblebee и Nvidia, используя

sudo apt-get install bumblebee bumblebee-nvidia primus nvidia-349

5) Добавьте текущего пользователя в группу безопасности шмеля.

sudo gpasswd -a $ USER bumblebee

для Ubuntu 15.04 только вам нужно вручную включить демона шмеля с помощью

sudo systemctl enable bumblebeed

6) Это позаботится об установке необходимого программного обеспечения в вашей системе. Нам нужно настроить его.

Я могу заверить вас, если вы выполнили эти шаги до сих пор, тогда настройка должна быть легкой.

Начнем с включения драйвера bbswitch и intel i915.

7) sudo gedit / etc / modules

Ubuntu 15.04 файл /etc/modules-load.d/modules.conf

добавьте эти две строки к нему

i915 bbswitch

8) Отредактируйте файл конфигурации шмеля. sudo gedit /etc/bumblebee/bumblebee.conf

  1. строка 22:

Driver = NVIDIA

  1. строка 55:

= KernelDriver-349 NVIDIA

  1. строка 58:

LibraryPath = / USR / Библиотека / NVIDIA-349: / USR / lib32 / 349-NVIDIA

  1. строка 61:

XorgModulePath = / USR / Библиотека / NVIDIA-349 / Xorg, / USR / Библиотека / Xorg / модули

В дополнение к этому есть еще один файл, который необходимо отредактировать.

9) sudo gedit /etc/modprobe.d/bumblebee.conf

Добавьте строку ниже.

черный список nvidia-349

Теперь вы можете перезагрузиться. После перезагрузки.

Проверить использование

sudo apt-get install mesa-utils, если mesa-utils еще не установлен.

primusrun glxinfo | grep OpenGL

Это должно сказать вам, что драйвер nvidia-349.16 используется.

Обратите внимание, что nvidia-349 является последним драйвером на момент написания этого сообщения. Пожалуйста, проверьте страницу стартовой панели для xorg-edgers ppa и соответственно замените nvidia-349 на последнюю версию, если она есть.

Сообщите мне, если это сработает для вас.

    
ответ дан Rajat Pandita 19.05.2015 в 12:16