Почему apt-get всегда использует прокси-сервер, хотя прокси-сервер не настроен?

18

Я пытаюсь отключить прокси для apt-get , но похоже, что apt-get получает его прокси-конфигурацию из другого места, кроме /etc/apt/apt.conf , потому что хотя файл apt.conf пуст (а системный прокси установлен до None ), он все еще пытается подключиться к прокси.

У кого-нибудь появилась идея?

    
задан Ahatius 12.09.2013 в 21:27
источник

6 ответов

21

Я использую скрипт для замены разных файлов конфигурации, чтобы легко переключаться между прокси-серверами и не-прокси-серверами. Проблема заключалась в том, что я заменил файл proxy apt.conf пустым файлом apt.conf, который затем игнорировался.

После записи Acquire::http::Proxy "false"; в apt.conf он работал без прокси:)

    
ответ дан Ahatius 13.09.2013 в 20:11
источник
10

Иногда существуют переменные среды прокси, которые все еще установлены.

Чтобы узнать, выполните следующую команду:

env | grep proxy

Если вы видите какой-то вывод, например:

http_proxy=http://127.0.0.1:1234/

Затем вам нужно будет отключить эту переменную.

Для этого выполните следующую команду:

unset http_proxy

Следуйте такому же подходу для всех других записей, таких как https_proxy .

    
ответ дан Alaa Ali 12.09.2013 в 21:54
2

Существует не только одно место, где apt-get читает файлы конфигурации. Вы должны запустить grep proxy /etc/apt/apt.conf.d/* , и он даст вам точный файл с настройками прокси-сервера (это всего лишь пример с update вместо proxy :

grep update /etc/apt/apt.conf.d/*
/etc/apt/apt.conf.d/20apt-show-versions:// When Apt's cache is updated (i.e. apt-cache update)
/etc/apt/apt.conf.d/20packagekit:// Whenever dpkg is called we might have different updates
/etc/apt/apt.conf.d/20packagekit:// i.e. if an user removes a package that had an update
/etc/apt/apt.conf.d/20packagekit:"/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 1 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null";
/etc/apt/apt.conf.d/20packagekit:// When Apt's cache is updated (i.e. apt-cache update)
/etc/apt/apt.conf.d/20packagekit:"/usr/bin/test -e /usr/share/dbus-1/system-services/org.freedesktop.PackageKit.service && /usr/bin/test -S /var/run/dbus/system_bus_socket && /usr/bin/gdbus call --system --dest org.freedesktop.PackageKit --object-path /org/freedesktop/PackageKit --timeout 1 --method org.freedesktop.PackageKit.StateHasChanged cache-update > /dev/null; /bin/echo > /dev/null";
    
ответ дан Braiam 15.09.2013 в 03:32
1

Возможно, переменная окружения http_proxy установлена ​​на некоторый прокси. попробуйте очистить переменную (или, по крайней мере, посмотреть, имеет ли она значение)

    
ответ дан aviran 12.09.2013 в 21:53
1

Глупый способ заставить его работать - временно отключить прокси-сервер, используя system settings > Network .

Или удалите конфигурацию прокси из /etc/environment и /etc/apt/apt.conf

И добавьте конфигурацию прокси-сервера вручную после возврата прокси-сервера.

    
ответ дан prayagupd 23.09.2016 в 20:30
-1

Несмотря на то, что все порты открыты для сервера и ничего в файле конфигурации для apt, машина все еще хотела использовать прокси. снятие с охраны окружающей среды сделало трюк

    
ответ дан user294006 16.06.2014 в 11:56