Как отключить звук ударных барабанов на экране входа в систему?

111

Я бы ожидал, что Система ▸ Администрирование ▸ Экран входа в систему ▸ Воспроизведите звук входа в систему , но снятие флажка не препятствует воспроизведению звука барабана.

    
задан ændrük 05.02.2011 в 19:05
источник

15 ответов

59

Звук запуска можно отключить, отредактировав конфигурацию Unity Greeter. Выполнение следующего с терминала сделает следующее:

echo -e '[com.canonical.unity-greeter]\nplay-ready-sound = false' \
    | sudo tee -a /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Если вы используете Ubuntu 12.04 LTS, убедитесь, что у вас установлены обновления, поскольку эта функция была добавлена в обновление.

    
ответ дан Andrejs Cainikovs 25.04.2016 в 23:34
источник
58

Для Ubuntu 12.04 +

LightDM Way

Также известный как FluteFlute Slap, LightDM Way включает в себя выход из системы и на экране входа LightDM вы можете изменить громкость или даже отключить звук.

В Login Greeter вы можете увидеть том в правом верхнем углу. Регулировка громкости не влияет на громкость при запуске сеанса, поэтому вы можете MUTE использовать звук в Greeter, не отключая звук при запуске сеанса:

UbuntuTweakWay

СпособUbuntuTweakвключаетвсебязагрузкуприложенияUbuntuTweak,азатемотключениезвукаоттуда.Выполнитеследующиедействия,ивыможетесделатьэтоследующимобразом:

sudoadd-apt-repositoryppa:tualatrix/ppasudoapt-getupdatesudoapt-getinstallubuntu-tweak

ОткройтеUbuntuTweak,анавкладкеTweakвыберитеопцию«Параметрывходавсистему»,выдолжныувидетьопциюPlayLoginSound.Чтобыизменитьэто,вамнужнонажатьнакнопкублокировкивыше.

Для Ubuntu 11.10 и ниже

Перейдите к System -> Preferences -> Startup Applications

Отключитьвызов,названныйЗвуквходавGNOME

(снимитефлажокинажмите«Закрыть»)

вы также можете перейти на System -> Preferences -> Sound и отключить всю звуковую систему (например, звуки Windows, предупреждения и т. д.)

В более старой версии вы можете перейти к части «Звуковые предпочтения» и выбрать каждый звук и то, что вы хотели сделать. Он был удален около 9,04 или 9,10. Было бы хорошо, если бы он вернулся.

    
ответ дан Luis Alvarado 05.02.2011 в 19:20
54

12.04 - 16.10 (LightDM)

Вот что сработало для меня после того, как я установил 12.04 на прошлой неделе.

Эти шаги, адаптированные из Ссылка :

gksudo gedit /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override

Добавьте следующие строки:

[com.canonical.unity-greeter]
play-ready-sound = false

Сохранить, а затем запустить:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Перезагрузитесь и наслаждайтесь.

    
ответ дан K. P. MacGregor 10.09.2012 в 13:11
20

11.10 (LightDM и GDM)

Быстрое решение:

Откройте терминал и запустите команду

sudo mv /usr/share/sounds/ubuntu/stereo/desktop-login{,-disabled}.ogg  

Звук барабана Lightdm для готовности системы может быть отключен аналогичным образом

sudo mv /usr/share/sounds/ubuntu/stereo/system-ready{,-disabled}.ogg  
    
ответ дан RobinJ 15.10.2011 в 13:23
11

За 12.04

По умолчанию он отключен. Чтобы включить его, откройте терминал и запустите

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Затем измените значение для X-GNOME-Autostart-enabled на "true", т.е. X-GNOME-Autostart-enabled=true

Для 11.10

Введите на терминал gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop и измените значение NoDisplay от true до false :

Теперь перейдите в свои приложения для запуска, и вы увидите и сможете отключить необходимый параметр:

    
ответ дан Bruno Pereira 15.10.2011 в 13:26
10

10.10 (GDM)

На экране входа в систему появляется ошибка. Однако я не могу найти официальный отчет, этот пост форума подтверждает исправить.

Перейдите на страницу «Система / Администрирование / Логин». Разблокируйте его, затем отметьте «Воспроизвести входной звук».

Закройте окно, затем снова вернитесь в приложение, откройте его, затем отключите ту же опцию.

    
ответ дан Scaine 05.02.2011 в 20:43
7

Если вы используете GDM с 12.04

Чтобы отключить звуки входа, клавиша event-sounds в разделе org.gnome.desktop.sound для пользователя gdm должна быть установлена в значение false.

Для этого мы должны сначала предоставить владельцу GDM собственный домашний каталог. Откройте терминал и введите: sudo chown -R gdm:gdm /var/lib/gdm

Затем запустите:

sudo xhost +SI:localuser:gdm
sudo -u gdm gsettings set org.gnome.desktop.sound event-sounds false

и выйти из системы (или перезагрузить).

Если вы используете LightDM с 12.04

Откройте терминал с помощью Ctrl + Alt + T и введите / вставьте следующее, по одной строке за раз:

sudo xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter play-ready-sound false
exit

Что это значит, отключите параметр play-ready-sound для пользователя пользователя / диспетчера рабочего стола (lightdm).

    
ответ дан ish 10.09.2012 в 12:15
5

11.10 (LightDM и GDM)

Для удаления звука запуска:

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old 

Для включения звука запуска

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old /usr/share/sounds/ubuntu/stereo/system-ready.ogg

Для удаления звука входа (после входа в систему):

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old

Для повторного включения:

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old /usr/share/sounds/ubuntu/stereo/desktop-login.ogg
    
ответ дан Vibhav Pant 07.03.2012 в 09:03
3

11.10 (LightDM и GDM)

Это должно сработать для вас.

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Затем измените NoDisplay = на false, ect.

или удалить его:

sudo rm /usr/share/sounds/ubuntu/stereo/system-ready.ogg
    
ответ дан Ringtail 07.03.2012 в 09:02
3

11.10 (GDM)

gsettings set org.gnome.desktop.sound event-sounds false
    
ответ дан blueyed 30.09.2011 в 09:13
1

12.10 (GDM)

Ничего из этого не работает для меня с gdm. Если я отключу звук, готовый для системы (бонго), он все равно делает короткий звук барабана (один удар).

Способ его отключения:

  • Загрузитесь, войдите в gdm.
  • Переключитесь на консоль ( Ctrl + Alt + F1 )
  • Войти
  • Введите:

    export DISPLAY=:0
    sudo -H -u gdm pavucontrol
    
  • Вернитесь к gdm ( Ctrl + Alt + F8 )

  • Отключить звук в микшере. Я отключил его в «Воспроизведение» и «Устройства вывода».
  • Закройте микшер, вы можете получить сообщение о записи файла конфигурации, это безопасно.
  • Вернитесь на консоль и введите

    sudo service gdm restart
    

    , и exit для выхода из системы.

ответ дан jdm 17.07.2012 в 18:02
1

11.04 и ранее (GDM)

Запустить эту команду в терминале?

sudo -u gdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false

    
ответ дан Jorge Castro 11.09.2012 в 05:49
1

12.10 (LightDM)

Запустите ту же команду Хорхе Кастро дал , только с gdm заменено на lightdm :

sudo -u lightdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false
    
ответ дан C Schilder 27.06.2012 в 09:51
1

Самый простой способ - просто отключить звук в приветствии. Просто нажмите громкость и нажмите «отключить звук».

Это отключит звук только в приветствии.

    
ответ дан Pilot6 15.06.2015 в 12:48
0

Откройте «Настройки загрузочных приложений», выполнив поиск в тире,

Или из cog,

Найдите запись для входа в систему GNOME и удалите галочку из окна, чтобы отключить ее, или выберите ее, чтобы затем закрыть ее.

    
ответ дан Mark Rooney 07.03.2012 в 10:48
0

12.04 (LightDM)

Звук LDM LightDM не может быть отключен с помощью любой опции GUI в 12.04, и здесь есть отчет об ошибке:

Приведенные выше методы командной строки могут отключить его.

Звук после входа в систему можно легко отключить с помощью приведенных выше ответов.

    
ответ дан Eric Nemchik 07.04.2012 в 04:04