XUbuntu: Сделать Shift + NumPad работать как Windows

27

Хорошо, я некоторое время использовал Ubuntu с GNOME, но теперь я использую XUbuntu. В Ubuntu раньше была предпочтение клавиатуры, которое делает numpad более разумным, его называли «Make Shift + NumPad, работающим как Windows».

Проблема, решаемая этими параметрами, заключается в том, что когда вы нажимаете NumPad 7, она действует как клавиша «Домой», все в порядке, но если вы нажмете Shift + NumPad 7, она действует как клавиша «7», которая это не нормально, потому что я на ноутбуке, а обычный ключ «Домой» требует от меня анатомически безумного движения. В любом случае, этот параметр заставил Shift + NumPad 7 действовать как клавиша «Главная».

Я не могу найти этот параметр в XUbuntu. Как его установить?

Обновление: Графический интерфейс или командная строка не имеет значения.

    
задан Raphael R. 14.08.2011 в 20:35
источник

5 ответов

40

После некоторого grepping я нашел решение: вам нужно добавить параметр numpad:microsoft в XkbOptions. На старшем Ubuntus сделайте это в своем xorg.conf. На новых можно открыть файл /etc/default/keyboard и изменить эту строку:

XKBOPTIONS=""

к

XKBOPTIONS="numpad:microsoft"

Сохранить и перезагрузить (перезапуск X не работает, по крайней мере, не с RAlt + PrintScreen + K). Возможно, вам понадобится запустить sudo dpkg-reconfigure keyboard-configuration , чтобы изменения вступили в силу.

    
ответ дан Raphael R. 15.08.2011 в 16:52
источник
15

У Ubuntu 14.04 больше нет «Разное совместимости» в настройках клавиатуры. Редактирование /etc/default/keyboard также не является рабочим решением. Но база данных dconf содержит необходимые параметры с ключом /org/gnome/desktop/input-sources/xkb-options . Эти параметры должны быть заполнены с numpad:microsoft на что-то вроде ['grp:alt_shift_toggle', 'grp_led:scroll', 'numpad:microsoft'] вручную в dconf-редакторе или с помощью этого скрипта:

# !/bin/bash
old='gsettings get org.gnome.desktop.input-sources xkb-options'
new='echo $old | sed "s/'numpad:microsoft'//g" | sed -r "s/(, )+/, /g" | sed -r "s/(, )?]/, 'numpad:microsoft']/"'
gsettings set org.gnome.desktop.input-sources xkb-options "$new"
    
ответ дан tbrush 22.07.2014 в 08:26
12

Рад, что нашел ваш пост. Используя Natty Narwhal, я нашел аналогичный вариант в настройках клавиатуры.

  1. Поиск клавиатуры
  2. Вкладка «Макеты»
  3. Нажмите кнопку «Параметры»
  4. Развернуть различные параметры совместимости
  5. Проверить «Смена с помощью цифровых клавиш клавиатуры работает как в MS Windows»
  6. Закрыть, и вы хорошо!
ответ дан Kit Menke 16.08.2011 в 04:40
9

В Xubuntu 16.04 параметр XKBOPTIONS (XKBOPTIONS="numpad: microsoft") в / etc / default / keyboard игнорируется - я считаю, что это ошибка.

Я использую следующую команду в качестве обходного пути:
setxkbmap -option 'numpad:microsoft'

Для запуска указанной команды автоматически при запуске графического рабочего стола, я создал запись автозапуска приложения:
Меню > Настройки > Сессия и запуск > Приложение Autostart > Добавить

          Name: Make Shift+NumPad work like MS Windows
Description: whatsoever
   Command:setxkbmap -option 'numpad:microsoft'

    
ответ дан F.M. 26.09.2016 в 23:57
2

У меня была аналогичная проблема на lubuntu. Я попытался изменить файл /etc/default/keyboard , но это не помогло.

Я думаю, что причина может заключаться в том, что у меня был сменщик макетов в моей системе. Однако добавление numpad:microsoft в поле «Расширенные параметры setxkbmap» в параметрах обработчика макета клавиатуры действительно сработало. Мне даже не пришлось перезагружать X.

    
ответ дан Alexander Belov 02.04.2016 в 18:35