Спящий режим отсутствует на экране входа в систему

16

Повторное включение спящего режима путем добавления правила в набор политик добавило возможность спящего режима на сеанс рабочего стола, как ожидалось, но не для экрана входа в систему.

Как включить спящий режим прямо с экрана входа 14.04?

    
задан Dusan Milosevic 07.02.2014 в 19:51
источник

7 ответов

5

Адрес файла набора политик изменен в Ubuntu 14.04.

Следуйте тем же шагам , что и раньше, за исключением замены файла:

/var/lib/polkit-1/localauthority/10-local.d/hibernate.pkla

с этим:

/var/lib/polkit-1/localauthority/50-local.d/hibernate.pkla

Попробуйте этот

sudo gedit /var/lib/polkit-1/localauthority/10-local.d/hibernate.pkla

Наконец, перезапустите nautilus, выполнив nautilus -q , и индикатор должен появиться.

    
ответ дан Subhas 01.05.2014 в 13:17
источник
13

Вот решение. Hibernate в сеансе рабочего стола и экране входа в систему , как показано ниже:

Настольная сессия:

Экранвходавсистему:

Сначала откройте терминал и добавьте следующее:

sudogedit/var/lib/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Теперьоткрытtxt-файл,добавьтеследующиестроки:

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Сохранить и перезагрузить вашу систему после того, как этот спящий режим должен появиться и работать хорошо.

    
ответ дан nux 26.02.2014 в 23:03
9

Конфигурация для спящего режима уже находится в файле

/var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

Просто откройте этот файл и включите спящий режим: ResultActive=yes Полученный код выглядит следующим образом:

[Disable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

и

[Disable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

Вот и все. Теперь вы увидите вариант спящего режима в диалоговом окне питания и войдите в систему

    
ответ дан Maug Lee 10.05.2014 в 12:10
4

Это ошибка, которая, мы надеемся, будет решена в Ubuntu 14.04. Невозможно включить спящий режим на экране входа в систему.

    
ответ дан user251455 01.03.2014 в 21:47
3

Если у вас есть многопользовательская настройка в Ubuntu, вам также нужно добавить этот фрагмент:

[Re-enable hibernate for multiple users by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate-multiple-sessions
ResultActive=yes
    
ответ дан morhook 17.06.2014 в 15:00
0

Откройте терминал и введите следующую команду:

sudo gedit /var/lib/polkit-1/localauthority/50-local.d/hibernate.pkla

Скопируйте и вставьте этот код в файл:

[Re-enable Hibernate]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

Сохраните файл и перезапустите.

    
ответ дан Liso 01.03.2014 в 00:15
0

Причина, по которой спящий режим отсутствует, заключается в том, что функция Hibernate Ubuntu всегда не работает на многих компьютерах. Для новых моделей оборудования функция Hibernate часто не работает по умолчанию. В некоторых случаях функция Hibernate даже приведет к потере данных.

Но если u хочет использовать его, вы можете сделать следующее:

  1. Спящий режим находится в разделе «Питание - > Когда мощность критически низка».

  2. включить кнопку спящего режима:

    Сначала проверьте, поддерживает ли ваш компьютер спящий режим, введя следующие коды в терминале:

    pm-hibernate
    

    , если он переходит в спящий режим, выполните следующий шаг:

    а. откройте файл:

    sudo nano /etc/polkit-1/localauthority/50-local.d/com.ubuntu.desktop.pkla
    

    б. затем отредактируйте следующим образом:

    [Re-enable hibernate by default]
    Identity=unix-user:*
    Action=org.freedesktop.upower.hibernate
    ResultActive=yes
    
ответ дан Harun Guna 26.02.2014 в 01:54