Каков лучший инструмент Wireframing? [закрыто]

17

Я ищу что-то похожее на iPlotz или Mockup.

Я нашел проект карандаша , но для него требуется xulrunner-1.9 (который, кажется, несовместимый с xulrunner-1.9.2), чтобы работать как отдельное приложение. Его можно использовать как плагин firefox ... но он немного медленнее.

Ошибка на моем рабочем столе (Ubuntu 10.04): Could not find compatible GRE between version 1.9.1 and 1.9.2.*

Кто-нибудь знает другое программное обеспечение?

Изменить : предпочтительным является программное обеспечение с открытым исходным кодом, и не имеет значения, свободно ли он.

    
задан Strae 05.11.2010 в 16:32
источник

6 ответов

13

WireframeSketcher - это быстрый инструмент для создания каркасов для Eclipse-IDE, таких как Aptana, Zend Studio и т. п. Он также поставляется как отдельная версия для всех основных платформ, включая Ubuntu. Попробуйте.

    

ответ дан Peter Severin 04.12.2010 в 04:10
источник
6

После некоторых исследований я нашел Dia, и это именно то, что я искал: простой, открытый и стабильный.

Возможно, я плохо объяснил свои потребности. Для разработки макетов я использовал не только программное обеспечение, но и то, что обеспечивало возможность построения блок-схем. Я тоже попробовал ArgoUML. Это выглядит великолепно, немного сложнее.

    
ответ дан Strae 05.11.2010 в 23:43
2

Возможно, это не так сложно, но вы также можете попробовать Gazpacho, дизайнер пользовательского интерфейса. Он находится в репозиториях.

    
ответ дан radioboy 05.11.2010 в 20:16
2

Попробуйте Balsamiq . Он использует Adobe Air и работает правильно на Ubuntu.

    
ответ дан Kendor 05.11.2010 в 19:01
2

Я немного поработал и нашел это . В соответствии с этим, после установки последней версии Firefox и Pencil (последняя версия Pencil не входит в deb по умолчанию, поэтому получите rpm и установите с alien -i <rpmname> ), отредактируйте application.ini от карандаша папку в /usr/lib и изменить максимальную версию, указанную в версии Firefox, которую вы имеете (основной версии выпуска достаточно, например, 16). Затем отредактируйте usr/bin/evoluspencil , что не что иное, как скрипт для вызова xulrunner . Измените /usr/bin/xulrunner на /usr/bin/firefox . Теперь открытие карандаша из меню приложений будет работать очень хорошо, и Firefox не должен быть открыт для его запуска.

    
ответ дан Subhamoy Sengupta 25.09.2012 в 16:01
1

Как и в случае с Pencil 1.2, он запускается на xulrunner 1.9.2 (я на Ubuntu 11.04 64-бит).

Сначала установите xulrunner 1.9.2:

sudo apt-get install xulrunner-1.9.2-gnome-support 

Если у вас все еще есть проблемы или вы на 64-битном, запустите его следующим образом:

xulrunner /opt/pencil/application.ini 
    
ответ дан Hendy Irawan 27.05.2011 в 00:58