Как изменить браузер по умолчанию, с которым konsole открывает URL-адреса?

17

У меня есть google-chrome, который установлен в качестве моего браузера по умолчанию в приложениях Ubuntu и gnome. Однако при использовании konsole все ссылки открываются в konqueror, а не google-chrome!

Я попытался настроить браузер по умолчанию: sudo update-alternatives --config 'x-www-browser'

Это работает для открытия ссылок в gnome-terminal и других программ gnome ... но не kde, таких как konsole. Кроме того, не существует программы kcontrol для доступа к настройкам kde.

Кто-нибудь знает способ установить настройку kde для этого при использовании gnome?

EDIT: из того, что я могу сказать, у меня есть все связанные настройки, которые я могу придумать ...

grep 'chrome' ~/.local/share/applications/mimeapps.list

x-scheme-handler/http=google-chrome.desktop;firefox.desktop;
x-scheme-handler/https=google-chrome.desktop;firefox.desktop;
x-scheme-handler/http=google-chrome.desktop
x-scheme-handler/https=google-chrome.desktop
x-scheme-handler/chrome=firefox.desktop
text/html=google-chrome.desktop
application/x-extension-htm=google-chrome.desktop;firefox.desktop;
application/x-extension-html=google-chrome.desktop;firefox.desktop;
application/x-extension-shtml=google-chrome.desktop;firefox.desktop;
application/xhtml+xml=google-chrome.desktop;firefox.desktop;
application/x-extension-xhtml=google-chrome.desktop;firefox.desktop;
application/x-extension-xht=google-chrome.desktop;firefox.desktop;
x-scheme-handler/about=google-chrome.desktop
x-scheme-handler/unknown=google-chrome.desktop

grep 'chrome' /usr/share/applications/defaults.list

text/html=firefox.desktop;google-chrome.desktop
text/xml=firefox.desktop;google-chrome.desktop
application/xhtml_xml=google-chrome.desktop
x-scheme-handler/http=firefox.desktop;google-chrome.desktop
x-scheme-handler/https=firefox.desktop;google-chrome.desktop
x-scheme-handler/ftp=google-chrome.desktop

И нет ссылок на konqueror:

grep -i 'konqueror' /usr/share/applications/defaults.list
grep -i 'konqueror' ~/.local/share/applications/mimeapps.list
grep -i 'kon' /usr/share/applications/defaults.list
grep -i 'kon' ~/.local/share/applications/mimeapps.list
    
задан TrinitronX 19.09.2011 в 23:35
источник

4 ответа

11

Я столкнулся с этой проблемой при запуске konsole в Ubuntu / Unity. Когда все остальное не удалось, я отредактировал ~/.kde/share/config/kdeglobals :

[General]
BrowserApplication[$e]=!google-chrome

Выход из системы, вход в систему - bingo!

    
ответ дан vadim 12.11.2012 в 19:33
источник
8

Проблема с «приложениями по умолчанию» в настоящее время заключается в том, что разные программы ищут значения по умолчанию по-разному. Традиционным подходом можно назвать файлы $BROWSER и mailcap .

Но в последнее время многие графические программы начали полагаться на .desktop файлов, и есть набор xdg-* инструментов, предназначенных для управления и получения некоторых значений по умолчанию.

Try:

xdg-settings get default-web-browser

Если это показывает konqueror, то

xdg-settings set default-web-browser google-chrome.desktop

Следует исправить это, по крайней мере, если доверять документации xdg-settings .

Теперь все, что xdg-settings делает, говорит с текущей рабочей средой рабочего стола, поэтому это должно быть GNOME , и оно должно быть уже установлено на google-chrome ...

    
ответ дан njsg 23.05.2012 в 13:25
4

Это правильное поведение Konsole . Он открывает ссылки в браузере по умолчанию KDE. Если браузер не указан, он запустит Konqueror . Поскольку вы не можете найти упоминание Konqueror в файлах конфигурации, последнее в точности соответствует вашему случаю.

Чтобы настроить предпочтительный браузер, выполните следующие действия (я полагаю, что Консоль и Konqueror от KDE4 ):

  • откройте настройки системы KDE (например, запустив Kcontrol )
  • выберите Приложения по умолчанию (это должно быть где-то в разделе «Внешний вид рабочей области»)
  • найдите раздел Веб-браузер
  • напишите [путь и] имя вашего предпочтительного браузера

Надеюсь, что это поможет.

    
ответ дан Vitalie Ciubotaru 25.05.2012 в 12:04
0

Посмотрите эту страницу: Ссылка

Существует приложение настроек по умолчанию для системы kde. Однако, поскольку вы в gnome, проверьте этот файл:

/usr/share/applications/defaults.list

Кроме того, загляните сюда:

~/.local/share/applications/mimeapps.list

Удалите ссылки на konqueror.

    
ответ дан balloons 17.02.2012 в 21:25