Установка Skype на Ubuntu 13.04 64-разрядная

17

Вот что я пробовал:

$ sudo apt-get install skype
[sudo] password for umpirsky: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype : Depends: skype-bin
E: Unable to correct problems, you have held broken packages.

$ sudo apt-get install skype-bin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 skype-bin:i386 : Depends: libasound2:i386 (>= 1.0.23) but it is not going to be installed
                  Depends: libc6:i386 (>= 2.7) but it is not going to be installed
                  Depends: libgcc1:i386 (>= 1:4.1.1) but it is not going to be installed
                  Depends: libqt4-dbus:i386 (>= 4:4.5.3) but it is not going to be installed
                  Depends: libqt4-network:i386 (>= 4:4.8.0) but it is not going to be installed
                  Depends: libqt4-xml:i386 (>= 4:4.5.3) but it is not going to be installed
                  Depends: libqtcore4:i386 (>= 4:4.7.0~beta1) but it is not going to be installed
                  Depends: libqtgui4:i386 (>= 4:4.8.0) but it is not going to be installed
                  Depends: libqtwebkit4:i386 (>= 2.2~2011week36) but it is not going to be installed
                  Depends: libstdc++6:i386 (>= 4.6) but it is not going to be installed
                  Depends: libx11-6:i386 but it is not going to be installed
                  Depends: libxext6:i386 but it is not going to be installed
                  Depends: libxss1:i386 but it is not going to be installed
                  Depends: libxv1:i386 but it is not going to be installed
                  Depends: libssl1.0.0:i386 but it is not going to be installed
                  Depends: libgl1-mesa-glx:i386 but it is not going to be installed
                  Recommends: sni-qt:i386 but it is not going to be installed
                  Recommends: libasound2-plugins:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Я также пробовал все предложения от Не удалось установить Skype на 64-битном Ubuntu , но никто из них не работал для меня.

Список моих источников:

$ cat /etc/apt/souces.list /etc/apt/sources.list.d/*.list
cat: /etc/apt/souces.list: No such file or directory
deb http://downloads.hipchat.com/linux/apt stable main
deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/screencloud/ubuntu raring main #Added by software-center; credentials stored in /etc/apt/auth.conf
deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/splashtop-streamer/ubuntu raring main #Added by software-center; credentials stored in /etc/apt/auth.conf
deb https://private-ppa.launchpad.net/commercial-ppa-uploaders/vkaudiosaver/ubuntu raring main #Added by software-center; credentials stored in /etc/apt/auth.conf
deb http://ppa.launchpad.net/upubuntu-com/chat/ubuntu quantal main
# deb-src http://ppa.launchpad.net/upubuntu-com/chat/ubuntu raring main

Пожалуйста, помогите.

UPDATE:

Я попытался установить teamviewer и получил аналогичную ошибку:

UPDATE:

Я только что установил новый Ubuntu 13.04 и получил ту же ошибку.

UPDATE:

Я установил Skype с помощью:

sudo dpkg --force-depends -i skype-ubuntu-precise_4.2.0.11-1_i386.deb

Но не может его запустить:

$ ll /usr/bin | grep skype
-rwxr-xr-x  1 root root    30701056 мај  7 01:42 skype*
$ /usr/bin/skype
bash: /usr/bin/skype: No such file or directory

UPDATE:

Я могу воспроизвести это без установки Ubuntu с живого компакт-диска.

    
задан umpirsky 08.09.2013 в 19:47
источник

13 ответов

13

Установка из источников

Сначала следуйте всем инструкциям, перечисленным в следующем сообщении, чтобы избавиться от неудовлетворенных зависимостей:

  • Как разрешить неудовлетворенные зависимости после добавления PPA?

Затем установите Skype, как указано здесь:

  • Невозможно установить Skype на 64-битном Ubuntu

Перефразируя, это правильный способ установить Skype на 64-разрядную версию Ubuntu:

sudo dpkg --add-architecture i386
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install skype

Установка из файла .deb в Ubuntu 12.04+ на 32 или 64-разрядный

  1. Скачать Skype для Ubuntu 32-bit Precise i386 .
  2. Когда загрузка закончена, откройте загруженный файл как обычно из Nautilus.
  3. При появлении запроса выберите Открыть с помощью программного обеспечения Ubuntu Software Center (по умолчанию).
  4. В правой части окна программного центра Ubuntu, который открывается, выберите Установить .
  5. На всякий случай, если шаг 4 не работает, попробуйте с терминала:

    sudo dpkg --force-depends -i skype-ubuntu-precise_4.2.0.11-1_i386.deb
    

    Обратите внимание, что этот шаг 5 не идеален, но я почти уверен, что это сработает.

Источник : Начало работы с Skype для Linux .

    
ответ дан Radu Rădeanu 10.09.2013 в 20:41
7

Честно говоря, я думаю, что есть решение, которое проще, чем все другие ответы.

Если я правильно помню, я установил skype на 13.04 64 бит, перейдя на страницу загрузки skype.com, и выбрав Ubuntu 12.04. Затем вы открываете его с помощью программного центра, и он заботится о вас.

Я думаю, что это стоит попробовать. Если это не сработает, оставьте комментарий, и я удалю ответ.

    
ответ дан don.joey 13.09.2013 в 09:19
3

Как я могу понять из сообщения, ответов и комментариев (ссылки / gist тоже), вы сделали опечатки и есть несколько источников с дублирующимися записями.

  1. Сначала, когда вы добавили опечатку при добавлении архитектуры, исправьте ее, используя: sudo dpkg --remove-architecture i38
  2. Чтобы избавиться от повторяющихся записей, проверьте этот ответ: Как удалить эту дублируемую запись sources.list?
  3. Теперь откройте "Software & amp; Обновления ", перейдите на вкладку" Другое программное обеспечение "и снимите отметку со всего, что вы не хотите использовать. Затем запустите sudo apt-get update
  4. Наконец, используйте ответ , указанный Radu :

    First, follow all instructions listed in the following post to get rid of unmet dependencies:

    • How do I resolve unmet dependencies after adding a PPA? As for the unmet dependencies that don't have a 64-bit version, install the i386 (32-bit) one by searching that package name in 'Ubuntu Software Centre'.

    Then install Skype as is specified here:

    • Unable to install Skype on 64bit Ubuntu

    Paraphrasing, this is the correct way to install Skype on Ubuntu 64-bit:

    sudo dpkg --add-architecture i386
    sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
    sudo apt-get update
    sudo apt-get install skype
    

Совет. Команды копирования вставки.

    
ответ дан TomKat 23.09.2013 в 17:02
1

Чтобы установить skype, нет ничего проще:

sudo rename -n 's/\.list$/.list.disable/g' /etc/apt/sources.list.d/*.list
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install aptitude
sudo aptitude full-upgrade
sudo aptitude install skype
    
ответ дан Braiam 08.09.2013 в 20:14
0

Вы должны использовать эти команды

sudo dpkg --add-architecture i386   # only needed for 64-bit systems
sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install ia32-libs
sudo apt-get install skype skype-bin sni-qt:i386

Если это работает, вы можете использовать Skype, иначе попробуйте выполнить команду ниже

sudo apt-get -f install

Если ничего из этого не работает, вы можете попробовать и получить Skype от официального .deb и установить из него

wget http://download.skype.com/linux/skype-ubuntu-precise_4.2.0.11-1_i386.deb
sudo dpkg -i skype-ubuntu-precise_4.2.0.11-1_i386.deb

UPDATE:

Попробуйте выполнить следующие команды:

sudo apt-get clean
sudo apt-get autoclean
sudo apt-get -f install

Затем повторите команды сверху, начиная с sudo apt-get install ia32-libs

    
ответ дан kiri 08.09.2013 в 20:53
0

Перейдите в Ссылка и создайте исходный список. Измените исходный список.

nano /etc/apt/sources.list

После этого обновите и обновите свою систему.

sudo apt-get clean && sudo apt-get update && sudo apt-get upgrade 

Теперь попробуйте установить skype.     

ответ дан Ketankumar Patel 13.09.2013 в 09:40
0

Я пошел на skype.com и загрузил версию ubuntu 12.04, а затем открыл магазин программного обеспечения и попросил меня установить добавление, чтобы он работал на моем компьютере, и теперь он работает нормально. Я бы попробовал это.

    
ответ дан Thomas 15.09.2013 в 19:34
0

Этот метод автоматически определит архитектуру ОС и установит последний скайп:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update
sudo apt-get install skype && sudo apt-get -f install

Примечание. Если вам нужно установить libqt4-webkit, для этого я использовал Synaptic

Попробуйте следующее:

sudo dpkg --add-architecture i386
sudo apt-get install ia32-libs
sudo apt-get update
wget -O skype.deb http://download.skype.com/linux/skype-ubuntu-precise_4.2.0.11-1_i386.deb
sudo dpkg -i skype.deb
sudo apt-get -f install

Изменить 2:

Попробуйте это. Просто нажмите Ctrl + Alt + T на клавиатуре, чтобы открыть терминал. Когда он откроется, запустите следующие команды:

sudo apt-get install lib32stdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1

Затем Загрузить Skype для Ubuntu 32-разрядный Точный i386. Выберите, чтобы открыть с помощью Ubuntu Software Center, после открытия нажмите «Установить».

Часть информации из Nooslab

    
ответ дан Mitch 15.09.2013 в 17:57
0

Я просто снимаю в темноте здесь, но с экрана снизу:

Ссылка

Попробуйте перейти в «Центр программного обеспечения Ubuntu» и введите поиск «libasound2: i386».

Я сделал и получил этот результат:

Shared library for ALSA applications
libasound2:i386

ссылка на экранный снимок - Ссылка

Проверьте, не установлены ли они. Если нет, тогда попробуйте установить это сначала, а затем установите свой Skype ...

Надеюсь, что это сработает, удачи!

@umpirsky Как сказано в вашем снимке экрана, libasound2: i386 зависит от файла libc6, поэтому перейдите в Ubuntu Software Center и введите libc6 и попробуйте установить его в первую очередь. Если он не работает, проверьте, не зависит ли libc6 от какого-либо файла и попытайтесь установить его, а затем выполните свой путь назад ...

В ошибке указано: "Further more there could be a conflict between software packages which are not allowed to be installed at the same time" . Это может быть проблема, с которой вы сталкиваетесь, поэтому вам придется устанавливать их отдельно.

«EDIT» и downarrow;

Как сказал «Saurav Kumar» в начале, просто установите « Synaptic » и перейдите в список, добавив и установка списка по одному ...

Надеюсь, это поможет, удачи ударирски ...

    
ответ дан SoCalDiegoRob 16.09.2013 в 22:00
0

Похоже, что последнее обновление Ubuntu исправило эту проблему.

Я попытался установить сегодня, и он прошел хорошо Ссылка .

Спасибо всем, кто пытался помочь!

    
ответ дан umpirsky 16.10.2013 в 12:27
0

Используете ли вы главный сервер в качестве сервера dist?

У меня была такая же проблема, с которой мне удалось исправить , изменив мой сервер dist с локального сервера на «Основной сервер» в «Системные настройки» > «Программное обеспечение и обновления».

К сожалению, я не смог найти командную строку для простого изменения сервера dist, но вы всегда можете отредактировать /etc/apt/sources.list и изменить сервер.

Надеюсь, что это поможет.

    
ответ дан Amit Kumar 10.03.2014 в 08:31
0

Я сталкивался с такой же проблемой и пытался установить libqtwebkit с помощью apt-get или aptitude, ни dkpg, ни gedi

Вот как я решаю проблему с зависимостями:

wget  http://th.archive.ubuntu.com/ubuntu/pool/main/g/gst-plugins-base0.10/libgstreamer-plugins-base0.10-0_0.10.36-1_i386.deb

dpkg -i libgstreamer0.10-0_0.10.36-1ubuntu1_i386.deb

wget http://th.archive.ubuntu.com/ubuntu/pool/main/g/gst-plugins-base0.10/libgstreamer-plugins-base0.10-0_0.10.36-1_i386.deb

dpkg -i libgstreamer-plugins-base0.10-0_0.10.36-1_i386.deb.1

wget http://th.archive.ubuntu.com/ubuntu/pool/main/q/qtwebkit-source/libqtwebkit4_2.2.1-1ubuntu4_i386.deb

dkpg -i libqtwebkit4_2.2.1-1ubuntu4_i386.deb

wget download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb

dpkg -i skype-ubuntu-precise_4.3.0.37-1_i386.deb
    
ответ дан Sam Wong 15.09.2014 в 05:26
0
  1. Чтобы Skype работал в Ubuntu 13.04 Raring Ringtail с проприетарные драйверы Nvidia / AMD, во-первых, мы переименуем Skype исполняемый файл из «skype» в «skype-bin»:

    sudo mv /usr/bin/skype /usr/bin/skype-bin
    
  2. Теперь давайте создадим файл под названием «skype» в / usr / bin / - для этого мы запустим текстовый редактор как root (я буду использовать Gedit в инструкции ниже):

    gksu gksu gedit /usr/bin/skype
    

(Я использовал «gksu» дважды в команде выше, поэтому Gedit не открывает пустую вкладку вместе с / usr / bin / skype)

В этом файле вставьте следующее:

#!/bin/sh
export LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1
exec skype-bin "[email protected]"

Затем сохраните файл.

И, наконец, запустите в терминале следующую команду:

sudo chmod 0755 /usr/bin/skype

Вот и все. Теперь Skype должен работать в Ubuntu 13.04 Raring Ringtail.

Если вы хотите отменить изменения, сделанные с помощью приведенных выше инструкций, используйте следующие команды:

sudo rm /usr/bin/skype
sudo mv /usr/bin/skype-bin /usr/bin/skype

Источник

ответ дан blade19899 13.09.2013 в 08:00