Как понизить Firefox с 30 до 28?

17

Я случайно sudo apt-get upgrade (в то время как инструкции c / p-ing делают что-то и не замечают, что это не sudo apt-get update ), и он обновил Firefox с 28 до 30. Теперь мои меню полностью перепутаны , поэтому я хочу, чтобы FF28 вернулся, и меня не интересуют мнения о том, как более новые версии улучшены (в настоящее время их больше нет в форумах поддержки Mozilla вместо фактических ответов).

Кроме того, загрузка firefox-mozilla-build_28.0-0ubuntu1_i386.deb и попытка его использования, по-видимому, не работают, программный центр Ubuntu говорит:

Breaks existing package 'firefox' that conflict: 'firefox'.

    
задан Danijel 21.07.2014 в 13:45
источник

3 ответа

3

Попробуйте сначала удалить его:

sudo apt-get purge firefox

Затем вы можете установить, используя firefox-mozilla-build_28.0-0ubuntu1_i386.deb

    
ответ дан Back.Slash 21.07.2014 в 13:47
источник
60

Run

apt-cache show firefox | grep Version

, чтобы получить список доступных версий Firefox. В моем 14.04 это результат:

Version: 32.0+build1-0ubuntu0.14.04.1
Version: 28.0+build2-0ubuntu2

Далее скажите APT, какую версию установить:

sudo apt-get install firefox=28.0+build2-0ubuntu2

Затем вы должны сообщить APT, чтобы он не обновлялся до новой версии. Согласно Ссылка , есть много способов сделать это, я выбрал:

sudo apt-mark hold firefox

Как только вы хотите отпустить свой Firefox 28 и снова следовать обычным выпускам, просто выполните:

sudo apt-mark unhold firefox
sudo apt-get upgrade

В качестве альтернативы вы можете указать доступные версии:

apt-cache policy firefox

PS: Firefox сохраняет все свои настройки в папке ~ / .mozilla. Эта папка не будет изменена вышеуказанными командами, поэтому все ваши настройки должны сохраняться. Если вы хотите быть в безопасности, выполните резервное копирование настроек до того, как вы понизите рейтинг:

cp -ra ~/.mozilla ~/.mozilla.backup
    
ответ дан alfonx 11.09.2014 в 09:21
1

После прочтения ответов мой ответ немного отличается от приведенных выше, поскольку он служил моей цели. Инструкция состоит в том, чтобы понизить до любой версии, когда существующая версия firefox еще в системе.

  1. Сначала найдите нужную версию firefox:

    • Перейдите по ссылке: Ссылка
    • Перейдите к определенной версии (например, /35.0.1/linux-x86_64/en-US/ ) и загрузите файл .tar.bz2
  2. Перейдите в каталог, в который вы загрузили файл .tar.bz2 и запустили его в терминал (он распакует ваш файл):

    tar xvjf firefox-35.0.1.tar.bz2 (измените имя файла по своему вкусу)

    Эта команда распакует ваш файл tar.bz2 и создаст папку firefox

  3. Затем запустите в терминале:

    which firefox

    Это даст вам что-то вроде: /usr/bin/firefox . Это местоположение вашего firefox. Удалите папку (так как вы позже ее замените другой папкой firefox)

  4. Удалите все старые профили firefox из каталогов:

    • .mozilla/firefox/

    И, возможно, это тоже (но я этого не делал):

    • /etc/firefox/
    • /usr/lib/firefox/
    • /usr/lib/firefox-addons/
  5. Скопируйте папку firefox с шага 2. в /usr/bin/firefox , и все будет сделано. Запустите свой firefox, как вы запускаете normaly, и вы запустите эту конкретную загруженную версию.

  6. Отключите обновление в привилегиях - > Дополнительно - > Обновления, если вам нужно сохранить версию.

Боковое примечание:

Если вам нужно это для ruby и selenium , то перед этим проверьте, какая версия firefox вам действительно нужна.

Перейдите в Ссылка и найдите свою версию селена и проверьте, какую версию Firefox она поддерживает. Например, найдите что-то вроде этого: Firefox support up to 35

    
ответ дан Aleks 09.09.2016 в 08:45