Как установить postgresql 9.4

17

После попытки apt-get install postgresql-9.4 , обновления, повторного попыток и т. д. и т. д. Кажется, я не могу его установить:

 Couldn't find any package by regex 'postgresql-9.4'

Я знаю, что в askubuntu есть аналогичный вопрос, но ответ там тоже не работает.

Мне нужна postgresql версия 9.4, потому что я делаю pg: backup из Heroku, и я получаю this , если у меня нет 9.4.

Большое спасибо за вашу помощь.

    
задан alejoss 08.06.2015 в 20:29
источник

4 ответа

41

Эта команда устанавливает последнюю версию для вашего распространения:

sudo apt-get install postgresql

postgresql-9.4 доступно с Utopic.

Источник

здесь является пошаговое руководство по установке Postgesql 9.4 для вашего Ubuntu (утопический, надежный, точный , Lucid).

sudo add-apt-repository "deb https://apt.postgresql.org/pub/repos/apt YOUR_UBUNTU_VERSION_HERE-pgdg main" 

Для надежного:

sudo add-apt-repository "deb https://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main"

Чтобы получить версию ubuntu:

lsb_release -sc

Теперь импортируйте открытый ключ и установите:

wget --quiet -O - https://postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add - 
sudo apt-get update
sudo apt-get install postgresql-9.4
    
ответ дан A.B. 08.06.2015 в 20:37
источник
11

Используйте следующие команды (команда способна получить вашу версию Ubuntu, нет необходимости в ручном изменении):

sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ $(lsb_release -cs)-pgdg main" > /etc/apt/sources.list.d/pgdg.list'
wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | sudo apt-key add -
sudo apt-get update
sudo apt-get install postgresql-9.4 pgadmin3

Источник: Как установить PostgreSQL 9.4 в Ubuntu / Linux Mint

    
ответ дан Vipin raj 28.11.2015 в 09:07
6

Вы можете установить его, запустив

sudo apt-get install postgresql

Версия 9.3 будет установлена ​​для 14.04, 9.4 для 14.10 и 15.04.

Если вам нужно 9.4 с Ubuntu 14.04, вы можете установить его, как описано на сайте postgresql

    
ответ дан Pilot6 09.06.2015 в 16:30
0

Если вы хотите установить PostgreSQL 9.5 в Ubuntu в определенной версии, например Ubuntu 14, выполните следующие действия:

Создайте файл /etc/apt/sources.list.d/pgdg.list и добавьте строку для репозитория:

sudo sh -c 'echo "deb http://apt.postgresql.org/pub/repos/apt/ trusty-pgdg main"> /etc/apt/sources.list.d/pgdg.list'

Импортировать ключ подписи репозитория и обновить списки пакетов:

wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | \
sudo apt-key add -
sudo apt-get update
sudo apt-get install postgresql-9.5
    
ответ дан Shariful Islam 10.01.2017 в 08:23