Ubuntu 16.04 LTS Network Manager не может добавить VPN - greyed out

16

Я пытаюсь добавить VPN в мою сеть, но опция greyed out.

Снимок экрана с индикатором greyed-out

Я установил network-manager-openvpn , но все равно не повезло. При редактировании моего подключения не отображаются настройки или вкладки VPN.

Я был бы признателен, если бы кто-нибудь мог указать мне в правильном направлении!

РЕДАКТИРОВАТЬ . Если у кого-то еще есть эта проблема, формулировка «Добавить VPN-соединение» вводит в заблуждение, поскольку она сообщает вам, что вам нужно добавить VPN-соединение , а не то, что вы должны нажать, чтобы добавить один оттуда.

Итак, выберите «Редактировать подключения», «Добавить», а затем выберите VPN.

    
задан Harmonic 09.04.2017 в 19:52
источник

3 ответа

30

В случае, если у кого-либо еще есть эта проблема, формулировка «Добавить VPN-соединение» вводит в заблуждение, поскольку она сообщает вам, что вам нужно добавить VPN-соединение , а не то, что вы должны нажать на добавьте один оттуда.

Итак, выберите «Редактировать подключения», «Добавить», а затем выберите VPN.

    
ответ дан Harmonic 09.04.2017 в 20:05
источник
7

Недавно я настроил VPN на Xubuntu 16.04 LTS. Это то, что я должен был сделать:

sudo apt install openvpn
sudo apt install network-manager-openvpn-gnome 

Я использовал network-manager-openvpn-gnome вместо network-manager-openvpn, чтобы получить возможность импортировать файлы конфигурации VPN.

После этого я мог бы пойти:

  1. Изменить подключения в нижней части меню
  2. Нажмите кнопку Добавить в следующем окне
  3. Выберите тип подключения
  4. Импортировать сохраненную конфигурацию VPN

После этого я смог отредактировать VPN-соединение с помощью

  1. Изменить подключения ... в нижней части меню
  2. Выберите VPN-соединение, которое я хочу изменить
  3. Нажмите кнопку Изменить

    
ответ дан fliegenpilzmann 10.04.2017 в 02:23
3

Простым способом является использование команды на терминале:

nm-connection-editor

nm-applet обычно запускается при входе в диспетчер сеансов рабочего стола и его не нужно запускать вручную.

В некоторых версиях Ubuntu были проблемы с политикой безопасности.

Чтобы решить эту проблему, вы должны отредактировать файл «org.freedesktop.NetworkManager.policy» в / usr / share / polkit-1 / actions /

sudo -H gedit /usr/share/polkit-1/actions/org.freedesktop.NetworkManager.policy

И измените это действие:

<action id="org.freedesktop.NetworkManager.settings.modify.own">
.
.
.
<allow_inactive>no</allow_inactive>

к

<allow_inactive>yes</allow_inactive>

Затем перезапустите сетевой менеджер

sudo systemctl restart network-manager
    
ответ дан Marco A. Pivetta 28.01.2017 в 21:50