Разрывают (нет Vsync) в фильмах (собственный драйвер Nvidia)

18

Это больше KDE, чем вопрос Ubuntu, но ... У меня видны разрывы на экране. Состав KDE, флеш-видео в Firefox и простые игры, такие как kpat, vsynced, но в парных играх и в фильмах наблюдается четкое постоянное разрывание. Если я отключу vsync повсюду, разрыв будет вдвое заметнее, так что это не просто графический процессор, игнорирующий настройки.
Что меня больше всего беспокоит, что у меня такая же проблема на многих разных установках. У всех эта проблема, и никто не заботится?
Моя настройка

  • Kubuntu (последние несколько версий) или OpenSuse или Gentoo.
  • KDE 4.12 - 4.13
  • Nvidia GTX 260, 570, TITAN, разные версии драйверов.
  • Я смотрю фильмы в SMplayer с бэкэндом mplayer2. VLC имеет ту же проблему.

Что я пробовал (и это не помогло)

  • Включение и выключение в разных конфигурациях настроек Vsync в настройках nvidia и эффектах KDE Desktop.
  • Переключение параметров Mplayer и direct rendering .
  • Отключение адаптивного режима питания в настройках nvidia.
  • Отключение компоновки
  • Изменение монитора Hz
  • Запуск mplayer из CLI
  • Выполнение ритуалов и жертвоприношений

Что работало (но это не приемлемое решение)

  • Отключение KDE и запуск Mplayer в чистом X сеансе
  • Переход в нуворив и отключение композиции и открытие видео в полноэкранном режиме - без какой-либо части он все еще разрывается.

Прошу совета.

ОБНОВЛЕНИЕ 1 . Я узнал, что если я перейду к Desktop Effects - Advanced и изменим там что-нибудь ценное (версия OpenGL, scal algorythm) и нажмите Apply, разрывание исчезнет до перезагрузки. Однако никакая настройка не решает эту проблему раз и навсегда. После перезагрузки я должен пойти и изменить что-то снова. Думаю, этого достаточно, чтобы обвинить это в ошибке, а не о моих ошибках, поэтому я напишу отчет об ошибке.

    
задан Barafu Albino 27.04.2014 в 14:33
источник

6 ответов

8

Источником проблемы были (конечно) неисправные драйверы nvidia. Решение прост. Добавить переменные среды:

export __GL_YIELD="USLEEP"
export __GL_THREADED_OPTIMIZATIONS=1

где-то до начала X. Общесистемный /etc/profile/ работает отлично.     

ответ дан Barafu Albino 27.09.2014 в 10:27
источник
8

Простое руководство для решения этой досадной проблемы:)

  1. Создать файл:

    /etc/profile.d/Tearing.sh
    
  2. Введите этот код:

    export __GL_YIELD="USLEEP"
    
  3. Затем сделайте его выполнимым с помощью:

    chmod +x /etc/profile.d/Tearing.sh
    
  4. Как только это будет сделано, перезагрузитесь или нажмите ctrl + alt + F2, войдите в систему и запустите sudo service lightdm restart Или перезапустите то, что когда-либо было вашим диспетчером.

GL_YIELD работал для меня, и теперь вертикальная синхронизация работает так, как должна.

( Ссылка )

    
ответ дан Dominik Najberg 28.09.2014 в 15:40
5

Я прибил его ...

Итак, прежде всего, обязательно проверьте, не исчезла ли проблема после того, как вы отключили эффекты рабочего стола (Alt + Shift + F10). Я могу гарантировать, что проблема может уже исчезнуть.

Перейдите в раздел «Системные настройки» и «Эффекты рабочего стола»:

  • Метод масштабирования для чего-то еще, чем установленный в настоящее время & lt; - фактическое исправление

Я знаю, что параметры не могут быть названы точно так же, как указано выше. Извините, но я использую польскую версию Kubuntu.

Вышеупомянутые шаги исправили проблему для меня. Но только после новой установки. :)

EDIT: в текущей версии 14.04 Kubuntu проблема связана с методом масштабирования. Изменение его на все, кроме выбранного в данный момент, помогает решить проблему ВРЕМЕННО.

    
ответ дан Dominik Najberg 28.04.2014 в 17:37
5

Я пробовал все трюки и ничего не решил на Ubuntu 15.04 (вместе с xorg-edgers и nvidia-355), пока я не пришел на страница nvidia archlinux .

Тест с помощью

nvidia-settings --assign CurrentMetaMode="nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"

Чтобы сделать изменение постоянным, вам необходимо добавить следующее в раздел «Экран» вашего конфигурационного файла Xorg, для пример в /etc/X11/xorg.conf.d/20-nvidia.conf

Option  "metamodes" "nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }"
    
ответ дан Giovanni Toraldo 13.08.2015 в 21:52
0

Удаление драйвера NVIDIA для меня решилось. Для XFCE единственное, что помогло, это замена диспетчера окон.

    
ответ дан Waterscroll 15.06.2015 в 17:12
0

Я пробовал каждое предложение попробовать и исправить разрывы экрана во время просмотра видео в Unity, Gnome и Gnome Classic на двух компьютерах (один с Nvidia Titan X, а другой со старой картой Radeon). Ничего не получилось.

Затем я заметил, что когда я переключил видеовыход в настройках VLC с OpenGL на X11, разрывание исчезло, но я начал получать много случайных черно-белых квадратов или «шум».

Чтобы воспроизвести воспроизведение видео, я установил Lubuntu Desktop, который использует OpenBox вместо OpenGL. Lubuntu - это производная Ubuntu, которая по умолчанию установлена ​​LXDE. Он чрезвычайно легкий и идеально подходит для работы в фоновом режиме, когда вы используете Kodi и Steam, или просто смотрите видео.

При перетаскивании окон может произойти разрывание окна, но это не имеет значения для меня в этой ситуации, поскольку я использую только Kodi и Steam в полноэкранном режиме на этом компьютере.

Выполните следующую команду для установки как LubDEU LXDE, так и Villa LXDE на Ubuntu:

sudo apt-get install lubuntu-desktop

Используйте эту команду вместо этого, чтобы установить только vanilla LXDE:

sudo apt-get install lxde

Вы также можете включить LXDE, загрузив Lubuntu live CD .

Каждая среда отличается только по умолчанию. Они имеют разные темы, обои и макеты панелей. Например, браузер Chromium используется по умолчанию для Lubuntu, а Mozilla Firefox по умолчанию используется для использования в ванильном LXDE. Конечно, вы можете использовать любой браузер, который вам нравится. Они оба используют файловый менеджер PCManFM, легкую замену файлового менеджера Nautilus, найденную в GNOME.

После установки любого из пакетов выйдите из системы и выберите сеанс Lubuntu или LXDE на экране входа в систему.

Мои видео никогда не выглядели лучше, чем в Lubuntu. Я смог поднять свою частоту до 120 Гц в соответствии с моим телевизором. Воспроизведение было замечательно гладким для 1920x1080p.

    
ответ дан guttermonk 12.07.2015 в 03:19