Google Chrome «Мерцание»

18

У меня проблема с Google Chrome на Ubuntu 12.10 64.

Примерно на 20-30% веб-сайтов страница появляется и начинает «мерцать». Похоже, что есть другой или частичный рендеринг страницы в другом буфере, и несколько раз в секунду страница меняет местами между двумя экранными буферами, вызывая своего рода эпилептическое мигание разных изображений.

Я также не могу прокручивать страницу, когда она находится в этом мерцающем состоянии, любая попытка прокрутки приводит к тому, что страница снова вернется к следующему мерцанию.

Я использую драйвер fglrx, если это что-то значит:

$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Advanced Micro Devices, Inc.
OpenGL renderer string: AMD Radeon HD 7900 Series
OpenGL version string: 4.2.12002 Compatibility Profile Context 8.961

Версия Chrome:

Google Chrome   25.0.1364.172 (Official Build 187217) 

Любые идеи?

    
задан Andrew Tomazos 08.04.2013 в 02:20
источник

4 ответа

10

Это известная проблема с графической картой ATI / AMD и композицией.

Для некоторых пользователей запуск Chrome с параметром -blacklist-accelated-compositing дает некоторую помощь. Другие сообщают, что параметр --disable-gpu помогает.

См. Ссылка

Насколько я понимаю, единственное реальное решение - переключиться на Nvidia или Intel GPU. Добавление таких параметров, как те, которые превышают стоимость, и отключить некоторые функции, требующие компоновки. Чтобы проверить состояние дел в GPU в Chrome, посетите chrome: // gpu

    
ответ дан longsleep 16.04.2013 в 14:01
7

Повторное рассмотрение этой страницы через месяц, проблема заключалась в том, что аппаратное ускорение не было включено. Это также видно на видео HTML5!

Перейдите в chrome: // flags

Найдите «Override Software Rendering List», то есть включите ускорение GPU на неподдерживаемом оборудовании и включите его. Перезагрузите Chrome (закройте фоновый процесс, если он работает в верхней части панели), и посмотрите, работает ли он для вас.

Подробнее здесь .

    
ответ дан ben lifehacker 13.07.2014 в 17:01
5

Вы можете попробовать запустить хром с% co_de%.

Ссылка: Ссылка

    
ответ дан jox 20.12.2014 в 12:51
4

Это решение очень похоже на ответ @ jox (отключив поддержку GPU для этой проблемы), но если кому-то интересно, как это сделать, вы можете просто перейти на Настройки - > «Показать дополнительные настройки ...» - > System и снимите флажок «Использовать аппаратное ускорение при наличии»

Я использую Ubuntu 15.04 и fglrx из репозиториев Ubuntu на Chromium 45.0.2454.85.

    
ответ дан wchest 29.09.2015 в 17:28