Как устранить проблему загрузки на черный экран на виртуальном боксе

20

Я использовал 13.04 в качестве гостевой ОС на своем Virtualbox 14.2.18. Хост - это Windows 8. После обновления до 13.10 ubuntu не запускается. Я вижу черный экран и мигающий курсор.

Может ли кто-нибудь помочь? Я довольно новичок в ubuntu. Я чувствую, что это неправильно с графическими драйверами. Я могу получить доступ к tty и всем файлам (/ home).     

задан don 05.11.2013 в 11:16
источник

12 ответов

10

Вот как я устраняю неиспользуемый Ubuntu в Virtual Box (при условии оптимальные настройки для виртуальной машины уже были сделаны):

  1. Убедитесь, что вы установили наиболее последняя версия Virtual Box .
  2. Попробуйте перезагрузиться, введя терминал TTY ( Host + F1 )

    sudo reboot
    
  3. Обновите гостевую ОС от TTY ( Host + F1 ):

    sudo apt update && sudo apt dist-upgrade
    
  4. Установите гостевые дополнения из командной строки .

  5. Перезагрузите гостя после установки гостевых дополнений.
  6. Запустите lightdm вручную из TTY ( Host + F1 ) с помощью

    sudo lightdm
    
  7. Попробуйте несколько перезагрузок виртуальной машины. Из-за проблем с сроками это может помочь в конечном итоге.

  8. Попробуйте перезагрузить хост.
  9. Проверьте форумы и virtualbox.org для известных ошибок.
ответ дан Takkat 05.11.2013 в 11:55
источник
19

У меня была эта проблема, и мое решение было простым.

Как-то моя конфигурация VirtualBox для VM (Ubuntu) была изменена после обновления Virtual Box. Мой гостевой VM был 64-битным Ubuntu, и он был настроен как 32-битная версия. Чтобы изменить:

  1. Открыть виртуальную корзину
  2. Выберите свою виртуальную машину и нажмите «Конфигурации»
  3. Перейдите в раздел «Общие»
  4. Измените версию на "Ubuntu (64-bit)"
ответ дан Dherik 01.11.2015 в 23:50
8

Для меня ни один из вышеперечисленных ответов не работал. I решил эту проблему, отключив 3D-ускорение на странице настроек vm. Это довольно странно, поскольку я использую 3D-ускорение безупречно в течение нескольких месяцев на этой виртуальной машине.

    
ответ дан pomarc 19.06.2017 в 11:01
4

Это может быть ответ:

  1. Вы (и я) переходите к этому экрану через (случайный) хост + f9 . Это не говорит вам, что произошло.

  2. Обратное магическое заклинание alt + f7 (все восстановлено в прежней славе).

Я должен был открыть это сам. Хотя попасть в неприятности было достаточно легко.

    
ответ дан user287749 02.06.2014 в 16:37
2

У вас была такая же проблема после переноса моей виртуальной машины на другой 64-разрядный компьютер под управлением Windows.

Моя гостевая ОС (Ubuntu) изменилась на 32 бит. Не знаю, как это произошло (возможно, я сам выбрал вариант при создании виртуальной машины). Я просто изменил его на 64 бит, и он работал отлично. Процедура следующая: -

  1. Открыть виртуальную корзину
  2. Выберите свою виртуальную машину и щелкните ее правой кнопкой мыши, затем выберите «Настройки»
  3. Перейдите в раздел «Общие»
  4. Измените версию на "Ubuntu (64-bit)"
  5. Запустите виртуальную машину, и она должна работать.
ответ дан Hummer 26.02.2017 в 20:58
2

Это происходит со мной сегодня после обновления VBox до 5.1.30. Экран входа в систему выглядит нормально. Однако после входа в систему экран становится черным и остается черным, а предварительный просмотр VBox - рабочим столом.

Пробовал различные предложения, единственное, что работает, - отключить 3D-ускорение для гостевой ОС (Linux Mint18).

Обновление добавления гостей не имеет эффекта.

    
ответ дан user750199 21.10.2017 в 18:52
2

Я сделал следующее, поскольку это сработало для меня.

  1. Откройте TTYL ( Ctrl + Alt + F1 )

  2. Войдите в обычную учетную запись пользователя (не гость).

  3. Введите sudo dpkg --configure -a

  4. Нажмите ( Ctrl + F7 )

ответ дан Ankit 30.11.2016 в 16:23
1

Когда я добрался до экрана входа в систему, я выключил полноэкранный режим, вошел в систему и снова включил его. Это сработало. Возможно, мне повезло.

    
ответ дан aomimezura 17.03.2014 в 14:32
0

У меня была такая же проблема с установкой Kali в VirtualBox, мигающими курсорами в верхнем левом углу. Простое решение для меня было в BIOS, нажав F10 во время загрузки и включив виртуализацию.

    
ответ дан WilliamR 22.09.2016 в 23:02
0

Вот как я решил проблему. Я установил Hadoop на гостевую ОС openSuse. Существует несколько сервисов, которые нужно начать, чтобы начать работу с Hadoop, например,

start-dfs.sh
start-yarn.sh

Я добавил обе приведенную выше команду start в мой .bashrc-файл, так что я не должен запускать их явно каждый раз, когда я вхожу в систему. .bashrc запускается каждый раз при входе в систему.

$cd ~
$vi .bashrc

Я прокомментировал свои стартовые сервисные команды, как показано ниже.

    
ответ дан Vinayak Dornala 07.04.2017 в 14:00
0

Следующие действия для моего Ubuntu 16.04 внутри VirtualBox:

  1. Завершение работы гостевой ОС Ubuntu
  2. Перейдите в Настройки - > Система - > <Сильный> Материнские платы
  3. Измените Чипсет от ICH9 до PIIX3
  4. Перезапустите Ubuntu, и графический режим станет нормальным.

Как ни странно, ICH9 работает нормально до одного дня, когда я обновил VirtualBox от 5.0.18 до 5.1.28 .

    
ответ дан Joe X Zhu 21.09.2017 в 08:34
0

Ничего не работало, поэтому я загрузился в режим восстановления и выбрал опцию DPKG (ремонт сломанных пакетов) и после этого сделал это.

    
ответ дан Vindolin 20.11.2017 в 13:06
0

У меня была аналогичная проблема, что я сделал:

  1. Ввод в настройку - > Система - > Процессор
  2. Установите процессор на 2CPU вместо 1CPU
  3. Нажмите «ОК» и перезапустите.

Работал отлично для меня после

    
ответ дан V.Novice 09.07.2018 в 01:40