Ошибка SSH: разрешение отклонено, повторите попытку

18

У меня есть настройка сервера Ubuntu с использованием экземпляра amazon ec2. Мне нужно подключить мой рабочий стол (который также является машиной ubuntu) к серверу ubuntu с помощью SSH.

Я установил open-ssh на сервере ubuntu. Мне нужны все системы моей сети для подключения сервера ubuntu с использованием SSH (нет необходимости подключаться через клавиши pem или pub).

Следовательно, открыт SSH-порт 22 для моего статического IP-адреса в группах безопасности (AWS).

Мой файл SSHD-CONFIG:

# Package generated configuration file
# See the sshd_config(5) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication yes
PubkeyAuthentication yes
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
#IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
#PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

# Set this to 'yes' to enable PAM authentication, account processing,
# and session processing. If this is enabled, PAM authentication will
# be allowed through the ChallengeResponseAuthentication and
# PasswordAuthentication.  Depending on your PAM configuration,
# PAM authentication via ChallengeResponseAuthentication may bypass
# the setting of "PermitRootLogin without-password".
# If you just want the PAM account and session checks to run without
# PAM authentication, then enable this but set PasswordAuthentication
# and ChallengeResponseAuthentication to 'no'.
UsePAM yes

Через webmin (командная оболочка) я создал нового пользователя с именем 'senthil' и добавил этого нового пользователя в группу 'sudo'.

sudo adduser -y senthil
sudo adduser senthil sudo

Я попытался войти с помощью этого нового пользователя 'senthil' в 'webmin'. Я смог войти в систему успешно.

Когда я попытался подключить сервер ubuntu от моего терминала через SSH,

ssh [email protected]_IP

Он попросил меня ввести пароль. После ввода пароля он отобразится:

Permission denied, please try again.

В некоторых исследованиях я понял, что для этого мне нужно отслеживать журнал авторизации моего сервера. Я получил следующую ошибку в своем журнале авторизации (/var/log/auth.log)

Jul  2 09:38:07 ip-192-xx-xx-xxx sshd[3037]: pam_unix(sshd:auth): authentication failure; logname= uid=0 euid=0 tty=ssh ruser= rhost=MY_CLIENT_IP  user=senthil
Jul  2 09:38:09 ip-192-xx-xx-xxx sshd[3037]: Failed password for senthil from MY_CLIENT_IP port 39116 ssh2

Когда я пытался отлаживать, используя:

ssh -v [email protected]_IP


    OpenSSH_5.9p1 Debian-5ubuntu1, OpenSSL 1.0.1 14 Mar 2012
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to SERVER_IP [SERVER_IP] port 22.
debug1: Connection established.
debug1: identity file {MY-WORKSPACE}/.ssh/id_rsa type 1
debug1: Checking blacklist file /usr/share/ssh/blacklist.RSA-2048
debug1: Checking blacklist file /etc/ssh/blacklist.RSA-2048
debug1: identity file {MY-WORKSPACE}/.ssh/id_rsa-cert type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_dsa type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_dsa-cert type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_ecdsa type -1
debug1: identity file {MY-WORKSPACE}/.ssh/id_ecdsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.8p1 Debian-7ubuntu1
debug1: match: OpenSSH_5.8p1 Debian-7ubuntu1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.9p1 Debian-5ubuntu1
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ECDSA {SERVER_HOST_KEY}
debug1: Host 'SERVER_IP' is known and matches the ECDSA host key.
debug1: Found key in {MY-WORKSPACE}/.ssh/known_hosts:1
debug1: ssh_ecdsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: password
debug1: Next authentication method: password
[email protected]_IP's password: 
debug1: Authentications that can continue: password
Permission denied, please try again.
[email protected]_IP's password: 

Для пароля я ввел то же значение, которое я обычно использую для пользователя ubuntu.

Может ли кто-нибудь указать мне, где проблема, и предложить какое-то решение для этой проблемы?

    
задан Senthil Kumaran 02.07.2013 в 13:14
источник

8 ответов

2

Я нашел, где проблема и исправлена.

Я создал нового пользователя (named: senthil) и просто использовал его для SSH. В Ubuntu я чувствую, что когда мы создаем нового пользователя, по умолчанию пароль пользователя root будет назначен новому пользователю. Даже тогда сбросьте и назначьте новый пароль новым созданным пользователям.

После сброса пароля пользователя и внесения следующих изменений в sshd_config, теперь я могу подключить все свои системы (из своей сети) к удаленному серверу.

Обратите внимание: Я отключил все аутентификации SSH (например, RSAAuthentication, PubkeyAuthentication и KerberosAuthentication). Я включил только PasswordAuthentication.

Спасибо.

    
ответ дан Senthil Kumaran 03.07.2013 в 14:04
источник
11

Вы заблокировали учетную запись.

Из man-страницы usermod(8) :

-L, --lock
           Lock a user's password. This puts a '!' in front of the encrypted password,
           effectively disabling the password.

Теперь посмотрите на свою shadow строку:

ubuntu:!$6$rWDSG...HSi1:15347:0:99999:7:::

Разблокируйте его:

usermod -U ubuntu

Важное примечание! Если этот пользователь предустановлен в системе, он может быть заблокирован по какой-либо причине (соображения безопасности), но я не могу решить, что для вас, поскольку это не обычная установка Ubuntu, видимо.

Если вышеизложенное вызывает у вас дискомфорт, вы можете создать отдельного пользователя:

sudo adduser username

и ответьте на вопросы. Вы должны иметь возможность войти в систему просто отлично. Также сделайте его способным стать root (используйте sudo ), добавив его в группу sudo :

sudo adduser username sudo

Если вам нужно переключиться на пользователя ubuntu в командной строке, вам придется использовать свои повышенные привилегии, потому что вы не можете предоставить учетные данные по той же причине, что и почему вы не можете войти в систему SSH. Теперь войдите в систему, используя SSH как username , и запустите это, чтобы стать ubuntu :

sudo su -l ubuntu

По соображениям безопасности я не советую использовать root для входа в систему напрямую.

    
ответ дан gertvdijk 02.07.2013 в 13:25
6

У меня такая же проблема, и мне нужно много часов.

Однако я отмечаю, что это неверный пароль из-за различия между раскладкой клавиатуры сервера snd-клиента:

На сервере я решил установить пароль: [email protected] И, я отмечаю, что @ " в раскладке клавиатуры сервера.

Итак, правильный пароль: WEwd"ds

Таким образом, вам нужно проверить:

Раскладка клавиатуры сервера [vs] Раскладка клавиатуры рабочей станции

    
ответ дан Abdennour TOUMI 12.06.2014 в 16:48
4

Это не точный ответ на этот вопрос. Но в моем случае были избыточные линии. (была одна и та же строка)

PermitRootLogin yes

, а также

AllowUsers otheruser

Вы должны добавить пользователя root в эту строку или прокомментировать эту строку.

И перезапустите ssh service sshd restart

    
ответ дан Sadee 24.03.2017 в 16:25
1

У меня есть решение для вас В файле sshd_config вы добавляете следующую строку в конец файла:

AllowUsers senthil

Эта строка позволит вашему серверу подключиться к имени пользователя: senthil. Другому пользователю будет отказано. После этого перейдите на свой терминал по типу вашего типа:

ssh [email protected]

Готово! Удачи тебе Больше информации вы можете приехать сюда и посмотреть. Ссылка

    
ответ дан Dang_Ho 15.09.2016 в 05:49
0

Я видел много ответов на эти вопросы. Я тоже столкнулся с проблемой. Мое дело было моим соединением ssh работали до того, я изменил к Windows 10 автоматически модернизирован. Не работал на Ubuntu на моем рабочем столе.

Не знаю, в чем была проблема. Я проверил файл \ etc \ hosts, файл sshd_config все выглядело хорошо. Затем я решил проверить настройки антивируса - бинго, что является проблемой!

Закладочное приложение было включено в список запрещенных. Так что он включен ... затем войдите в систему успешно. Большой крик!

    
ответ дан Niranjan Das 16.09.2018 в 20:15
0

Для отчаянного дважды проверьте файл /etc/hosts , чтобы убедиться, что вы не обманываете свой компьютер, думая, что у определенного имени хоста есть другой IP-адрес, чем на самом деле. >. & Л;

    
ответ дан Alexander Taylor 18.10.2014 в 08:24
0

Проверить sshd списка доступа для разрешенных пользователей (файл конфигурации)

  1. cat /etc/ssh/sshd_config
  2. AllowUsers

не следует устанавливать, он должен быть прокомментирован # , как показано в примере ниже.

# Example of overriding settings on a per-user basis
#Match User anoncvs
#       X11Forwarding no
#       AllowTcpForwarding no
#       ForceCommand cvs server
Ciphers aes128-ctr,aes192-ctr,aes256-ctr
ClientAliveInterval 432000
ClientAliveCountMax 0
#AllowUsers TestUser
    
ответ дан willer 03.06.2017 в 00:04