Почему не больше «python-support» в 16.04?

17

Мне любопытно, почему пакет поддержки python больше не существует в 16.04 - это связанные с изменением Python3 по умолчанию? Кроме того, есть ли какой-либо пакет, который «требует» его, который на самом деле не устанавливает и не запускается нормально, форсирование зависимостей ?

Есть ли какая-либо опасность для сопровождающих пакетов, просто удаляющих «python-support» из списка требований, чтобы устранить эту проблему в обновлении?

    
задан NoBugs 02.05.2016 в 05:20
источник

2 ответа

27

Была такая же проблема при попытке установить cassandra на 16.04. Решил его:

wget http://launchpadlibrarian.net/109052632/python-support_1.0.15_all.deb
sudo dpkg -i python-support_1.0.15_all.deb

Источник: Ссылка

    
ответ дан Alex Burdusel 04.08.2016 в 21:38
1

Вы связаны с исходным пакетом, но пакет python-support определенно существует в двоичных репозиториях:

Ссылка

Я не уверен, почему он не отображается в исходных репозиториях - может быть, потому, что это просто скрипт Python, который может выполняться напрямую, а не что-то, что требует компиляции в двоичный файл, чтобы быть полезным.

Отвечает ли это на ваш вопрос, или вам нужен пакет в «исходных» репозиториях?

    
ответ дан user533208 02.05.2016 в 06:15