Проблема с перезапуском Apache 2 [дубликат]

73

Я пытаюсь перезапустить Apache 2:

sudo service apache2 restart

Но получите следующую ошибку:

* Restarting web server apache2 

AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1.

Set the 'ServerName' directive globally to suppress this message

Я попытался изменить

sudo gedit /etc/apache2/httpd.conf

Появится пустой файл, и я добавил следующее:

ServerName localhost

Но эта ошибка не исчезает!

Как я могу исправить эту проблему?

    
задан Hamed Kamrava 06.08.2013 в 15:42
источник

4 ответа

109

Я нашел это: Как перезапустить / перезагрузить Apache, если он не может определить доменное имя?

  

Хорошие новости! Apache успешно перезапускается. Apache просто не уверен   где вы хотите обслуживать, поэтому он выбирает ваш localhost (127.0.0.1)   по умолчанию. Чтобы предотвратить появление этого сообщения, уточните, что вы   хотите использовать localhost (127.0.0.1), добавив следующую строку   в файл /etc/apache2/apache2.conf :

ServerName localhost
    
ответ дан Meintjes 06.08.2013 в 15:52
источник
34

Указание ServerName localhost в ваших файлах конфигурации за пределами виртуальных разделов хоста - это способ сделать это.

Другие ответы предполагают, что вы должны изменить /etc/apache2/httpd.conf . Этот файл перезаписывается, когда apache обновляется с apt. Для конфигурации Apache, которую вы не хотите перезаписывать, вы должны создать новый файл. Ниже приведен пример «Debian» для изменения этой конфигурации:

# create the configuration file in the "available" section
echo "ServerName localhost" | sudo tee /etc/apache2/conf-available/servername.conf
# enable it by creating a symlink to it from the "enabled" section
sudo a2enconf servername
# restart the server
sudo service apache2 restart
    
ответ дан Stephen Ostermiller 10.03.2014 в 21:03
4

Ваш IP-адрес localhost должен быть 127.0.0.1, а не 127.0.1.1. Пожалуйста, правильно настройте файл /etc/hosts . Затем отредактируйте файл httpd.conf :

sudo -H gedit /etc/apache2/httpd.conf

Когда появится пустой файл, добавьте эту строку, затем сохраните:

ServerName localhost
    
ответ дан Masabza 02.03.2014 в 13:36
0

Вот еще одно решение:

Перед

[[email protected] ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: apr_sockaddr_info_get() failed for centos.wks.local
httpd: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
                                                           [  OK  ]

Добавлен 192.168.226.131 centos.wks.local в файле /etc/hosts

Примечание. 192.168.226.131 - это мой IP-адрес сервера Apache.

После того, как:

[[email protected] ~]# /etc/init.d/httpd restart
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
    
ответ дан Rahul Patil 06.08.2013 в 16:02