Skype на 12.04 x 64 не запускается даже после очистки и переустановки

17

Мне интересно, есть ли здесь кто-нибудь, кому удалось использовать Skype на 12.04. Он работал (с тех пор как я впервые пробовал Ubuntu 10.04) безупречно, но после обновления до 12.04 он просто не запускается.

Если я запустил Skype с терминала, он просто говорит Segmentation fault (core dumped). Я попытался удалить Skype и установить его из разных мест:

  • Веб-сайт Skype (вообще не установлен, «ошибка пакета»)

  • Из официального репозитория Ubuntu (не начинается вообще, ошибка сегментации)

  • Из репозитория "deb Ссылка $ (lsb_release -sc) партнер" (не начинается вообще, ошибка сегментации )

Интересная вещь: даже если я удаляю / очищаю Skype от системы, он все равно отображается в меню Unity (конечно, не запускается).

Любая помощь здесь?

    
задан Zevaka 19.05.2012 в 11:14
источник

11 ответов

18

Skype работает очень хорошо на Ubuntu 12.04 64-разрядной версии (используя его прямо сейчас).

Как сделать:

  1. Перейдите в Источники программного обеспечения , нажмите вторую вкладку Другое программное обеспечение и отметьте Canonical Partners и Канонические партнеры (исходный код) .
  2. Откройте терминал и добавьте следующую команду sudo apt-get update .
  3. После завершения обновления введите sudo apt-get install skype . Это установит skype и будет работать отлично.

Удачи.

    
ответ дан Dave 21.05.2012 в 00:03
4

Skype отлично работает для меня на 12.04 x 64, и мне не нужно было переустанавливать его после обновления с 11.10 по 12.04.

Я не совсем уверен, что вы подразумеваете при использовании skype on Ubuntu 12.04 x64. Вы используете x64-версию Skype, или просто хотите использовать Skype на своей 64-битной машине? Исторически Skype не выпустил собственную версию x64 для Linux, поэтому я всегда использовал версию i386 с библиотеками i386.

Я только заметил, что в репозиториях есть новый пакет, который выглядит как родная версия x64, но я не пробовал.

Версия, которую я использую, - это Skype (бета) версия 2.2.0.35 (пакет - skype: i386 версия: 2.2.0.35-0precise3)

Вы можете попробовать использовать версию i386, если вы еще этого не сделали, если иметь собственное приложение x64 не так важно для вас.

    
ответ дан adempewolff 21.05.2012 в 04:23
3

Я могу только повторить, что Skype работает хорошо для меня. Понадобилось довольно много времени для установки (установлено с их сайта с помощью Software-Center), но теперь он работает как мои предыдущие версии.

    
ответ дан LxMaD 19.05.2012 в 13:35
2

Также убедитесь, что ваш профиль Apparmor для Skype (если он у вас есть) не является причиной проблемы.

У меня были очень похожие симптомы (skype был просто coredumping), и удаление моего рукописного давнего профиля Apparmor для Skype ( /etc/apparmor.d/usr.bin.skype ) разрешило проблему.

    
ответ дан ulidtko 25.05.2012 в 15:36
2

Способ установки для Skype 4.0 на Ubuntu 12.04 64-бит:

  1. <р> apt-get remove skype
  2. <р> apt-get autoremove
  3. Перейдите на официальный веб-сайт Skype, выберите «Получить Skype для Linux», он покажет Ubuntu 11.10 32- и 64-разрядный.

  4. Выберите 64-битный и откройте его с помощью Software Center.

  5. Установите его, и он должен работать.

Я считаю, что есть некоторые проблемы с тем, что значок Skype не появляется. Поэтому я пробовал этот метод, и он работает, но из-за этих проблем я предпочитаю официальную версию, существующую в официальных репозиториях Ubuntu (Skype Beta 2.2).

    
ответ дан LnxSlck 15.06.2012 в 02:12
2

Да, я пользуюсь Skype на 12.04 x 64, который работает нормально, Скачайте «Skype Static» с официального сайта, и если он не запустит, просто установите пакет «ia32-libs» через программный центр.

    
ответ дан xIN3N 19.07.2012 в 03:17
0

Я успешно установил без каких-либо проблем ... шаги, которые я выполнил по ссылке ниже

Ссылка

    
ответ дан dwarez 29.06.2012 в 14:23
0

Кажется, что установка из репозиториев Ubuntu (как описано в вышеприведенных решениях) устанавливает версию Skype версии 2.2.

#> skype --version
Skype 2.2.0.35
Copyright (c) 2004-2011, Skype Limited

Официальный сайт Skype предлагает 4.0 версию Skype для Ubuntu 32 / 64bit. Чтобы установить его, загрузите пакет .deb с веб-сайта ( 32bit или 64bit ), затем выполните:

aptitude install lib32stdc++6 libstdc++6 lib32asound2 ia32-libs libc6-i386 lib32gcc1

, а затем

dpkg -i skype-ubuntu_4.0.0.8-1_amd64.deb (или его 32-разрядный аналог)

В конце у вас будет установлена ​​версия 4.0 для Skype.

#> skype --version
Skype 4.0.0.8
Copyright (c) 2004-2012, Skype
    
ответ дан Avio 18.07.2012 в 12:51
0

Ссылка

Самый простой способ установить последнюю версию Skype 4 и обновить ее, отлично работает на моем 12-ядерном настольном и четырехъядерном ноутбуке, а также на нетбуке, все работает на x64 12.04.

    
ответ дан Arup Roy Chowdhury 19.07.2012 в 04:53
0

Менеджер обновлений недавно обновил мою версию skype от
skype-bin: i386 2.2.0.35-0precise3
для изображения skype-bin: i386 4.0.0.8-0oneiric1

К сожалению, новая версия демонстрирует более низкое качество воспроизведения голоса, видео ошибки и случайные сбои.

Таким образом, может не работать для всех.

    
ответ дан Eero Aaltonen 14.08.2012 в 14:37
0

Чтобы установить Skype в Ubuntu 12.04, вам нужно получить канонический репозиторий

sudo apt-add-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update 
sudo apt-get install skype
    
ответ дан Akhilraj N S 15.10.2012 в 06:22