Adobe Flash Player не работает с Amazon Prime

17

У меня есть Ubuntu 12.04 64bit с использованием Google Chrome. У меня был хром из центра приложения, тогда сегодня премьер-амазонка перестала работать. Он сказал мне обновить Flash. Поэтому я удалил хром и установил Google Chrome. Не работает. Затем я загрузил flash для ubuntu через apt. Это дало мне сообщение «flash-версия не поддерживается». Версия flash была 11.

Теперь я попробовал Ссылка

Это сработало, но прямо в середине видео появилось сообщение об ошибке.

Sorry we are unable to stream this video. This is likely because your Flash Player needs to be updated.

Поэтому я не знаю, что произошло.

    
задан Alex 03.06.2012 в 04:12
источник

10 ответов

4

Вероятно, это не работает в Google Chrome для Linux из-за ограничений Pepper Flash, поскольку Google упоминает о их страница поддержки :

Linux users: Adobe Flash Player uses a cross-platform API, Pepper API (PPAPI), to run its plug-in in Chrome. You might notice some of the known issues below specific to Linux Chrome:

[...]

  • Viewing Adobe Access (DRM) content is not supported, since Adobe does not support it on Linux.

[...]

Я думаю, что очень вероятно, что:

  • Поддержка старых 11.2 Flash для Linux (с использованием обычного API) была удалена Amazon.
  • Поддержка DRM, требуемая в 11.7 в Chrome для Linux, не работает из-за вышеупомянутых ограничений.

Это заставляет Ubuntu находиться между двумя стульями в поддержке просмотра видео с поддержкой DRM.

    
ответ дан gertvdijk 21.06.2013 в 14:24
источник
23

У меня была такая же проблема на Ubuntu 12.04 с использованием Chromium. Я исправил его, следуя инструкциям на странице adobe справки для установки модуля уровня абстракции аппаратного обеспечения:

Предпосылки для воспроизведения защищенного контента

Для Ubuntu 10.04 или более поздней версии убедитесь, что модуль аппаратного абстракционного слоя сначала установлен с помощью apt-get. (Следите внимательно за ошибками установки «hal», так как поврежденная установка пакета может продолжать влиять на воспроизведение видео.)

sudo apt-get install hal

После завершения установки библиотеки libhal (HAL) закройте браузер и очистите каталоги Adobe Access, выполнив следующие команды оболочки:

cd ~/.adobe/Flash_Player
rm -rf NativeCache AssetCache APSPrivateData2

Примечание: Если модуль уровня абстракции оборудования отсутствует, Flash Player по-прежнему функционирует. Однако он не может воспроизводить защищенный контент, для которого требуется модуль DRM (Digital Rights Management) Adobe Flash Access.

    
ответ дан jpetersen 11.06.2012 в 02:26
3

попробуйте открыть эту страницу . Вы увидите небольшой ящик с информацией о версии . Кроме того, он будет запускать короткое флэш-видео в качестве теста и скажет вам

1), если ваш флеш-плагин работает нормально

2) точная версия установленной вспышки (хорошая основа для дальнейшего устранения неполадок)

Даже если это не решение напрямую, оно может быть полезно для вас.

    
ответ дан offline 11.06.2012 в 00:32
1

В моей системе 10.04 я запустил Менеджер синаптических пакетов , искал flash и нашел пакет с именем flashplugin-installer version 11.2.202.238ubuntu0.10.04.1 . Выбор его для установки заставил его удалить более раннюю версию флеш-плагина, которая была для 64-битного. Однако это решило проблему для меня. Теперь я могу воспроизводить основные мгновенные видеоролики.

    
ответ дан Cynthia 11.09.2012 в 03:48
1

Иногда, когда flash автоматически обновляется, более новая версия не работает для меня, как у моего предыдущего. Я не мог найти простой способ понизить, но вот один из способов, который работает для меня, когда я использую firefox:

  1. Загрузите предыдущую рабочую версию adobe из архивов flash-плееров . Из того, что я могу сказать, версии 11.2.202.xxx для Linux. Загруженная версия, 11.2.202.275 , попала в сжатую папку. Когда я извлек его, я увидел, что libflashplayer.so внутри.
  2. Я переместил libflashplayer.so в ~/.mozilla/plugins/ .
  3. Перезапустите firefox. Смотрите видео.
ответ дан Kevin 13.04.2013 в 17:10
0

Еще одна распространенная проблема с Flash, особенно в 12.04, - «Gnash», что маленький искатель вызвал у меня многочисленные проблемы со вспышкой. Просто полностью удалите Gnash, а затем загрузите плагин flash из Adobe или в «Центр программного обеспечения».

Терминальный путь:

sudo apt-get autoremove --purge gnash && sudo apt-get install adobe-flashplugin -y

Для тех, кто не знает, удаляет Gnash и конфигурации (с чисткой), а затем устанавливает последнюю версию flash. Возможно, вам придется перезагрузиться потом (что-то я не делаю очень часто, если честно).

Изменить Возможно, потребуется перезагрузка после удаления Gnash, иногда в текущей сессии активны конфигурации.

    
ответ дан ash 12.06.2012 в 18:27
0

В Chrome включена поддержка Flash, встроенная в браузер. Это не похоже на то, как Firefox использует flashplugin-installer / flashplugin-nonfree или adobe-flashplugin (которые отделены от браузера, но используются браузером). Пакетный плагин Ubunbu может использовать HAL, тогда как встроенный плагин для хром не может.

    
ответ дан David Walker 07.08.2012 в 15:29
0

/. adobe / Flash_Player / *, вероятно, не имеет прав доступа, даже если вы переустановите. Попробуйте следующее, если вы застряли после всего вышеперечисленного:

sudo apt-get purge flashplugin-installer ubuntu-restricted-extras
sudo apt-get install flashplugin-installer ubuntu-restricted-extras

Закрыть Хром и:

cd ~/.adobe/Flash_Player
rm -rf ./*

Откройте Chromium и попытайтесь воспроизвести неприятное видео (он, вероятно, пока не воспроизводится), а затем:

cd ~/.adobe/Flash_Player
chmod 777 *

Скорее всего, эти две последние команды - все, что вам действительно нужно делать. Остальное только для полноты.

    
ответ дан jarederaj 12.08.2014 в 23:50
0

Я новичок в Ubuntu и пробовал различные работы, связанные с не установленным флэш-памятью или отсутствием обновленной версии хрома или хрома и т. д., чтобы получить музыку Amazon для работы в Chrome и Chromium. В итоге пошел в firefox и пошел добавлять > плагины > ... установите ударную вспышку, чтобы она всегда активировалась, и теперь она работает нормально.

    
ответ дан Gary Tomkins 25.02.2018 в 10:42
-1

Перейдите в свой Chrome Chrome и выполните поиск adobe flash для Google chrome и установите правильный для своего браузера. Я думаю, что это как-то связано с вашим браузером. Вы пробовали его в другом браузере, таком как Firefox?     

ответ дан all4naija 11.06.2012 в 16:15