Как исправить установку PostgreSQL

18

Недавно я обновился от Maverick до Natty, и все прошло отлично, за исключением того, что во время dist-upgrade что-то пошло не так с PostgreSQL. С тех пор я пытаюсь переустановить, удалить и даже очистить его с помощью 'sudo apt-get purge postgresql', но он по-прежнему сталкивается с той же ошибкой, независимо от того, что я делаю. Смотри ниже. Он работал отлично до обновления. Любая помощь будет принята с благодарностью. Спасибо!

Setting up postgresql-common (114) ...
 * Starting PostgreSQL 8.4 database server         * The PostgreSQL server failed to start. Please check the log output:
2011-05-19 11:49:41 EDT LOG:  could not bind IPv4 socket: Address already in use
2011-05-19 11:49:41 EDT HINT:  Is another postmaster already running on port 5432? If not, wait a few seconds and retry.
2011-05-19 11:49:41 EDT WARNING:  could not create listen socket for "127.0.0.1"
2011-05-19 11:49:41 EDT FATAL:  could not create shared memory segment: Invalid argument
2011-05-19 11:49:41 EDT DETAIL:  Failed system call was shmget(key=5432001, size=37879808, 03600).
2011-05-19 11:49:41 EDT HINT:  This error usually means that PostgreSQL's request for a shared memory segment exceeded your kernel's SHMMAX parameter.  You can either reduce the request size or reconfigure the kernel with larger SHMMAX.  To reduce the request size (currently 37879808 bytes), reduce PostgreSQL's shared_buffers parameter (currently 4096) and/or its max_connections parameter (currently 103).
    If the request size is already small, it's possible that it is less than your kernel's SHMMIN parameter, in which case raising the request size or reconfiguring SHMMIN is called for.
    The PostgreSQL documentation contains more information about shared memory configuration.

[fail]
invoke-rc.d: initscript postgresql, action "start" failed.
dpkg: error processing postgresql-common (--configure):
 subprocess installed post-installation script returned error exit status 1
    
задан wired 22.05.2011 в 04:57
источник

2 ответа

29

Вам нужно увеличить максимальный размер части разделяемой памяти. Ядро Linux позволяет сразу выделить (известный как параметр SHMMAX)

Вам нужно отредактировать /etc/sysctl.conf и добавить следующую строку:

kernel.shmmax = 41943040

(где 41943040 - размер памяти в байтах, то есть 40 мегабайт. В производственной системе вы, вероятно, захотите установить это значение выше - документация Postgres рекомендует начинать с 1/4 доступной памяти)

Затем запустите

sudo sysctl -p

и снова перезапустите postgres.

В качестве альтернативы вы можете отредактировать /etc/postgresql/<version>/main/postgresql.conf и уменьшить значение параметра shared_buffers .

Это ошибка, более подробная информация здесь

Ссылка

(есть также файл /etc/sysctl.d/30-postgresql-shm.conf , который предполагается использовать для этой цели, но он, похоже, не включен в основную конфигурацию, поэтому его редактирование не имеет эффекта)

    
ответ дан freethinker 22.05.2011 в 08:55
источник
-2

Старый Postgres все еще работает скорее всего.

Хорошая идея, как заметил вольнодумщик, очень хорошо, что работает на этом порту.

Как только вы узнаете, что это Postrgres, вы, вероятно, захотите его убить:

# Find PID
ps axf | grep post

kill PID

Затем вы можете запустить новую версию:

/etc/init.d/postgresql start

Я озадачен, почему менеджер пакетов не смог остановить старую версию.

    
ответ дан Aleksandr Levchuk 22.05.2011 в 05:30