Как установить libOpenCL.so на ubuntu

25

Я загрузил intel_sdk_for_opencl_2016_ubuntu_6.0.0.1049_x64 , попытался запустить install.sh , но он говорит об Unsupported OS, поэтому я тогда где-то читал, что мне нужно было сделать файл .deb из одного из файлов RPM, я сделал это с помощью 2:

OpenCL-1,2-devel_6.0.0.1049-2_amd64.deb

OpenCL-1,2-Intel-devel_6.0.0.1049-2_amd64.deb

Установил их как с sudo dpkg -i , но у меня все еще нет libOpenCL.so, что мне нужно

Теперь я застрял ...: (

    
задан Badjano 09.07.2016 в 21:31
источник

1 ответ

29

Похоже, что libOpenCL.so предоставляется пакетом ocl-icd-opencl-dev . Чтобы установить этот пакет, запустите:

sudo apt update
sudo apt install ocl-icd-opencl-dev

Теперь libOpenCL.so должен быть расположен в папке /usr/lib/x86_64-linux-gnu/libOpenCL.so

    
ответ дан Nick Weinberg 09.07.2016 в 21:48
источник