Как установить Handbrake?

17

Я добавил ppa здесь

Ссылка

Когда я запускаю sudo apt-get update , источники программного обеспечения не найдены. Я подумал, что, возможно, они не обновили свои репозитории до самой новой версии, поэтому я изменил дистрибутив в Software Center на natty.

Теперь, когда я пытаюсь установить handbrake-gtk , я получаю сообщение

handbrake-gtk : Depends: libnotify1 (>= 0.5.0) but it is not installable

Depends: libnotify1-gtk2.10 but it is not installable

Похоже, что единственными пакетами, начинающимися с libnotify , являются

libnotify0.4-cil
libnotify-bin
libnotify-dev
libnotify4
libnotify-cil-dev
libnotify-doc

Единственное релевантное выглядело как libnotify4 , которое уже установлено. Версия CLI устанавливается нормально.

Как установить Handbrake?

    
задан Kris Harper 23.10.2011 в 19:29
источник

5 ответов

6

Ссылка
Получите это отсюда. Вам нужно libnotify1 v0.5 или новее.

    
ответ дан alex 23.10.2011 в 20:52
источник
18

Вот как установить официальные версии, а не снимки

sudo add-apt-repository  ppa:stebbins/handbrake-releases
sudo apt-get update
sudo apt-get install handbrake-cli

Затем вы можете запустить его с помощью:

HandBrakeCLI --help
    
ответ дан devin_s 16.12.2011 в 00:08
6

Установка (оригинальные инструкции доступны здесь )

Первое, что вам нужно сделать, это добавить официальный PPA - есть о том, как добавить PPA здесь в Ask Ubuntu. PPA, который вы хотите добавить, это:

Откройте терминал ( Ctrl + Alt + T ) и запустите:

sudo add-apt-repository ppa:stebbins/handbrake-snapshots
sudo apt-get update

И, наконец, установка:

sudo apt-get install handbrake-gtk handbrake-cli

    
ответ дан Juvencio 03.12.2011 в 15:58
2

Существует альтернатива: установите последнюю версию выпуска HandBrake из PPA-файлов HandBrake Snapshots PPP , которая также содержит одноименные пакеты со всеми правильными зависимостями: ppa: stebbins / handbrake-snapshots

    
ответ дан Pisu 01.11.2011 в 12:37
2

Ubuntu 14.04 и более поздние версии

Ручной тормоз находится в репозиториях по умолчанию Ubuntu 14.04 и более поздних версий. Чтобы установить его, откройте терминал и введите:

sudo apt install handbrake  

Ручной тормоз может быть установлен как пакет оснастки в Ubuntu 14.04 и более поздних версиях. Чтобы найти пакет привязки ручного тормоза, откройте терминал и введите:

snap find handbrake # the next 2 lines are the results of the command
Name          Version  Developer  Notes  Summary
handbrake-jz  1.0.2-0  jz         -      The open source video transcoder  

Результаты snap find handbrake обычно показывают, что версия handbrake-jz является последней стабильной версией Handbrake. Чтобы установить этот пакет привязки ручного тормоза, выполните следующие команды:

sudo apt install snapd
sudo snap install handbrake-jz

ручной тормоз и handbrake-jz также могут быть установлены из приложения Ubuntu Software в Ubuntu 16.04 и более поздних версиях.

    
ответ дан karel 02.02.2017 в 20:32