обновление с 15.10 до 16.04 apt не установлено

18

При попытке обновления с помощью терминала мое обновление останавливается. Это строка, отображаемая в терминале:

The required dependency 'apt(>=1.0.10.2 ubuntu2)' is not installed.

моя проблема в том, что я не знаю, как установить эту зависимость. Используя другие команды, он говорит, что apt обновлен. Решения?

    
задан paul 30.04.2016 в 22:57
источник

4 ответа

19

Была та же проблема, решена путем принудительного обновления apt и очистки текущей установки, как предложил Andrew:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install   # (not "install -f"!)
sudo apt-get -y install apt
sudo do-release-upgrade
    
ответ дан badger 02.05.2016 в 10:50
12

У меня была эта ошибка, для меня у меня отсутствовала линия wily-updates из моего /etc/apt/sources.list:

deb http://archive.ubuntu.com/ubuntu/ wily-updates main restricted universe multiverse
    
ответ дан Neil 14.05.2016 в 06:47
4

У меня тоже была эта проблема, это обновит все ваши лакомства, а также обновит с 15 до 16.

Перейдите к Software and Updates > Updates

Отметить следующее

  • Безопасность Wily
  • Обновления Wily
  • Wily Предлагаемый

Обновление и обновление текущей системы

sudo apt-get update && sudo apt-get upgrade

Получить обновление

sudo apt-get dist-upgrade

Обновление в CLI

sudo do-release-upgrade
    
ответ дан JREAM 04.08.2016 в 17:01
1

У меня была такая же проблема с «apt». Я получил решение от этой ссылки . Запустите sudo dpkg -l | grep apt . Вы можете увидеть эту запись в выводе команды:

ii  apt 1.0.10.2ubuntu1      amd64         commandline package manager

Если вы это сделаете, вам нужно будет получить требуемый apt (> = 1.0.10.2 ubuntu2) . Вот шаги, которые я выполнил:

  1. Перейдите к Software & amp; Обновление - > Программное обеспечение Ubuntu. Измените сервер на главный сервер (в моем случае я перешел на сервер для Индии). Ранее я использовал другое зеркало и, следовательно, имел более старую версию «apt».

  2. Запустить

        sudo apt-get update
        sudo apt-get install --reinstall apt 
    
  3. Запустить sudo dpkg -l | grep apt снова, чтобы проверить версию. Надеемся, что запись на выходе должна была измениться на: apt 1.0.10.2ubuntu2 .

  4. Запустите sudo apt-get update && sudo apt-get upgrade , после которого вы можете перейти к обновлению до ubuntu 16.04.

ответ дан Rahul 07.05.2016 в 11:06