После обновления с 14.04 по 16.04.1 Сервер Postgresql не запускается

19

Просто обновил мою систему с 14.04. LTS до 16.04.1 LTS, postgresql не запускается на systemd:

/etc/init.d/postgresql start                                                                                                                                                                              
[ ok ] Starting postgresql (via systemctl): postgresql.service

# /etc/init.d/postgresql status                                                                                                                                                                             
● postgresql.service - PostgreSQL RDBMS
  Loaded: loaded (/lib/systemd/system/postgresql.service; enabled; vendor     preset: enabled)
  Active: active (exited) since Вт 2016-08-09 13:40:51 MSK; 3min 23s ago
  Process: 23142 ExecStart=/bin/true (code=exited, status=0/SUCCESS)
  Main PID: 23142 (code=exited, status=0/SUCCESS)Seems that 

Кажется, что systemd-скрипт содержит неправильные данные:

# cat /lib/systemd/system/postgresql.service                                                                                                                                                                
# systemd service for managing all PostgreSQL clusters on the system. This
# service is actually a systemd target, but we are using a service since
# targets cannot be reloaded.

[Unit]
Description=PostgreSQL RDBMS

[Service]
Type=oneshot
ExecStart=/bin/true
ExecReload=/bin/true
RemainAfterExit=on

[Install]
WantedBy=multi-user.target

Какой должен быть правильный скрипт для postgresql?

    
задан Artur Eshenbrener 09.08.2016 в 13:13
источник

4 ответа

5

Это должно работать из коробки, если вы укажете правильную версию и имя кластера.

Допустим, вы используете версию 9.5 , а кластер называется main :

Начало: systemctl start [email protected]

Стоп: systemctl stop [email protected]

Статус: systemctl status [email protected]

Включить автозапуск при загрузке: systemctl enable [email protected]

Отключить автозапуск при загрузке: systemctl disable [email protected]

[email protected]:~$ systemctl status [email protected][email protected] - PostgreSQL Cluster 9.5-main
   Loaded: loaded (/lib/systemd/system/[email protected]; disabled; vendor preset: enabled)
   Active: active (running) since Fri 2017-03-31 17:44:46 CEST; 59s ago
   Main PID: 4546 (postgres)
   CGroup: /system.slice/system-postgresql.slice/[email protected]
           ├ ─ 4546 /usr/lib/postgresql/9.5/bin/postgres -D /var/lib/postgresql/9.5/main -c config_file=/etc/postgresql/9.5/main/postgresql.conf
           ├ ─ 4548 postgres: checkpointer process
           ├ ─ 4549 postgres: writer process
           ├ ─ 4550 postgres: wal writer process
           ├ ─ 4551 postgres: autovacuum launcher process
           └ ─ 4552 postgres: stats collector process

Mar 31 17:44:44 postgres postgres[4546]: [1-2] 2017-03-31 17:44:44 CEST [4546] @ HINT:  Future log output will go to log destination "syslog".
Mar 31 17:44:44 postgres postgres[4547]: [2-1] 2017-03-31 17:44:44 CEST [4547] @ LOG:  database system was shut down at 2017-03-31 17:44:43 CEST
Mar 31 17:44:44 postgres postgres[4547]: [3-1] 2017-03-31 17:44:44 CEST [4547] @ LOG:  MultiXact member wraparound protections are now enabled
Mar 31 17:44:44 postgres postgres[4546]: [2-1] 2017-03-31 17:44:44 CEST [4546] @ LOG:  database system is ready to accept connections
Mar 31 17:44:44 postgres postgres[4551]: [2-1] 2017-03-31 17:44:44 CEST [4551] @ LOG:  autovacuum launcher started
Mar 31 17:44:45 postgres postgres[4553]: [3-1] 2017-03-31 17:44:45 CEST [4553] [unknown]@[unknown] LOG:  incomplete startup packet
Mar 31 17:44:46 postgres systemd[1]: Started PostgreSQL Cluster 9.5-main.
Mar 31 17:44:47 postgres systemd[1]: Reloading PostgreSQL Cluster 9.5-main.
Mar 31 17:44:47 postgres postgres[4546]: [3-1] 2017-03-31 17:44:47 CEST [4546] @ LOG:  received SIGHUP, reloading configuration files
Mar 31 17:44:47 systemd[1]: Reloaded PostgreSQL Cluster 9.5-main.
    
ответ дан malte 31.03.2017 в 17:56
источник
14

Systemd должен использовать скрипт из /etc/init.d . Вместо этого systemd использует какой-то файл шаблона. Чтобы исправить это, выполните следующие действия:

  1. Удалить неверный служебный скрипт:

    # rm /lib/systemd/system/postgresql.service

  2. Перезагрузка сценариев демона:

    # systemctl daemon-reload

  3. Включить службу postgresql:

    # systemctl enable postgresql

После этого вы сможете запускать postgres с любыми предпочтительными вариантами: sudo systemctl start postgresql , sudo service postgresql start или sudo /etc/init.d/postgresql start . Чтобы проверить, что postgresql действительно запущен, проверьте статус службы: sudo systemctl status postgresql . Это выглядит следующим образом:

% sudo systemctl status postgresql                                                                                                                                                                          
● postgresql.service - LSB: PostgreSQL RDBMS server
   Loaded: loaded (/etc/init.d/postgresql; bad; vendor preset: enabled)
   Active: active (running) since Пт 2016-08-12 10:13:43 MSK; 1h 37min ago
     Docs: man:systemd-sysv-generator(8)
   CGroup: /system.slice/postgresql.service
           ├─4086 /usr/lib/postgresql/9.5/bin/postgres -D     /var/lib/postgresql/9.5/main -c  config_file=/etc/postgresql/9.5/main/postgresql.conf
           ├─4099 postgres: checkpointer process                                                                                              
           ├─4100 postgres: writer process                                                                                                    
           ├─4101 postgres: wal writer process                                                                                                
           ├─4102 postgres: autovacuum launcher process                                                                                       
           └─4103 postgres: stats collector process                                                                                           

авг 12 10:13:40 ubuntu-precise systemd[1]: Starting LSB: PostgreSQL RDBMS server...
авг 12 10:13:40 ubuntu-precise postgresql[4009]:  * Starting PostgreSQL 9.5 database server
авг 12 10:13:43 ubuntu-precise postgresql[4009]:    ...done.
авг 12 10:13:43 ubuntu-precise systemd[1]: Started LSB: PostgreSQL RDBMS server.
    
ответ дан Artur Eshenbrener 09.08.2016 в 13:13
0

У меня была такая же проблема после очистки postges9 и была установлена ​​10 на моем ubuntu16. Первоначально я редактировал файл /lib/systemd/system/postgresql.service со следующим содержимым:

[Unit]
Description=PostgreSQL RDBMS

[Service]
Type=notify
User=postgres
ExecStart=/usr/lib/postgresql/10/bin/postgres -D /analysis2/postgresql/data
ExecReload=/bin/kill -HUP $MAINPID
KillMode=mixed
KillSignal=SIGINT
TimeoutSec=0

[Install]
WantedBy=multi-user.target

И я могу использовать systemctl restart / stop / start для управления службой postgresql. Однако по какой-то причине вышеупомянутый файл был перезаписан (возможно, после обновления системы), и я не смог запустить команду systemctl, чтобы запустить и остановить сервер postgresql. После некоторого чтения я понял, что вы не должны редактировать этот файл. Вместо этого вы должны использовать systemctl edit foo для перезаписи значений по умолчанию. После выполнения решения, предложенного следующей ссылкой, моя система работает правильно с postgresql.

Как переопределить или настроить службы systemd?     

ответ дан Kemin Zhou 04.01.2018 в 23:36
-1

Не самое приятное решение, но это решает проблему без необходимости погружаться во что-либо. Добавьте это в cron:

@reboot sleep 5; systemctl start postgresql
    
ответ дан user3136936 24.08.2017 в 09:44