Как я могу предотвратить автоматическую загрузку Skype при загрузке?

29

Моя девушка вошла в свою учетную запись Skype с моего нетбука Xubuntu 12.10, и с тех пор Skype запускается автоматически каждый раз, когда я загружаюсь. Как предотвратить это?

Вещи, которые я пробовал:

  • Удаление из диспетчера настроек - > Session и Startup - > Application Autostart - не удалось найти в списке.
  • Проверка соответствующей настройки в самом Skype - не удалось найти что-либо подобное. (Я помню, что где-то была такая же настройка Skype, когда я использовал ее в Windows. Учитывая, что моя девушка - пользователь Windows, может быть, это тот параметр, который доступен на клиенте Windows, но не на Linux, и каким-то образом получил перевод?)
  • Используя BUM , чтобы отключить его - снова, не удалось найти его в списке.
  • Удаление Skype с apt-get remove skype --purge и надеемся, что он удалит все настройки, но это не так.

Сохранить для переустановки, что еще я могу попробовать?

Во время одной и той же заметки - как это возможно для автозапуска Skype без прохождения обычного маршрута Upstart?

EDIT: Еще пару вещей, которые я пробовал:

  • Поиск чего-либо подобного в поддержке Skype - я не ожидал ничего найти, и я этого не сделал.
  • Просмотр папки .Skype в моем домашнем каталоге. Я нашел пару файлов, которые выглядели многообещающими ( .Skype/shared.xml , .Skype/[my username]/config.xml , .Skype/[girlfriend's username]/config.xml ), но просмотр их ничего не принес. Однако множество файлов SQLite. Может быть, этот параметр находится где-то внутри?
задан Andrey 17.03.2013 в 11:05
источник

10 ответов

23

Имела ту же проблему, и, похоже, позаботились об этом: перейти к (Xubuntu) Settings > Сессии и запуск > Сессия, найдите Skype и щелкните левой кнопкой мыши, где написано «If Running» и измените ее на «Never».

    
ответ дан azeam 19.03.2013 в 09:15
источник
30

Для новой версии skype 2017, достаточно наглой, чтобы добавлять себя к автозапуску каждый раз, когда она запускается (серьезно? Никогда не устанавливайте ее на моей собственной машине), достаточно создать папку с тем же именем, что и файл, который он пытается создать

rm ~/.config/autostart/skypeforlinux.desktop
mkdir ~/.config/autostart/skypeforlinux.desktop
    
ответ дан int_ua 16.11.2017 в 12:48
13

Так как кажется, что ответы здесь меняются все время, начиная с установки skypeforlinux с этой недели (версия 8.11.0.4), мне удалось отключить автозапуск двумя шагами.

Сначала откройте Skype, перейдите в Инструменты > Настройки и снимите флажок «Автоматически запускать Skype».

Затем, вдохновленный предложением azeam, перейдите в (Xubuntu) Settings > Сессии и запуск > Приложение Autostart и удалите элемент для Skype. Я не уверен, что снятие отметки происходит; Сначала я попробовал это, но, возможно, в случае его попыток он может столкнуться с внутренними настройками Skype.     

ответ дан Dan 10.12.2017 в 17:47
7

У меня была такая же проблема. Я смог предотвратить автоматическое его запуск, удалив skypeforlinux.desktop из ~/.config/autostart/ . Я использую lubuntu; расположение вашей папки автозапуска может отличаться. Вы можете найти:

$ locate skypeforlinux.desktop

Вы действительно хотите удалить копию только в каталоге с именем autostart , иначе вы не сможете запустить приложение из значка.

Я предполагаю, что в следующий раз, когда вы на самом деле намеренно запустите Skype (надеюсь, ради вашего здравомыслия, что этот день far в будущем), что он попытается поставить этот файл обратно. В этом случае вам, возможно, придется снова удалить его или scour Skype для настройки, которая предотвратит это поведение.     

ответ дан Thismatters 01.11.2017 в 13:44
5

Перейдите в Инструменты - > Параметры - > Общие настройки. Снимите флажок «Запустить Skype при запуске». Сохранить и выйти из Skype.

    
ответ дан Massdon1 17.03.2013 в 11:23
2

В Kubuntu 14.04 проблема была решена путем перехода к Startup и Shutdown, затем управления сеансом и проверки. Начните с пустого сеанса и Apply.

    
ответ дан Craig 05.05.2014 в 18:07
1

Для регулярного Ubuntu 16.04 найдите «Запуск приложений». Когда откроется окно, просто удалите галочку из Skype, чтобы предотвратить его запуск при загрузке, затем нажмите «Удалить», когда вы выбрали Skype, чтобы удалить его из списка.

    
ответ дан yusko 20.05.2018 в 18:55
0

Кажется, что «закрытие» Skype фактически не закрывает его. Вы можете заметить это также тем фактом, что если вы снова открываете его, он уже вошел в систему.

Вы действительно можете закрыть его, введя в командной строке:

killall skype

Таким образом, он не будет сохранен в вашем рабочем сеансе при выходе из компьютера и поэтому не будет автоматически восстановлен при перезапуске вашего компьютера.

    
ответ дан Thijs 15.08.2014 в 22:54
0

Закрытие Skype - это не то же самое, что выйти из Skype. Я сделал три вещи в Kubuntu 14.04. После открытия Skype я перешел в Skype (Меню) > Options > General и установил флажок «Запустить Skype, скомбинированный в системный лоток». Затем Options > Advanced и unchecked «Проверить наличие обновлений при запуске». Наконец, вместо того, чтобы «выйти», я нажал кнопку «Выход» в нижней части меню. Я считаю, что это был последний шаг, который сделал трюк.

    
ответ дан WGCman 19.03.2015 в 00:41
0

Настройки Skype (для Linux)

Открыть Skype - Menue: extras - > Настройки - > категория: начало и закрытие

1. Автоматический запуск Skype

:

True

/home/$USER/.config/autostart/skypeforlinux.desktop

= > файл существует

ложь

/home/$USER/.config/autostart/skypeforlinux.desktop

= > файл НЕ существует!

rm -rf /home/$USER/.config/autostart/skypeforlinux.desktop

Удаляет автозапуск, но этот файл создается после изменений снова!

Поэтому лучше изменить код, чем удалить этот файл:

/home/$USER/.config/autostart/skypeforlinux.desktop

Автозапуск: X-GNOME-автозапуск с поддержкой = True

НЕТ Автозапуск: X-GNOME-автозапуск с поддержкой = ложь

sed -i 's/X-GNOME-Autostart-enabled=true/X-GNOME-Autostart-enabled=false/g' $HOME/.config/autostart/skypeforlinux.desktop

2. Начало Skype в фоновом режиме

True

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized": правда

ложь

/home/$USER/.config/skypeforlinux/settings.json

"app.launchMinimized" ложь

3. Skype работает в фоновом режиме

True

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning": правда

ложь

/home/$USER/.config/skypeforlinux/settings.json

"app.onCloseKeepRunning" ложь

Протестировано с помощью

  • skypeforlinux 8.18.0.6 amd64
  • Ubuntu 16.04.1 LTS
  • Cinnamon
ответ дан Werner Nöbauer 09.04.2018 в 12:47