Устранение неполадки при установке 14.04.1 LTS [дубликат]

2

Я пытаюсь установить VM Player на Ubuntu 14.04.1 LTS.

Я видел потоки для более ранних версий Ubuntu, которые говорят сначала установить заголовки build-essential и linux. Похоже, что заголовки linux уже являются самой новой версией. Однако build-essential не будет устанавливать для меня.

sudo apt-get install build-essential

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package build-essential

Что-то мне здесь не хватает? Заранее благодарю вас за помощь.

    
задан JoeC 07.09.2014 в 00:13
источник

2 ответа

10

build-essential доступен на основном хранилище для 14.04 . Поэтому сначала включите репозиторий.

  

Компонент main содержит приложения, которые являются свободным программным обеспечением, может свободно перераспределяться и полностью поддерживаться командой Ubuntu. & Амп; Компонент юниверс - это моментальный снимок свободного, открытого источника и мира Linux.

Вы можете включить Main & amp; Репозиторий Universe по следующей команде:

sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe"

Затем установите пакет, выполнив следующую команду в терминале:

sudo apt-get update
sudo apt-get install build-essential.
    
ответ дан Pandya 07.09.2014 в 07:07
источник
1

Попробуйте запустить эти команды в терминале один за другим:

sudo dpkg --configure -a
sudo apt-get -f install
sudo apt-get --fix-missing install
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install build-essential
sudo apt-get clean
sudo apt-get autoremove
    
ответ дан mixerowsky 07.09.2014 в 00:24