Steam не откроется в Ubuntu 15.10

19

Пробовал снова и снова, но ничего не происходит. Попробовал переустановить Steam вместе с Ubuntu, но ничего не сделал. Пробовал другие форумы с полезными советами, но ничего хорошего. У меня заканчиваются идеи, и я не знаю, что еще я могу сделать. Может кто-то, пожалуйста, помогите мне, прежде чем я начну вытягивать волосы? Я сошел с ума.

    
задан Travis Toompas 25.10.2015 в 07:43
источник

2 ответа

27

На основе этого вопроса выполните следующие команды:

mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}
mv ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}

Идея состоит в том, что Steam использует свои собственные динамические библиотеки, но Ubuntu поставляется с некоторыми новыми или что-то в этом роде, любым способом, с которым он работает!

ПРИМЕЧАНИЕ. Если вы просто устанавливаете Steam в первый раз, вам нужно будет запустить команды второй раз после первоначального обновления. Это займет время!

UPDATE:

Если вы используете 16.10, ребята из Ubuntu предоставили модифицированный установщик, который позаботится об этих проблемах. Я бы рекомендовал установить Steam из репозиториев Ubuntu

    
ответ дан Dan 26.10.2015 в 19:42
3

Основываясь на ответе Даниэля (у меня нет комментариев для комментариев!), на ванильном ubuntu-gnome 15.10, где я сделал «apt-get install steam», мне пришлось запускать эти измененные команды:

mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6{,.disable}
mv ~/.steam/steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1{,.disable}

Итак, просто изменив .local / share, которого нет в моей системе

    
ответ дан Henri Cook 12.11.2015 в 22:57