Цифровая клавиатура не работает

20

Я запускаю Ubuntu 10.04, полностью обновленный, с внешнего жесткого диска USB. Все работает очень хорошо, кроме клавиатуры. Цифровая клавиатура не работает. Клавиши ничего не делают, с NumLock или без него.

Настройки клавиатуры настроены для общего ПК с 105 ключами (Intl). Сама клавиатура на этом компьютере - PS2.

Любые идеи, где искать попытку исправить это?

    
задан UrkoM 21.09.2010 в 05:16
источник

4 ответа

29

Иногда в машинах, которые я подключаю через клавиши мыши VNC, загадочно включается. Возможно, это ваша проблема.

Нажмите «Системное меню» - > Предпочтения - > Клавиатура. На вкладке Mouse Keys проверьте, что Pointer можно управлять с помощью клавиатуры отключено.

    
ответ дан Javier Rivera 21.09.2010 в 08:50
источник
13

Я отправлю еще один ответ, потому что мне потребовались годы, чтобы понять это. Похоже, что в недавних выпусках ситуация немного изменилась. На вкладке «Мышиные клавиши» не было в моих настройках клавиатуры (Ubuntu 11.10, gnome shell), поэтому решение @ JavierRivera поставило меня на правильный трек, но не решило проблему отключения «указателя управления с помощью клавиатуры», вариант. Вот где я его нашел:

Settings > Universal Access > Pointing and Clicking

Я также включил «Цифровые клавиши клавиатуры работают как с Macintosh», так как я использую клавиатуру imac. Эта опция находится в:

Settings > Keyboard Layout > Layouts > Options > Miscellaneous compatibility options

, который мне кажется нужным.

    
ответ дан Ian Hincks 06.03.2012 в 03:43
4

Для Ubuntu 12.10:

  • Нажмите «Системное меню» - > Системные настройки - > Универсальный доступ - > Точка и щелчок

  • Отключите «Мышь».

ответ дан pasdenom 08.08.2013 в 11:19
0

Если вы используете XFCE4 (например, Xubuntu):

  • Перейдите в Диспетчер настроек > Доступность > Mouse
  • Снимите флажок «Использовать эмуляцию мыши»; если он уже не установлен, сначала проверьте его, а затем снимите его (я полагаю, по какой-то причине, GUI не знает, что Numpad имитирует мышь)
ответ дан Azmisov 23.11.2016 в 19:11