Не удалось загрузить модуль «canberra-gtk-module»

22

Сегодня я установил:

  1. Ubuntu 12.04
  2. Oracle JDK 7 и 8
  3. IntelliJ 11.1.4

Я установил свой путь JAVA_HOME, чтобы указать на JDK 7.

Когда я запускаю IntelliJ, я получаю это сообщение:

Gtk-Message: Failed to load module "canberra-gtk-module"

Является ли это проблемой, или я могу это посмотреть?     

задан Harrison Brock 30.10.2012 в 00:44
источник

3 ответа

40

Я исправил это, установив модуль:

sudo apt-get install libcanberra-gtk-module

Или, если он уже установлен, и вы все равно получите ошибку:

sudo apt-get install libcanberra-gtk-module:i386
    
ответ дан Harrison Brock 30.10.2012 в 01:08
источник
1

Этот вопрос составляет 4 года и 8 месяцев. Это уже в июле 2017 года.

На Raspberry Pi 3B работает Raspbian Jessie и Ubuntu 16.04 LTS . Я получал эту ошибку.

  

Не удалось загрузить модуль «canberra-gtk-module»

Это довольно общий.

Хорошей новостью является то, что исправление легко. Просто введите:

sudo apt-get install libcanberra-gtk-module

установлен какой-то материал ...

Затем он больше не появлялся.

    
ответ дан SDsolar 20.07.2017 в 08:30
1

произошло с приложением qt5 с использованием темы gtk в Ubuntu MATE

$ ./my-application
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "topmenu-gtk-module"

Давайте найдем libs

$ locate libcanberra-gtk-module.so
/usr/lib/x86_64-linux-gnu/gtk-2.0/modules/libcanberra-gtk-module.so
/usr/lib/x86_64-linux-gnu/gtk-3.0/modules/libcanberra-gtk-module.so

настройка LD_LIBRARY_PATH решает проблему

$ LD_LIBRARY_PATH=/usr/lib/x86_64-linux-gnu/gtk-3.0/modules:$LD_LIBRARY_PATH ./my-application

или отключите переменную окружения GTK_MODULES

$ unset GTK_MODULES; ./my-application
    
ответ дан neok 08.08.2017 в 12:40