Как заставить Sublime Text 2/3 не открывать предыдущие вкладки при запуске?

19

Каждый раз, когда я открываю Sublime, эти вкладки автоматически открываются. Как это исправить. Я не могу найти никаких настроек для этого.

    
задан BigSack 25.08.2012 в 04:37
источник

3 ответа

16

Sublime Text 2

Проверьте содержимое каталога ~/.config/sublime-text-2/Settings для файла с именем Session.sublime_session

Если эти файлы включены туда, удалите их

Sublime Text 3

ST3 хранит файлы сеанса:

~/.config/sublime-text-3/Local/Session.sublime_session
    
ответ дан Adonis K. Kakoulidis 25.08.2012 в 05:00
источник
41

В Sublime Text есть лучшее решение. Выберите Preferences-> Settings - User и установите remember_open_files и hot_exit в false. Полученный файл должен выглядеть следующим образом:

{
    "remember_open_files": false,
    "hot_exit": false
}

(Все возможные настройки можно увидеть в Settings - Default .)

Просто перезапустите Sublime Text после этого (может потребоваться перезагрузка программы два раза, один раз для применения настроек), и он должен запускаться без открытых файлов.

Примечание. Я только смог проверить это с помощью Sublime Text 3, но я уверен, что эти настройки существуют и в версии 2.

    
ответ дан Adam S 15.03.2013 в 18:48
1

В Sublime Text 3 ниже работала для меня.

  

$ rm ~ / .config / sublime-text-3 / Local / Auto \ Save \   Session.sublime_session

    
ответ дан BTR Naidu 15.11.2017 в 09:15