Как исправить медленную беспроводную связь на компьютерах с беспроводными картами Intel?

21

Я просмотрел все предыдущие вопросы, но отключить управление питанием для карты Wi-Fi не получилось. Эта проблема, похоже, связана с Lenovo Thinkpads. Я перешел на Ubuntu 11.10 из Windows 7 3 дня назад, поэтому я новичок в операционной системе.

    
задан Kaine McAliece 07.04.2012 в 02:18
источник

8 ответов

20

OP Добавлено:

  • Примечание1: медленное соединение может быть связано с вашим поставщиком услуг или по любой другой причине, чтобы проверить его, попробовать ту же сеть любым другим компьютером с другой ОС или подключиться к сети с помощью кабеля. Если это быстро, это решение может вам помочь. Если нет, это может быть трата времени! *

  • Примечание2: В первой ссылке в ссылках, которые я поставил, существует множество способов решения медленного беспроводного соединения. Каждый метод решает различные возможные причины медленного соединения. Я рекомендую протестировать решение, которое я поставил здесь, прежде чем искать разные методы, потому что он, скорее всего, эффективен. *

Если вы используете Ubuntu 11.10, выполните следующие действия:

открыть терминал. Введите следующие две строки:

sudo rmmod -f iwlagn
sudo modprobe iwlagn 11n_disable=1

Теперь проверьте скорость беспроводного Интернета. Если это все еще медленно, это решение, вероятно, не является решением для вашего дела. В этом случае просто перезагрузите компьютер, чтобы вернуть сделанное изменение. Если это становится нормальным и быстрым, сделайте это навсегда, набрав в терминале следующую строку:

gksudo gedit /etc/modprobe.d/iwlagn-disable11n.conf

Файл будет открыт. В конце файла вставьте следующую строку и сохраните:

options iwlagn 11n_disable=1

После сохранения просто закройте и НАСЛАЖДАЙТЕСЬ!

Решение для Ubuntu 12.04:

открыть терминал. Введите следующие две строки:

sudo rmmod iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Теперь проверьте скорость беспроводного Интернета. Если это все еще медленно, это решение, вероятно, не является решением для вашего дела. В этом случае просто перезагрузите компьютер, чтобы вернуть сделанное изменение. Если это становится нормальным и быстрым, сделайте это навсегда, набрав в терминале следующую строку:

gksudo gedit /etc/modprobe.d/iwlwifi-disable11n.conf

Файл будет открыт. В конце файла вставьте следующую строку и сохраните:

options iwlwifi 11n_disable=1

После сохранения просто закройте и НАСЛАЖДАЙТЕСЬ!

Литература:

* Я попробовал оба решения, и они работают.

    
ответ дан Jorge Castro 05.05.2012 в 01:03
10

Я решил это для себя, используя инструкции здесь .

в терминале, напишите:

echo "options iwlagn 11n_disable=1" | sudo tee /etc/modprobe.d/iwlagn.conf
sudo modprobe -rfv iwlagn
sudo modprobe iwlagn

За 12.04 и новее: измените options iwlagn 11n_disable=1 на options iwlwifi 11n_disable=1

    
ответ дан eskararriba 11.04.2012 в 03:14
4

В течение 12.04 измените:

options iwlagn 11n_disable=1

To:

options iwlwifi 11n_disable=1
    
ответ дан eskararriba 30.04.2012 в 20:52
3

Эта ошибка влияет на мой ноутбук с Centrino Ultimate-N 6300. Единственное, что помогло, это включить параметр swcrypto. Теперь мой /etc/modprobe.d/iwlwifi.conf выглядит следующим образом:

options iwlwifi 11n_disable=1 led_mode=1 swcrypto=1

И я могу использовать Wi-Fi без проблем. Однако тот факт, что n-сети не могут использоваться, остается раздражающим.

    
ответ дан Karl Frisk 02.08.2012 в 00:07
2

Эти команды помогли и сработали для меня, Kubuntu 15.10 (хитрый), My Intel Wifi Adapter (корпорация Intel Centrino Wireless-N 1000), по большей части, полностью ускорялся от обхода (скорость улитки):

echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlagn.conf
echo options iwlwifi 11n_disable=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

У меня было так много трудностей сперва найти это, я надеюсь, что это помогает кому-то там, сначала было так медленно, когда я установил Linux (Kubuntu), это сводило меня с ума:)

    
ответ дан David V. 04.11.2015 в 03:48
1

Я выполнил последние инструкции в этот пост .

Он решил проблему на моем Shuttle XS35 (Atom D510) с Ubuntu 12.04 с голодающей скоростью 0,91 Мбит / с до 8,74 Мбит / с (быстрее на 9 раз).

    
ответ дан cblanquer 27.06.2012 в 09:57
1

Откройте терминал ( Alt + Ctrl + T ) и введите:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=1

Теперь проверьте, улучшились ли скорости. Если да, сделайте его постоянным.

  1. Откройте /etc/modprobe.d/iwlwifi_disable11n.conf в качестве суперпользователя, например. г:.

    gksudo gedit /etc/modprobe.d/iwlwifi_disable11n.conf
    
  2. Добавьте следующую строку в конец файла:

    options iwlwifi 11n_disable=1
    
  3. После этого сохраните его и закройте!

Если вы получили сообщение об ошибке, например

ERROR: Removing 'iwlwifi': No such file or directory

замените iwlwifi на iwlagn в приведенных выше командах и повторите попытку.

    
ответ дан Mukund 20.12.2012 в 17:47
1

UPDATE: это почему-то закончилось тем, что я снова не подключался, поэтому я сделал больше исследований, вот что я нашел:

Восстановите исходные команды iwlwifi в файле iwlwif.conf (может не понадобиться восстановить исходные команды в файле iwlwifi.conf ) в /etc/modprobe.d/iwlwifi.conf и вставить эту строку в конец:

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Чтобы восстановить файл, вы можете создать новый текстовый файл в ваших документах с именем iwlwifi.conf и добавить командные строки:

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1

Затем сохраните документ и запустите консоль и введите команды

sudo cp /home/[replaceyourusernamehere]/Documents/iwlwifi.conf /etc/modprobe.d/iwlwifi.conf

После этого мой wifi начал работать быстрее, чем раньше, когда я только что ввел:

options iwlwifi 11n_disable=1

Примечание: приведенное выше просто сработало для меня, когда я скопировал файл с помощью суперпользователя. Я не делал эту часть ниже, но может работать или не работать.

Возможно, вам еще нужно запустить команды как:

echo options options iwlwifi 11n_disable=1 bt_coex_active=0 power_save=0 auto_agg=0 swcrypto=1 | sudo tee /etc/modprobe.d/iwlwifi.conf
sudo modprobe -rfv iwlwifi
sudo modprobe iwlwifi
apt-get update

Я все еще получал модуль ошибок iwlwifi использовался, когда я раньше запускал:

sudo modprobe -rfv iwlwifi.

Сообщите мне, если это работает для вас или нет в комментариях.

    
ответ дан David V. 07.11.2015 в 07:02
0

После нескольких лет неспособности использовать 801.11n на моем ноутбуке. Я нашел решение, которое действительно исправляет эту проблему! Это, по-видимому, наилучшее возможное решение, потому что вы все еще можете использовать bluetooth, а также получить доступ к сетям через 801.11n тоже без проблем (я получаю ~ 70 Мбит / с).

Введите в терминал следующие команды:

echo options iwlwifi bt_coex_active=0 swcrypto=1 11n_disable=8 | sudo tee /etc/modprobe.d/iwlwifi-disable11n.conf

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi

Вот объяснение того, что мы делаем:

  • swcrypto=1 переключает аппаратное шифрование для программного шифрования.
  • bt_coex_active=0 отключает функцию автоматической интерференции между Bluetooth и Wi-Fi - это, скорее всего, истинная причина проблем.
  • 11n_disable=8 активирует агрегацию TX AMPDU.

То, что bt_coex_active фактически делает, когда оно включено, - это, по сути, «отключение» Wi-Fi, когда система думает, что частота Bluetooth используется, но в случаях с ошибкой она предполагает, что Bluetooth всегда передает, таким образом закрывая Wi-Fi на постоянной основе.

Большинство людей предпочитают изменять файл по умолчанию /etc/modprobe.d/iwlwifi.conf , но лично я предпочитаю помещать его в отдельный файл, чтобы его можно было отменить, если потребуется. Если вы пробовали предыдущие настройки, убедитесь, что ваш файл вернулся к настройкам по умолчанию. Для справки mine (на Ubuntu 16.04):

# /etc/modprobe.d/iwlwifi.conf
# iwlwifi will dyamically load either iwldvm or iwlmvm depending on the
# microcode file installed on the system.  When removing iwlwifi, first
# remove the iwl?vm module and then iwlwifi.
remove iwlwifi \
(/sbin/lsmod | grep -o -e ^iwlmvm -e ^iwldvm -e ^iwlwifi | xargs /sbin/rmmod) \
&& /sbin/modprobe -r mac80211

Если это не работает для вас, запустите:

sudo rm /etc/modprobe.d/iwlwifi-disable11n.conf

Источники:

  • Ссылка
  • Centrino-6235-медленно замораживания

Ссылка

My Usage (ваше перемещение может варьироваться):

  • ОС: Ubuntu 16.04 (будет работать и с более новой версией!)
  • Оборудование: корпорация Intel Centrino Wireless-N 1000 [Condor Peak] (но будет работать на аналогичных моделях, например, Intel Centrino 6235!)
ответ дан hazrpg 23.05.2017 в 03:15
-2

В итоге мне пришлось переделать свою беспроводную сеть. Моя сеть имела 2,4 ГГц и 5 ГГц, используя тот же SSID. Когда я разделил их и подключился к сети 2,4 ГГц, проблемы с пропускной способностью исчезли. Поскольку сеть 5Ghz не отображается, я предполагаю, что моя карта не должна поддерживать 5Ghz, и она, должно быть, иногда пыталась подключиться к ней.

    
ответ дан AaronCampbell 30.08.2013 в 03:52